Linux user thread

So with the Version That Shall Not Be Named and That Which We Really Aren’t Discussing:

% ~/scrivener/scrivener_beta/bin ./Scrivener hildegard@volmar ./Scrivener: symbol lookup error: ./Scrivener: undefined symbol: _ZN11QWebArchive16staticMetaObjectE

Tried it in /usr/local, as well, but same error. Too late to really troubleshoot, but I don’t think it’s a dependency issue, since those say that a given library can’t be found. Then again I could be completely talking out my behind, since this isn’t the sort of programming I do.

I can confirm the exact same error. I’m on Ubuntu 10.04 running Qt 4.6.2. I’ll investigate if an upgrade to Qt 4.7 helps. Also, we’re unable to comment to the Linux announcement thread. (I know. “There are those annoying Linux beards on the Windows forum again.” :slight_smile: )

This thread is for Linux users to post progress using the new native Linux version of Scrivener. It is NOT intended to be a request for L&L to provide support. Please understand the Linux version is community supported, which means we figure out our own solutions as much as is possible. Of course, when and if Lee has time to drop by and discuss Scrivener on Linux, we’ll be glad to see him. :laughing: But Linux is NOT an L&L supported platform, and right now Lee’s incredibly busy with the Windows version. So please post your comments about the Linux version here until we have our own corner of the forum, okay?


If you missed it, here’s the thread where you can read the announcement about the Linux version, and download it:

Note that we haven’t been able to post to that thread, that’s why we have a thread here until we get something else worked out.

I tried running Linux Scrivener on a fresh install of Kubuntu 10.10 since Qt 4.7 is shipped with it by default. I got the same error message as noted in previous posts here.

If anyone has a suggestion, or a different (maybe successful?) experience with running LinScriv, please let us know. Generally speaking, it’s helpful to tell us your Linux distro, your desktop manager, and the version of Qt you’re running in addition to your results with the Scrivener installation.

We’ll get there! :smiley:

PS–if anyone needs help with the basic steps to running the binary file under Linux, let us know.

Did you extract the archive to /usr/local/LiteratureAndLatte/ and try running it from there?

or was it /usr/local/LiteraturAndLatte/? I can’t remember which one now as I’m away from work computer.


LiteraturAndLatte (without the “e” on literature) in /usr/local/LiteraturAndLatte/ as per the directions in the README. That’s where the files are, and I’m still getting the undefined symbol error.

Ok, first point to be clear on is Scrivener uses a custom Qt build, the one that comes with Linux won’t work.

The error reported indicates either it’s missing a library or is using the wrong lib. I’m guessing it’s using the libs that come with Linux rather than the ones shipped with scrivener. I’ll get back to you with more info early next week. If I get chance before I’ll post it.

Thanks for taking time to share that information. It’ll keep me from beating my head against this error until either the error or I gave in–think the error won this round! :laughing:

We’ll check this thread for updated info. In the mean time, have a good weekend. :smiley:

Oh, and by the way? I LOVE the penguin added to that Scrivener icon! Cool!


MacScriv, WinScriv, TuxScriv.


Alright, guys, i’ve made a little progress! Taking a hint from the previous posters, i have successfully loaded the included libraries and started Scrivener by doing the following:

cd /usr/local/LiteraturAndLatte
/lib/ --library-path /lib:/usr/local/LiteraturAndLatte/lib bin/Scrivener

So far, from the Tutorial provided with the Windows Version, it won’t display the PDF/Image there, as to be expected. The images in the rest of the document, though, do display appropriately, as do the tables. Full screen works.

and, if you try to load /usr/lib along with the incl. libraries, it won’t load. this is probably because I initally installed qt4.

I am using Ubuntu 10.10 Maverick, i386.

Subsequently i’ve attached the .desktop and .png files that correspond to putting Scrivener in the menu.
put the .desktop into /usr/share/applications
put the .png into /usr/share/icons
you may have to log-out and login to see it
also, you may have to update the icon cache with gtk-update-icon-cache
Scrivener (39.1 KB)

Woot! That worked. I think it would be trivial (once people have had coffee) to write a shell script to start it up. Or at least a shell alias.

Things that are definitely better: font kerning. Yeah, it’s not something I wanted to bring up with the windows version, since it was probably an issue of how wine deals with fonts.

For now, if we need to import web pages, we can do it in the windows version, and they’ll load in the linux one. Using winetricks to load quicktime improves PDF importing/viewing on the windows version. (I’m still running both, just to be safe. And frequently backing up projects.)

Okay, shell alias. (zsh at least)

alias scriv-linux='/lib/ --library-path /lib:/usr/local/LiteraturAndLatte/lib /usr/local/LiteraturAndLatte/bin/Scrivener'

Woohoo. Pasting into it from something else (like Open Office) works!

I’ve been fiddling around trying to get this working on my netbook (running Ubuntu 10.10 Maverick) and had to create symbolic links ending in .so.4 for every file in lib ending in .so.4.7.0 (e.g., has pointing to it) before I could get Scrivener to launch successfully. If anyone else is not having immediate success with /lib/ --library-path /lib:/usr/local/LiteraturAndLatte/lib bin/Scrivener, this might be worth a try.

My only problem now is that instead of a cursor, I have a blinking black rectangle that stretches from the point I’m at in the text to the end of the line. I suspect this is related to the repeated error messages I get in the terminal while running Scrivener, in a pattern of

WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

four times in a row, followed by one

(WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).

Any thoughts? I don’t know much of anything about Qt, so this is beyond my ken. I see a relevant-looking file under plugins/phonon_backend but can’t figure out anything to do with it.

Yeah, my cursor disappears, too. Haven’t found a way to get it back yet.

Phonon is for media playback within Qt, I think…Lee mentioned that mp3 playback and pdf importing isn’t going to work in the linux version, so that stands to reason. (It’ll compile pdfs, however.)

Edit: Looks like a known issue, not just us.

Ah, it makes sense I’d be getting phonon errors, then. Now to cheerfully ignore them!

I wish I had the invisible cursor problem; the black rectangle is very distracting. I’m going to keep poking to see if I can make it go away.

I can confirm,

Exec=/lib/ --library-path /lib:/usr/local/LiteraturAndLatte/lib /usr/local/LiteraturAndLatte/bin/Scrivener

did the trick.

And I must tell it works better than the wine version. Good job!

p.s. no need to extract the content of the archive in /usr/local. Just make sure to point /lib/ to the correct path, e.g.

Exec=/lib/ --library-path /lib:/home/user/Scrivetux/lib /home/user/Scrivetux/bin/Scrivener :wink:

Packaged for Ubuntu

Check changelog for more info in /usr/share/doc/scrivener-beta/changelog.gz

Its easy to install!!

$ sudo dpkg -i scrivener-beta_1.0beta-1_i386.deb

Its easy to run!!

$ scrivener-beta

Its in the menu!!

Applications -> Office -> Scrivener

Its easy to get!! … 1_i386.deb

In the beginning there was MacScrivers (Macheads) and the word was good. Then there was tumult and chaos, whence came, WinScrivers :open_mouth: Now, from the void, comes, LinScrivers. size=85[/size] Now we are one. We are whole. And the word is good. :wink:

Welcome aboard the Good Ship Scrivener, LinScriverssize=85.[/size] The world is your lobster.
Take care

Can we post “bugs” here?

I can’t resize the height of the window.