Linux user thread

Did a little digging, and it looks like the windows version of Scrivener is using aspell (there is an aspell subdirectory in the Scrivener program directory so I assume that’s what the program is using – I could be wrong). I have aspell installed in Linux (also Ubuntu 10.10, like jethomes) but I’m not getting any spelling corrections. The linux version of Scrivener uses a custom version of qt, does it also use a custom version of aspell? Do we need to tweak anything to get the local install of aspell working with Scrivener?

Good idea, but I’ve got it installed as well, and no issues.

I notice that, according to your sig, you’re running Slackware. The two of us who have had this problem so far are running (K)Ubuntu Maverick. I wonder if it’s a flaw in the way aspell is packaged for (K)Ubuntu? Maybe I should remove the package and try compiling from source…

Here’s a tangent:

I click on the download link for Scrivener for Linux and get a 404-style error. is something down? And will it be up soon?


Which version are you using? aspell --version gives: International Ispell Version 3.1.20 (but really Aspell 0.60.5)

Maybe that’s the difference?


the last post has the corrected links.


I get International Ispell version 3.1.20 (but really Aspell 0.60.6)

So there is a .1 difference, apparently.

I was not aware of a new beta! I will repackage accordingly…

OK here we go, no testing as far as all this ‘aspell’ drama is concerned, but, simply repackaged for the 1.3 beta released on the link previously revealed…

Ubuntu/DEB: scrivener-beta_1.3beta-4_i386.deb
RedHat/RPM: scrivener-beta-1.3beta-5.i386.rpm
Slackware/TGZ: scrivener-beta-1.3beta.tgz

As usual, it should put the icon in the Office section according to the FreeDesktop spec. Subsequently, you can run it from the terminal via scrivener-beta. 64bit can run it, i just don’t know all the library dependencies for it, since i don’t run a multiarch build environment…

the usual libs for running 32bit apps… ia32-libs ia32-libs-gtk lib32asound2 lib32bz2-1.0 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32v4l-0 lib32z1 libc6-i386 :wink:

Any bug fixes in this beta3?

p.s. spell check isn’t working. I have aspell 0.60.6-4

I wonder if it’s a 64bit vs 32bit thing (i.e., Spell Check works for 32 bit systems but not for 64 bit systems).

I installed the software on my Dell Vostro at work and it seems to work fine. I installed it on my Asus Laptop at home and it will not run properly. It has a display error that makes it unusable. It starts with the top of the program hidden under the launcher at the top of the screen. and if you click in the program window the top of the program jumps down to it’s proper position. The only problem is the bottom of the program window is then hidden under the bottom launcher. You can not resize the window, or close the Inspector. As long as you click in the program window it just jumps up and down under the top and bottom launcher. It’s a weird bug. I had high hopes since it works on the Dell at work. Hope the December beta corrects this issue, as I really would like to use this Software on Ubuntu. I can’t afford a Mac, and I abandoned Windows years ago as a primary OS. You guys have already done great work in the short time the software has been available to us. I know you will get is sorted out eventually. FOSS community always get it fixed in the end.

It might be. I’m running 64 bit also and have no spell checker. Doesn’t even blanch at “missspeeelled”. I’ve got the original beta installed, not the latest RPM from just above; I’ll see if that changes anything.


drgnkngt, that seems to be something that lots of people are having a problem with. I’ve tamed it somewhat by using Compiz to set the Scrivener window to a fixed position with the window title bar totally off the top of the screen, and the very top of the menu bar. This renders the menu still usable, while showing most of the status bar on the bottom.

My settings for this on the Compiz ‘Place Windows’ plugin is on the ‘Fixed Window Placement’ tab to add a rule in the ‘Windows with fixed positions’ section for “title=^Scrivener”, an x position of 0 and a y position of -10, with ‘Leave in Workarea’ left unchecked. I auto-hide my launchers, so your mileage might vary if you don’t.

Not the perfect solution, but it makes it possible to use all the available features without having to fight the window positioning constantly.


Randy, the Red Hat/Fedora RPM install runs fine on my x86_64 system without a hitch, so you might be good on the dependencies. Still no spell check, but I wasn’t expecting this install to fix that.


thats good on the dependencies… thanks everybody… from what i can tell, the standard ia32 libs that come with ubuntu64/fedora64 and so on, seem to be all thats necessary. this makes sense considering the dependencies on i386 are minimal.

on the whole FOSS community thing, there isn’t a whole lot we can do to fix major and small bugs b/c there is no source code… you can’t do a whole lot with a bunch of binaries!

I am using aptosid xfce amd64 (debian sid) and by default it has no ia32 libs installed. It took me some time to understand first time I moved from Xubuntu to aptosid why some 32bit apps didn’t worked :slight_smile: It’s a good thing (I suppose) most popular distros came with standard ia32 libs, but for the rest of Linux users who might have difficulties on running Scrivener, maybe it would be good to have a thread with a first post with all the little tricks needed to run Scrivener on one configuration or another…

hehe, thats what i was talking about, concerning the 64 bit requirements… reluctantly, i don’t know the versions, etc…, necessary to build the package for 64 bit. i know what packages are necessary, at least for ubuntu, but who knows what Fedora/Sid calls the ia32 libraries? tricky stuff!

Indeed, the Fedora equivalent for ia32-libs is glibc.i686. But I never used Fedora, so I don’t know if a

yum install glibc.i686

is enough for Fedora users.

:confused: Looks OK to Me