local links

hey,

just trying scapple and I see, that I am able to set links (cmd + L) to a pdf file.
file///localhost/…path…/file.pdf

This works great, when I export the .scap to a pdf and use the link there.

(Using the link in scapple it can’t define in which program the file should be opened. Also ponting on Preview or else dont’t work. But that’s not my main question)

As I like to Connect different mindmaps as PDF by links, I try to insert local file links to be able to use the links on another machine in the same folder also.
BUT NO LUCK.

I tried thinks like:
file:./file.pdf
[file://./file.pdf](file://./file.pdf)
file:file.pdf

Mostly trying to use the pointer for the current folder ./

Any suggestions?
Thanks!

Right, Scapple is not a file manager, so it would not be responsible for setting up which programs are used to load PDF files, or that specific PDF file. That is a job for your Mac. To set which program a PDF file should be opened with, right-click on the PDF file itself and hold down the Option key. You will see the “Open With” menu change to “Always Open With”. What you choose here will forever be the default for that PDF. To change the default for all PDFs, you need to set the system default. Hit Cmd-I with any PDF selected, reveal the “Open With” section if necessary, select the program you prefer, and then click the “Change All…” button.

Okay as for the second question, it looks like you are trying to set a relative path, using the file:// URI protocol, which only accepts absolute paths. There is no way to do what you are trying to do with file system links. Scapple just uses the system for this.

What you need to do, when working in an environment that requires absolute links (and that goes for PDF too), is make sure the absolute path is the same on all systems. Locating resources on an external drive (which will always be identified the same way no matter where you plug it in), or at the very least, a DMG that is shared between machines with Dropbox or something, will suffice.

Thanks! “relative Path” was the term I was looking for.
Ok, will find a Workaround.


Well, yes, that was known and set. But I am still not shure where the difference is:
Given, I use the absolute path to the pdf file, just see the differences:

  • When I export the mindmap as a pdf: Links to the pdf file(s) are working.
  • When I use the Link “out of a scapple mindmap” it asks me to define a program to open the pdf file. (It names and locates the corresponding file correct!)
    And even when I choose a program within the Failure-Dialog, the window disappears after hitting “return” button and — nothing happens.

May (may) there is a bug within the communication between scapple and the OS?
Ok, yes, Scapple is not a File Manager, but in some Situations I would like to use scappe to directly point to the within scapple visually sorted knowledge.
:wink:

Sure, what I meant by that was that Scapple doesn’t manage files in the technical sense, and thus their associations with software or their organisation on the disk. As for the human management of files, it can be quite good at that, especially if you like to visually organise your files. :slight_smile:

So are you saying that when you click on the link in the PDF file after you have exported from Scapple, whatever program you are using to view the PDF is asking for a file viewer? There isn’t anything we can do about that. It is just a file link in the PDF, if the viewer you are using does not honour the system defaults that is something that should be reported to the makers of that viewer.

I tested this in Skim, and PDFs exported from Scapple with links to other PDF files work just fine. I click the link in Skim, and it opens the PDF in Skim (my default PDF viewer).

It is not this simple to answer.
I further tested different kind of absolute path to different files of different formats, reset the system defaults in the OS… OS is 10.9

And I ended up with the following matrix:

As we see here (on my machine) I have to add “file//” in front of the “/Volumes/…” path, (which I dropped in the scapple-link-edit-popup-window) resulting in file:///Volumes/… for the best result in .scap and in .pdf files.
Except that prewiev.app even don’t ask for a App to open if the file:///path doesn’t point to a PDF.
That`s very weird, but, ok, not at scapple’s side.

The chart leads me to one big Question: Is it possible for Scapple to automatically add the “file://” section, when I drop a file to the link-edit-window?

(Tested also with Acrobat Pro, Result is quite simillar, except that it sends the link to the browser, which itself triggers the correspondig app to open 8)

Okay, without the “file://” part it is expected that the link will fail because “/something/something.rtf” is not a valid URL. I think, from looking at your chart, that this is the underlying answer to all of the problems (save for 10.9 Preview’s bugs and Acrobat preferring to use a browser for everything :slight_smile:).

Not really, the OS provides a text string when you drop a file, and we probably shouldn’t assume that the string is a file path, it may be something else.

We do give you a little help with non-supported formats. For example if you drop an XLS file into the Scapple board itself, a new note will be created with a link pointing to that file. The software will prioritise import for formats it does support though, such as text documents, PDF and other image formats. This again goes back to it not being designed for file management—its operating assumption is that you are collecting and working with data directly on the board, not networking out to external files.