Lock Group View Mode not available (greyed out) when container is a File not a Folder

Possibly another glitch to do with using 10.6 though can’t quite see why…

When I select a file that is a container, View>Editor has the Lock Group Mode command greyed-out. The Toolbar shows Group View Mode (and it works); I just can’t lock it. If I change the file to a folder and repeat, the command becomes visible (and seems to work). Change the folder back to a file, and the lock will disappear from the Toolbar and the view is no longer locked. In fact, the view will always default to No Mode the next time I select the file in the Binder, even if the last container I selected was in a different mode (and irrespective of whether that other container was a file or folder).

Correction: the lock icon does not actually disappear from the file’s View Mode until another mode is selected or you navigate away from the file, but it is no longer a true account of the situation: the file is no longer locked. When you select another mode or return to the folder the lock will be gone.

If I then change it BACK to a folder, Lock Group View Mode is automatically reactivated, as one can see by checking out View>Editor (Lock Group View Mode is checked)*. Note though that the lock icon itself does not immediately reappear — not until a different mode is selected. This is true no matter what mode the file is in at the time it’s switched back to folder (ie. even if it is in Outline or Corkboard, not No View, and ought to show a lock).

Not an enormous problem, but it’s frustrating to have to turn containers that need View-Locking (a really valuable feature!!) into folders — being able to treat files as containers is a wonderful feature of Scrivener and now it can’t be used to the full!

Thanks for listening!

I am using a newly-acquired copy of Scrivener 2.7 (26106) on a Macbook Air running OX10.6.8 on a 2.3GHz Intel Core 2 Duo processor.

*ok, this is getting a little confusing, but the idea is the container is View-locked while a folder, then changed to a file — View-lock vanishes/stops working — and then switched back to a folder, whereupon Voila! it turns out to be View-locked all along. The setting persists through the switch to file and back again, it just isn’t expressed while it’s a file.

Ooops. I think I’ve solved my own problem (redfaced).

Preferences>Navigation has a checkbox: ‘Treat all documents with subdocuments as folders’. Ensuring that box is checked seems to do the trick!

Hope this is helpful to anyone else who has been having the same puzzle.

1 Like