Long titles that wrap in Scrivenings mode obscure the wrapped words.

When in Scrivenings mode, and while showing titles in that mode, if the title wraps to more than one line, the words that wrap to the second line are mostly obscured, as if “behind” the top of the document they belong to.

My configuration is at 125% zoom, and the font as displayed in the formatting bar, when I select the title in Scrivenings mode, appears to be “Calibri, Regular, 18”

I’m having no luck getting this to happen so far (initial testing done with an eight-line title at the maximum). There are a number of settings in Appearance: Scrivenings that might be compounding factors, could you give a run-down of those or a screenshot of the Options tab? On the Fonts tab, what are your reduction/minimum settings, and would the 18pt you observed be a product of those settings, or is 18pt the maximum?

The other thing that might be of impact is input methods. Does it only happen when typing and the line wraps? Does it only happen when the whole title arrives suddenly in that state (such as with Documents ▸ Auto-Fill ▸ Set Selected Text as Title), or partially, with some kind of text expansion utility being used within the line?

I’d try a couple of things:

  • Does navigating away from and back to the session resolve it?
  • Does the problem come up with factory default settings?
  • And lastly in a factory default Blank project?

I reproduced this problem. I couldn’t get it to happen while typing, but I did get it to happen, and switching away from Scriv and back to Scriv does not help. I can’t say this is with factory default settings, because I changed the font of Scrivening titles, and the fonts of other things.

If I then EDIT that title in Scrivenings mode, the title will scoot itself up a few pixels, allowing the lower part of the title to be seen, but the characters will be scraping the top of the editor window (or the dashed line). Mind you, I’m using 24-point text for titles. The inspector is visible. If I pull the inspector over to force the title into 3 lines, the 3rd line does not show.

If I increase the font for Scrivening titles (to 36, say), the problem shows itself much better.

Here’s a screen shot of 24 point text: drive.google.com/file/d/1FKmE7T … sp=sharing

And, having just reproduced a similar behavior (the title’s top cannot now be seen; it’s hidden by the edge of the Scrivenings window) with a factory default brand new project, with only the font for Scrivenings titles modified, yes, it happens with factory default settings.

Second screenshot: drive.google.com/open?id=19wEsE … nBJ8kSuV6W

For me, after rebooting my computer for a windows 7 update, the problem has become erratic. Now the Scrivenings titles are failing to obey the zoom level sometimes, and at others, are beyond huge…

To try and recreate the problem, I deleted my copy of the tutorial and loaded a fresh copy. Then I loaded a container in Scrivenings mode, with the “Show Titles” setting on. The titles appeared to be in Segoe UI, 12pt. Zooming to 800% left them at a relatively small size, where the same exact font in the body of the document is huge in comparison. (Side issue: At 800% zoom, even loading just the “Get it Out There” folder in Scrivenings mode takes close to 30 seconds to render).

Then I changed to 200%, and now the titles are too tall to display a single row of text. Reducing to 100% zoom, the titles remain too large to display.

Exiting Scrivenings mode resets the problem, and now the problem’s back to the titles being small in comparison to the document text when zoomed to anything > 100%.

Edit: I tried going to File-Settings and resetting everything to default. No change in behavior. However, it appears that I can sort of reset things/reproduce the problem if, while in Scrivenings mode, I click on a single document in the binder, and then click on the container again to go back to Scrivenings mode. At that point, the titles seem to adopt the current zoom level, which they retain if I switch to another zoom level–until I click a single document and then re-enter Scrivenings mode again,.