Lookin' and Likin'

I have the autocorrect enabled, which I love. But some of my characters have accents and say things like lookin’, likin’, bein’, robbin’, etc. where they leave off the ending G. Problem is Scrivener autocorrects it. I can take the word and have it Learn Spelling, but there are hundreds of words that can be abbreviated like this.

Is there some way to make sure it doesn’t autocorrect words like this? If not, feature request! :slight_smile:

Thanks for the feedback. We don’t actually have anything to do with the spell checker or the auto-correction that can be enabled on top of it. That is all Mac stuff, you should be seeing the same behaviour in TextEdit, Mail and other programs that use the native text editor. I have limited knowledge of how this stuff works in practice (I’m not a big fan of the computer changin’ what I typed so I never use them save for isolated testing), but you might find some tips on the Web for better ways of using this.

Specifically on that point, you can edit the learned words file, it is in ~/Library/Spelling. This is just a plain-text file with one word per line. So you could insert bulk words to this file and then reload Scrivener.

You can turn off auto-correct by going to the Preferences (Scrivener > Preferences) and turning off “Correct spellings as you type” in the Corrections pane. Auto-correct drives me barmy, generally, but it’s enabled by default given that it is what most Mac users have come to expect.