Losing formatting when changing fonts?

Sometimes I like to change the font of a chapter to make it uniform - for aesthetics’ sake - after I’ve cut and pasted in material from elsewhere and it’s got rather bitty (different fonts and different point sizes). However, when I do this by selecting all the text and then changing the font I lose italics and bold. I guess this is probably because I’m doing something wrong. Guidance appreciated!

Are you changing to a font that doesn’t have italic or bold?

You can also use “paste and match style” so your newly pasted things match what’s already there. You can re-map your shortcuts for scrivener in system preferences > keyboard and mouse > keyboard shortcuts so that the regular paste keyboard shortcut maps to paste and match style. The procedure has been posted on the forums a couple of times. Here’s one.

Even better, I just checked the Scrivener wiki, and it has a page for this already: How to assign or change keyboard shortcuts in Scrivener

As Janra points out, the most likely reason is that the font you are using does not support italics or bold - not all fonts do (for instance, Lucida Grande). In the font panel, check the font you are using has an italic and bold variant (when you select the font on the left, the variants appear in the box on the right of the font list).

I take on board Janra’s point about creating this shortcut, but the answer to the other question is that I am switching to a font that has italics, bold, etc.

I can make a change where everything in the amended font is in italics or bold; the problem is that when I change font - say from TNR to Garamond - the local use of italics (and bold) disappears. So, for instance, I might have written a para not in italics which includes the titles of several books, italicized, and one or two non-English words, also italicized. When I switch font the italics are lost.

To which I should add:

In future I can use “Paste and match style” (mea culpa - I hadn’t spotted that option), but what can I do to standardize fonts without losing italics etc. within the 47 chapters I’ve already written, which seem for a variety of reasons to be in about six different fonts?

Select the documents in the binder. Go to Documents > Convert > Formatting to Default Text Style.
If you have any lists and such they may end up looking strange, but bold and italic text shouldn’t be affected.
EDIT: At least it doesn’t harm my italics, but you may want to try it on a single document before wreaking havoc on your whole draft.

All that command does is reset everything according to the preferences in Editing. So: Margin points, tab stops; line spacing and paragraph spacing; indentation; font family; and font size will all be forced upon the document. Things like block quotes, lists, centred titled, fine print, and so forth will be lost. Everything else like emphasis, underscoring, colour, tables, and so on should be fine. One should always make sure to use the “Backup Project To…” command prior if they rely on RTF for a lot of information relating to function.

Insignia’s suggestion worked (so thank you!), but I take the point about the risk of losing complex formatting.

I’m still having problems with the same issue. When I use “Paste and Match Style,” I lose italics marking book titles and the like. When I use “convert document to default text style,” I lose block quotations, centering, etc. Is it possible that there’s no way to change the base font of a paragraph without losing all the internal italics, bold, underlining, etc.?

Thanks for any light anyone can shed.

Have you tried pasting it normally, then selecting the text and changing the typeface (Command-T)?

The Cmd-T method is probably the best way to manage this situation, and don’t use the “favourite fonts” section of that palette, either. Select the font and size manually.

There is a weird relationship between all of these factors. Rulers control things that look like blockquotes and centred titles, page margins, indenting and so forth. The font palette controls things like underline, bold, italic, family, and size.

Apple styles are just baked ruler and font settings (sometimes one and not the other). Even though you may have picked something called “Blockquote” from the style list, all it really did was just tweak some ruler settings and maybe font size settings. It isn’t actually a blockquote, which is why I use the phrase, “looks like”. This is important, because to the underlying text engine a blockquote is meaningless and just a ruler variation from the normal.

Using the convert to default tool will reset all rulers to the settings provided in preferences. That means losing everything that looks like a quotation and so forth. That’s because these things are not really quotations, but rather just adjustments in the ruler settings. There is no way for the conversion tool to discriminate between changes you have made specifically, Apple styles you’ve picked, and changes that were inadvertently pasted in. To the text system, they all look the same.

Paste and match style will completely obliterate any formatting, always. That is the definition of that tool. If it retained italic and bold, it would no longer be matching style.

Best workflow is to assemble your content from everywhere—use the conversion tool to fix it all at once (this will retain minor formatting like bold and italic), and then apply your preferential appearances to blocks of text like quoteblocking and centred titles.

In the meantime, if you want to fix just a portion of the document, try using the split tool to snip out the offending chunk of the document—use the conversion tool—then merge it back into the main document.

I just upgraded to 1.5, and don’t know if this is a change in the program or simply that my list of favorite fonts was cleared by the upgrade. In the past, I’ve tried making the changes using command-T, but have still lost italics, etc. But this time when I hit command-T, instead of getting a list of favorite fonts, I got a list that included both specific fonts and font families. The option to change the font family was exactly what I needed. Again, I’m not sure if this is a 1.5 change or if I just somehow missed it before–I’m a relatively new user.

Thanks to everyone for the suggestions.

I am not sure why it switched on you like that, but this ability has been there for years now. The font panel is provided by Apple, and I think they implemented the favourites feature with 10.2 or so. Anyway, that you have been using favourites all this time explains the problem as favourites store all font attributes together.