Losing paragraph identifiction in compiling for LaTeX

In writing in Scrivener I have unindented paragraphs separated by a blank line. When I compile for LaTeX all my paragraphs get run together. What do I need to do to get paragraphing to be preserved in compiling for LaTeX?


If you turn on Format/Options/Show Invisibles, do you see one or two pilcrow symbols after each paragraph? If one, then that would be the problem. MMD (and most text based formats, LaTeX included) requires a clear line in between each paragraph. Try copying and pasting out of Scrivener into a text editor to see what I mean—if there is no literal space between paragraphs, it all just kind of runs together—and both MMD and LaTeX allow you to separate lines from one another but recombine them into a single paragraph later.

If you do have an entire project typed out with no space lines between paragraphs, you could probably fix the situation easily by visiting the Text Options compile pane and turning on “Convert to plain text”, setting the drop-down to “Paragraph spacing”. You probably do not want indents interpreted to spaces as MMD takes an initial tab (or four or more spaces) in front of a line to mean “code block”. If your paragraphs all have an indent in the editor, then every paragraph would turn into a “code block” in LaTeX.

Just one.

Thanks Amber for the instructions for getting the document I’m working on into appropriate format. However, I’m curious about how I got into this situation. I have never indented paragraphs. I’ve always put a blank line between them. It has looked to me since I started using Scrivener like that was what it was doing. I’ve tried to find where is this set, but have been unable to do so. Where is it done?

Sure, the default formatting settings are in the application preference pane: Formatting. At the top of this panel is a mock editor you can use to set things up in your preferred manner. I like to turn off indents and paragraph spacing when working in MMD, so I have a literal view of the document, but if you prefer using paragraph spacing -> plain-text conversion, you’ll want to leave paragraph spacing turned on, and make sure the spacing is at least 50% of the font size. So at least 6pts using a 12pt font. The space conversion routine rounds off to the nearest whole line—so a 19pt space would insert two empty lines between each paragraph, if that make sense.

Note if you already have text formatted the way you want in a particular document, you can put your cursor in it and click the Use Current button to bring those settings into this preference area.

Thanks, Amber. I’m confused. Currently, as displayed in Scrivener, I have a blank line between paragraphs with only one pilcrow showing. Prior to checking I had assumed the blank line was achieved with double CR-LFs, which is what is needed for LaTeX to distinguish paragraphs with blank lines.

Looking at Preferences > Formatting I don’t see anywhere to turn paragraph spacing on. I am also uncertain what turning it on does. I am getting a blank line between paragraphs in Scrivener with only one CR-LF. Is that a result of having paragraph spacing turned on? Or does turning it on cause a second CR-LF to be inserted? If not, wouldn’t the way to get two CR-LFs be to turn paragraph spacing off and insert them manually myself?

If I knew where to switch paragraph spacing on and off I could figure this out by trial and error, but I have no idea where or how.


Well, I still don’t know how to turn paragraph spacing on and off, but I think I’ve figured out what’s going on. The document with which I was having a problem was a section of a larger document. After posting my last response I noticed that the other sections had two pilcrows/CR-LFs between each paragraph. Then I remembered that I had edited the problemmatic section in another editor, that in that editor I was using just one CR-LF to distinguish paragraphs, and that I overlooked that in transitioning back to Scrivener.

Still puzzled, though. In Scrivener the problemmatic section has a blank line between paragraphs, just like the sections that have two CR-LFs. How is that done? And, again, still don’t know how paragraph spacing is turned off/on or how it works/what it does.

Mystery aside, at least I know I won’t have this problem in the future.


Hi Eric,

It’s done using paragraph spacing. In rich text editors it is possible to set up “paragraph spacing before” or “paragraph spacing after”. This places padding between paragraphs. So, if you had a “paragraph spacing before” setting of 12 points, this would place 12 points of padding between each paragraph, which would look like a blank line, but would really just be a single return and rich text padding. Ioa suggested you use the “Convert to plain text” option in Compile because this converts rich text padding into real returns.

If you want to get rid of the padding, select all the text and click on the line spacing control in the format bar:

From the bottom of the menu that pops up, choose “Spacing…”. This will open the spacing panel:

As you can see in the above shot, “paragraph spacing after” is set to 14 points, so there is a 14 point gap between each paragraph, even though there is only a single line break between each.

You should change that value to 0 if you want to see the actual plain text spacing.

You should also change it in the “Formatting” pane of the preferences if you haven’t already (apologies if you’ve already said that up-thread - it’s a Saturday night so I’ve only skimmed), so that new documents you create in Scrivener don’t use such padding as you don’t want it.

Hope that helps.

All the best,

Thanks, Keith. I had no idea that “spacing” was on that drop down menu. When I checked, the line spacing multiple was set to 1 and the spacing before and after each paragraph were set to zero, so all along it’s been set to what I want. The problem arose when I edited this particular section in another editor in which I use only one carriage return and no blank lines between paragraphs. If the problem arises again I’ll know how to fix it.

Thanks again for the very clear guidance – and for pointing me to where paragraph spacing is controlled.