Losing some paragraph indents when pasting from MS Word to Scrivener (on Mac)

Hi All,

I’m using the newest version of Scrivener on a Mac.

I am trying to import my MS from Word into Scrivener. The import works fine except that after the first few paragraphs of every new chapter, Scrivener “forgets” my paragraph indents. Everything–including the first line of each new paragraph–is left aligned. The only way I can see around this is to go through the MS manually and re-indent all my paragraphs–which would take forever!

Here are the importing methods I’ve tried:

  • File → Import → Files

  • File → Import → Import and Split

  • Copying from Word and pasting in normally

  • Copying from Word and using the “Paste and Match Style” option

I had the same issue with every approach. (It also inserted extra spaces between paragraphs in each of the above approaches, but I was able to easily fix that.)

Then I tried to fix the indent issue globally using the following two approaches:

  • Select a paragraph with the correct formatting → Format → Copy Formatting → highlight a non-indented paragraph → Paste Formatting.

  • Select a paragraph with the correct formatting → Format → Make Formatting Default → highlight a non-indented paragraph → Convert → Documents → Convert → Text to Default Formatting.

None of these approaches works (I tried every possible combination of the above approaches). The issue seems to be that when I am pasting or importing my Word document into Scrivener, Scrivener isn’t recognizing all the indents (although it’s recognizing some–I have no idea why it recognizes some but not others).

Anyone here know a way around this?

Thanks in advance for the help!

The Convert menu here applies the default formatting as seen in Scrivener->Preferences->Editing->Formatting, but it applies to documents you select in the binder, not to text you select in the editor.

That should work to tidy up the paragraph indents. Plus, if there’s anything else you want to do, such as change the font/font size, paragraph spacing, line spacing, etc…

Thanks! I made sure that my Chapter 1 document in my project binder was selected, and then I went through the steps you excerpted above. Nothing happens. Is there a particular procedure I need to do to make the Convert feature work?

Below you can see what I’m seeing in Scrivener, and below that, you can see what it should look like, from Word:

Are those paragraph indents, or tabs?

In Scrivener, you can see tab characters with the View → Text Editing → Show Invisibles command. Failure to apply the default formatting suggests that there’s some sort of embedded formatting that’s taking precedence.

I have to confess I don’t know the difference between paragraph indents or tabs. When I was writing this in Word, I’d hit Enter at the end of a paragraph and it would automatically start the next paragraph .5 inches in.

If it helps, when I applied the Invisibles in Scrivener, this is what I see:

So, some of the indenting of paragraphs in your source was made by styling and some was made by typed tabs. The “indents” that survive in your paste are just those paragraphs that start with tab characters that you (presumably) typed. The one’s that come out flat, if they appear indented in Word, are indented as a matter of paragraph styling, not by dint of a typed character.

Imposing the Default Paragraph Format to docs in Scrivener is not doing what you want, presumably, because you do not have your default paragraph in Scrivener set to indent the first line of paragraphs. You can specify the features you want typical paragraphs to have by default in Scrivener by going to Scrivener Preferences > Editing > Formatting and using the controls there to make the sample paragraph there look like a typical paragraph should. Then imposing the Default Paragraph Format to docs will do as desired.

-gr

1 Like

Using a mix of tabs and indents is likely to cause problems later, as if you apply a paragraph indent (as gr explains) the paragraphs that also have tabs will end up double-indented. The Edit → Text Tidying → Strip Leading Tabs command will clean things up for you.

1 Like

Thank you both! I think I’m getting closer to the solution.

I used the “Edit → Text Tidying → Strip Leading Tabs” to strip out the tabs. That worked. Now everything–including the first lines of all paragraphs–is left aligned.

But then trying to apply default formatting to indent the first line of paragraphs is not working for me. I first tried a simple Copy Formatting and Paste Formatting. Nothing happened.

So then I tried to set my default formatting as follows:

Once that was set, I clicked on the Chapter 1 text heading within my binder (see my response to robertdguthrie earlier in the topic for a screenshot of that) and tried the “Documents → Convert → Text to Default Formatting.”

Still, nothing happened. Am I doing something wrong?

Thanks again for the help!

I figured it out! The key was changing the formatting in the Project > Project Settings > Formatting settings. For whatever reason, when I did that and then followed the steps to Convert, it worked even though the Scrivener->Preferences->Editing->Formatting approach did not work.

Thank you so much everyone for your help!

Project Settings override Scrivener > Preferences settings, so if at some point you clicked on the little box in Project Settings which says “Use different default formatting …”, then changes in your Scrivener > Preferences won’t have any effect.

So, you can either change the Project Settings, as you did, or untick that box.

:slight_smile:

Mark