Losing spaces

I am seeing single spacing between sentences in my writing. I normally use a double space to separate sentences. Does Scrivener force single spacing when compiling?

If you look in Compile > All Options > Transformations there’s a option to convert multiple spaces to single spaces. Perhaps you have this ticked?



You can also set paragraph spacing in your preferences and your compile output so that you don’t have to add the extra carriage returns at the end of each paragraph. In the menu: Scrivener->Preferences->Formatting tab, there’s symbol, two parallel horizontal lines with a double-headed arrow , and a drop-down list next to it. Change that to 2 to get double-spacing between paragraphs in your editor (for new documents). To make all your documents conform to your new preference, select them all in the binder and select Documents->Convert->Formatting to default text style.

For compiling, do the same adjustments under File-Compile-Formatting tab. Select each of the levels that correspond to where your text is (If you go by what has a check-mark under the “Text” column, you can skip others that won’t contain paragraphs of text).

Thanks for the replies …
Brookter, no I don’t have the transformation checked.

David, the paragraph idea is a good one. I’ve been a little confused by all the formatting options and overlays, and this helped.

The important thing to remember is that your compile settings can radically alter what you put down in the editor. If you prefer to write single-spaced, with initial paragraph indentations and no spaces between paragraphs, in Comic Sans at 18pt, there’s nothing to stop you. When you compile, you can change all of those things. There are many here (myself included) who write in a favorite font, line and paragraph spacing, regardless of how the final product is supposed to be formatted.

Sorry, I’m a little confused. Your initial question was about spaces between sentences, hence my suggestion.[space space]But your answer to Robert suggests it’s about spacing between paragraphs.
Have I misunderstood or do you still have a problem with spaces between sentences?



Oh :blush:
Just realized that I’m the one muddying the waters here. johnro didn’t mention anything about paragraphs. Sorry.

So… ON TOPIC: What is the output type you are using? That might be the reason you’re only seeing single spaces. For instance, HTML doesn’t usually preserve extra spaces on the output. E-books are based on html, but if you’re seeing this with output to PDF or RTF/Word, then there’s something else at work here.

The problem I’m having is within the editor (Scrivener proper) itself. I use a double space between sentences, and I have noticed during editing that I have quite a few single spaced sentences. If it were a few, I would suspect operator error, but it’s many. I also note that Scrivener has a hard time indicating spacing with italic writing.

I have used several output types: Manuscript print, e-book mobi, e-book epub. I am in the process of checking the output to see whether the single space problem is carried over to output. I will report when I know more.

A quick check of the ePub format says that the spacing oddities carry faithfully through the compile step. That’s a relief … I should be OK if I correct the problems in the editor!

Ah. May I ask why you want to preserve the double-space on the output? Unless you’re using a fixed-width font, or are trying to align things into columns, the convention seems to be leaning toward a single space after terminating punctuation. This is mostly because computers are smart enough to put an extra-wide space where you would put two, whereas the practice of hitting the spacebar [TWICE] is (debatabley ) just a holdover from the days of typewriters.

I know some people prefer to enter two spaces (I was of that habit until I learned it was okay to use just one), but I bring this up in the hopes that you don’t go to a lot of effort for what most people won’t notice. By letting Scrivener remove the double-spaces, everything can be made uniform without any extra effort.

To each his own, your mileage may vary, etc., etc…


That is a very good question since, for at least twenty years, publishers prefer you don’t bother with double-spaces at sentence breaks. It’s easily fixed, of course, but why spend the calories? :slight_smile:


At the risk of taking this thread off topic again…

…I cannot find where it is in the Compile Formatting options that I can set the spacing between paragraphs. Spacing within paragraphs (i.e. line spacing) yes. But paragraph spacing? Can someone point me there please?

In general, if you click on the spacing drop down box, one of the options is ‘other’ - that will allow you to set para spacing as well.

So, you can set it in the Editor first of all. But if you want to do it in the compilation dialogue, then go to Compilation and choose the All Options tab. Choose Formatting in the list down the left hand side. Choose the level you want to change and make sure ‘Override text and note formatting’ is set. Then click the spacing drop down, choose ‘other’ as before… the dummy text will reflect your choice.



Thanks, David! I didn’t think to look there!

It seems to me that this might be labelled a bit more clearly. Or perhaps Other should a separate button, rather than at the bottom of this pull-down menu.

It’s an Apple text engine ‘feature’ unfortunately – if you look at TextEdit, it has exactly the same issue. Once you know it’s there, it’s not a problem, of course… :wink:

The Apple text engine isn’t perfect, but it would be a daunting task for a one-person development team to rewrite it: he’s already made a lot of improvements (such as the preset format features which aren’t in the standard text engine), but I don’t know whether changes to the spacing dialogue are on his ToDo list…

Ah, I didn’t know it was built in. Hmmm, that’s an impediment, for sure. It’s interesting, then, to see how Pages handles this. There, the drop down menu for line spacing has Show More at the bottom, and selecting this opens the Inspector, with all the spacing options (character, line, before and after paragraph) laid out pretty clearly, IMHO.

Could a case be made for reworking the Compile window as an Inspector?

Pages doesn’t use Apple’s text engine! It has a lot of bespoke features that aren’t available in the default engine (and has many more developers…)

But, given that the whole ethos of Scrivener is to produce the best possible text content and structure, and leave much of the cosmetic fiddling to programs such as Word, then I’m not sure putting more effort into the WYSIWYG elements is worthwhile. (As opposed to improving the Apple engine’s unsatisfactory treatement of bullets/numbered lists, for example…)

Anyway, my opinion counts for absolutely nothing in all this, so ignore it!