Loss of italics and bold when trying to change font

If this has come up before, I apologize; I’ve been using Scrivener for a while now, but I can usually find my problem posed earlier when I search for it.

It’s a simple problem. When I attempt to select all and change a document’s font, the font gets changed–but I lose all of my italics and boldfacing when I do it in Scrivener.

If I export to .rtf, I can select text and change font within TextEdit, and maintain the italics/bold – so it’s only in Scrivener that I lose it all, even when I’m attempting to change to the same font in either application.

Help?

Questions (helpful, I hope):

  1. Exactly how, within Scrivener, are you changing the font?
  2. From what font are you changing to what font?

Mark

I am trying to change from Cochin 14 to Cochin 13, by selecting all within a document and then using the pop up font screen and switching font size. I have, however, tried switching to a different font, rather than just between sizes, and the results are the same – the font changes, but all formatting is lost.

I’m on a 15" i7, running OS 10.6.4.

Now, if I cut and paste from Scrivener to TextEdit, the same thing happens to the text – I can’t select all and change font.

It occurs to me that I wasn’t completely clear when asking the question either >.< If I export just a document, rather than compiling a manuscript, the same problem seems to occur. If I compile the manuscript, it doesn’t. When working with the compiled manuscript file, I can change the font in the entire .rtf file by doing a select all and then a font change, and it preserves the formatting.

So all I want to be able to do is change the font I’m currently working in – without losing any of the italics, bold-face or underlines.

Hello,

I can’t reproduce this problem at all (and there should be no good cause for such a thing happening, as Scrivener’s text and font handling is all done by the underlying OS X text system, exactly the same as for TextEdit with no interference from Scrivener code).

Could you please provide step-by-step instructions on how I can reproduce the problem to see it for myself?

Thanks,
Keith

Well.

Apparently, neither can I, sorry =(.

I’ve been experimenting with short manuscript exports for the better part of today – but all of those actually use underlines as emphasis, not italics. The underlines are preserved. No other formatting is, which wasn’t clear to me because otherwise, I don’t use other formats much. The italics/bold are preserved on export, even if the export induces a font change, which for some reason it sometimes does. They’re not, however, changeable in TextEdit using select all/select font either; only in Word.

It’s not, obviously, a huge thing – it’s just one of the things that sometimes jumpstarts me if I’m slowing down (changing font), and I’ve not been able to do that at all in Scrivener. Since I’ve never actually written manuscripts in TextEdit (prior to Scriv it was Word), I assumed it was Scrivener, because the emphasis characters in TextEdit – all underlines at that time – were preserved.

I’m just going to go crawl down this hole here. Don’t mind me.

Sorry again =/.

I’m having the same problem. I recently decided to do all my script work in Century OS MT Std. When I try to select something and use the formatting bar to change it to bold or italics, it doesn’t work. The underline function does. There are other fonts where I don’t seem to have this problem, but I also have it when I use Papyrus. I haven’t made an investigation to see how many fonts are affected. I use Century OS MT Std in Word for Mac as well, and I have no problem bolding or italicizing the font there.

Load up the font palette with Cmd-T, and find Century OS MT in the font browser. When you click on the font, you should see a middle column with font variants like Regular, etc. Do you see any variants for bold or italic? If not, then you can’t use this font in a strict text engine like Scrivener. Word will fake it. It will basically slant a font or add pixels to it to make it look bolder, but this is nearly 100% of the time typographically inferior to a variant that has been designed as italic or bold. It’s also a lot of work to program such a thing, so Scrivener has no capabilities of faking variants.

Ideally, you want to see something like this:

This means the font will be able to express bold and italic, as well as a combination of the two.

What’s interesting is this: Since Scrivener 2.0 came out, I’ve had no problem at all losing my italics or bold.

But I’m using the exact same font that I was, in 10.6, in version 1.5 – and unless apple has updated the font to add all the italics/bold/etc., I consistently lost all italics regardless of which font I was using, if I did a select all/change font.

(I was using Cochin primarily; it does have the different font types; it doesn’t seem to have made a difference unless the system itself has been upgraded)

… and I might as well add this. Ever since it was pointed out as a flaw in text handling, I’ve been playing with it. One thing I’ve discovered is this: I can maintain, in TextEdit, the italics and bold when I do a font change – but not if I chose a font from the “recently used” list. If I change it from a font list, and if the font follows the rules mentioned above, the characteristics are preserved. So choosing “Cochin 13” from the “recently used” menu nukes my italics/bold, even if I’m just downsizing a font size (from “Cochin 14”); going into the font list and choosing the font itself doesn’t seem to do this.

I’m wondering if that’s what’s happened in Scrivener 2.0, because I can change font and not lose the formatting now.

Umm, and I’m sorry, because a thought occurred to me and I went back to my current WIP in Scrivener, but this time I attempted to change font using a “preset” style. When I did that, it wiped all of the italics/bolding that I’d done, although the style in theory is just the font at a different size.

At this point, though, if I just use the pulldown menus in Scrivener to change font, it changes the font–but it leaves the italics/bold alone. So, are you using the TextEdit “styles”, or the “recently used” to execute the font changes?

Thanks for bringing that up, msagara. Presets in Scrivener, and Apple’s “Styles” tools are both format paintbrushes. They apply a described set of formatting rules to your text selection, and will completely obliterate anything within their scope. This last part is key. Scope means character or paragraph. In Scrivener, you can quickly tell the difference between the two with the little icon. If the preset has a little ‘a’ in it, then it will impact character settings. If it has a paragraph symbol in it, then it will wipe out ruler settings like line spacing, indents, tabs, and so on. If it has both, you get the idea.

In short, don’t ever use presets to change the font of something, unless you want a scorched earth change. Use the font family drop-down on the format bar, or the font palette.

As far as TextEdit, it’s basically the same.

When you pull up the font palette, you get this:

withouttypeface.png
Thus it’s possible to just alter the size or the font family without selecting a typeface, and provided that the family chosen supports italics or bold, that will be preserved when you change the text.

However, when you choose “recently used,” it’s like choosing a style–you’re selecting the family, typeface, and size all at once:

withtypeface.png
So in this case, even though Cochin, for example, has bold and italic, what you’re selecting is just the regular typeface and so it’s overwriting your bolds and italics in the selected text.

Same goes for Favourites by the way, picking one of those is like picking a style.