Mac Big Sur & Scrivener

Big Sur is beta, I know.
Still, attached is a screenshot of the error feedback that MacOS produces when I try to boot Scrivener. It does start as usual, but crashes the moment any content is supposed to show up. The cause seems to be a bad system call as suggested in this screenshot.
Hope this is of any assistance in getting Scrivener up and running under the new MacOS release.



Please try downloading developer beta 5 - that seems to fix this issue. (The screenshot is of a bug in Apple’s code that I could reproduce in developer beta 4 but which is now fixed in beta 5.)

Thanks and all the best,

Hi there,

running Mac OS 11beta (10A5374g). Beta. I know. However, the majority of software seemed to be not affected by what Apple is doing under the hood. Started Scrivener again after a couple of weeks of collecting new ideas in order to type them up - but the program refused to start at all. It gets aborted right away with the error message:

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘launch path not accessible’
abort() called
terminating with uncaught exception of type NSException

Can anybody help, please ? Yes, rolling back to pre-beta I can’t. Yes, time to put my thought to paper it is… No, I haven’t got a clue who else to turn on for assistance :frowning:. Please help. Thanks,


Hello. Some ideas:

  1. Is Scrivener set to reopen a project on launch? If yes, try launching Scrivener while holding down the SHIFT key (which stops the project loading).

  2. Are you using Scrivener from the App Store or from L&L direct? If from the App Store, try using the L&L version instead: … =Scrivener

  3. If you boot the Mac into safe mode, does Scrivener then launch?

  4. Tried deleting Scrivener, cold booting the Mac, and then reinstalling a fresh download of Scrivener?

  5. Is Scrivener installed in the Applications folder, or are you running it from somewhere else?

Thx for the helpful ideas. I‘ll try them and shall report back here


This is to Lo:

Here are the test results:

Option 1 - shift key during startup of program

Result: no change. Still abort with NSException error as mentioned before

Option 2 - Scrivener not from the app store

Result: Indeed, I got the program through the App Store. didn’t remember. It is 216.8 MB of size and dates back to May 29th 2020. As suggested I loaded from the L&L Web Site and installed as “keep both”. The newly installed file is 221.3 MB of size and dates back to Dec 11th 2019. The latter works… the trial version at least does. Trying to retrieve the license for the product… I worked the “retrieve license dialogue” provided by the L&L web site. It (paddle) responded that there would be no order history. This in turn appears logical to me at this point since I placed the order with Apple on the App Store.

As of now I am confident that the program downloaded would do the trick if I could enter a license. This detail, however, is not in my obvious possession. I may need to write to L&L and ask for their valued assistance with that. If worse comes to worst I will wind up buying another license, which would’t turn me into a beggar, but would put a dent into the shiny body of L&L I see at present instead.

I’m not seeing any problems launching Scrivener on Big Sur. However, the bug reported above, which I said was fixed in Big Sur beta 5? Apple has just brought it back in beta 7. :frowning: And it is definitely an Apple bug. I’m looking for a workaround, of course.

I sure hope Apple doesn’t release Big Sur too soon - right now it is one of the buggiest versions of macOS I have worked with at this stage of the game (September). Paragraph spacing controls still haven’t been hooked up properly in the standard TextKit spacing panel and page layout is a mess, to name but two of the big issues I’m waiting for Apple to solve (and trying to find workarounds for).

Right now, I strongly advise against using Big Sur with Scrivener.

All the best,

This is to KB:

Thank you very much for sharing your insight to Apple’s workings regarding Big Sur. As I am enrolled into the Beta program I understand that ways to return to pre-Beta-status have been made utterly cumbersome by Apple. Sitting in that trap I now wish I had been more content with what features an official os has had and your well meant and appreciated advice would not hang in the air like mist over water.

Maybe L&L is helping me out getting the older scrivener product operational… As of present I don’t need all bells and whistles of the product jet, except the features of collecting and arranging information. If L&L can’t help either I’ll just jot my words into individual ASCII-files and drop them into a folder in order to wait out the misery.

Thanks again for helping, folks (thumbsup)

Hello, Dieter.

Good to hear you have had some success. This page might help / you might not even need to locate your licence info (although Big Sur’s bugs might make things more difficult):

Also, you can use the direct-download version for 30 days of use during the trial period. If, for example, you only use it three days each week, the trial will last ten weeks, giving you plenty of time to get everything sorted out, I hope.


We shall see and find out. I filed a plea for help meanwhile to the L&L support… see what they come up with.


“KB” is the developer of Scrivener. His position – that Scrivener is unsupported and not recommended with Big Sur – is the final word on the subject.


That doesn’t mean we won’t try to help, though! But it does mean that we can’t guarantee to get you up and running on a beta OS. That exception is pretty weird, though - that’s the sort of thing you see when an app is trying to run something via the command-line.

Did you try Login’s suggestion of deleting Scrivener completely and re-downloading from the App Store? The error looks like it might just be a bad installation - which sounds even more likely if the trial from our web page is working for you. (If you have installed from the App Store in the past, the version on our site should recognise you as a registered user. It’s strange that’s not working for you - I’ll need to test that’s still working on Big Sur.)

All the best,