Mac-saved project won't open

I’m just testing the Windows version for the first time.
First off it was weird to me that the project is a folder and I have to open the project file inside. (I guess it’s because Windows don’t have the same bundle concept for folder like Finder has.)

But still, the first time I tried opening the project (saved on Dropbox, but I had quit the Mac app), I was told it was in use. I selected “Make a copy”, but nothing seemed to happen.
When I try to open the project now, I get nothing, not errors, dialogs or anything …

Stuff I should remember to do on the Mac before trying to open the project on Windows?

Will going back and forth most likely be a problem/be painful?
(Just got a Windows tablet.)

That’s correct, the project format looks like a folder off of a Mac because other operating systems do not have the “bundle” feature. There really is no good way around that since the project format is designed to be scalable and hold potentially gigabytes of research. You definitely would not want all of that in a single file.

The first thing to do is check and make sure there are not files marked as “conflicted” by Dropbox. If the project was initially open on the Mac and then quickly loaded on the tablet, you might have doubled-up on edits and caused some of the crucial files to get duplicated. Ordinarily that won’t cause a project to refuse to open however, but it can cause some bad problems with the binder outline getting out of sync. So it’s a good idea to always make sure Dropbox is done syncing (up or down) before opening a project or turning off the computer.

Otherwise, would this project be something you’d be willing to send in to support? I can say that ordinarily this should be working fine, so if something is specifically broken in a way that is causing cross-compatibility to break, it would be nice to know why and potentially code a solution so that it doesn’t happen again.

I did a save as a new project on the Mac and that worked. (There was conflicted copies of some files.)
If I get into trouble again, I’ll send the files to support.

My main issue with the windows version now, is scrolling – since this is on a tablet, touch screen scrolling using the finger seems to be weird, I’m selecting text without trying to, and I have trouble getting a smooth scrolling/flow through the selected texts, both in normal mode and full screen … (Maybe I can tweak something in the OS.)

Excellent, glad it was an easy fix.

I’ve never used a Windows-based tablet extensively (I played with one a while back in one of Microsoft’s stores to see how Scrivener felt on it). I do agree it can take a little acclimation to get used to it, but I’m not sure what settings there may be that can help. There probably is a setting to disable smooth scrolling though, as not everyone likes it.

Re: the not opening, make sure you don’t have multiple .scrivx files within the project .scriv folder. That can make it not open on Windows, even though it will continue to open on the Mac. Other conflicted files could do the same, but the .scrivx is the one I most often see this with.

Yes, the .scrivx file had a duplicate/conflicted copy.

Interesting. After I opened the project in Windows, the active (rtf) files I worked on have changed fonts. Would that be solved by making sure Windows gets the same fonts as my Mac? :slight_smile:

Yeah, I think so. On the Mac, the font chooser has a section for web safe fonts. If you choose amongst them, then they’ll be available on Windows and later on iOS as well. I chose Georgia for my cross-platform projects, and it seems to come across nicely.