Major problem with saving [BUG FIXED in Beta 023]

I am a Win XP user. I remember the first change to my project I made yesterday having 0.22 installed (0.21 had worked very fine until then without a single crash or bug) because it caused a crash (and another one when I tried the change - setting a couple of words bold - again). Scrivener seemed to work normally then, and I subsequently worked on my thesis for the whole day. I was quite shocked when I opened Scrivener today to find that all of yesterday’s work has been lost! I quickly found out why: Scrivener won’t save any changes I make in “Research”, even if I save manually or save it under a different file name. Even changes I make in “Draft” are lost when I re-open the programme if I had also made changes to “Research”. If I only make changes in “Draft” during a given session, then they will be saved.
It’s the same on my other Win XP machine.
I am afraid this error cost me a whole day of my PhD… :frowning:

I see some saving problems too, but can’t replicate it all the time. It’s with synopsis and sometimes it’s saved, sometimes it’s not. Could be autosave related, not sure so far.

I, too, am having problems with saving with 0.22.

Is there an issue with outline view that I missed?

If I edit text in outline view those changes are not saved, even after a manual save. Some of my synopsis notes associated with some of the outline titles are quite extensive (360 words plus) - is there a problem with word counts? I wanted to thin them down, but Scrivener is not playing ball.

I deleted a section of text in the editor & the asterisk at the top of the screen appeared & disappeared as one would expect, but when I reopened the program the deleted text was still there.

The program also now seem to have a tendency to crash, when it has not done so for me before.

I am using Windows 7 Home edition on my Acer Aspire 5738.

What you describe sounds quite similar to what I am experiencing; not only regarding the saving (see my post above) but also the tendency to crash which was not there in previous versions.

I also note that nothing happens when I use the shortcut (ctrl + s) to try and trigger a manual save.

I have done some further testing and found that the phenomenon I outlined in my first post actually has nothing to do with “Research”/“Draft”, it just appeared to be the case.
Actually, what does cause the error seems to be any changes made to the text belonging to a folder itself (i.e., not to one of the documents contained in a folder), regardless of whether the folder is part of “Research” or “Draft”. As soon as I have made any changes in the text of the folder, any changes I had made anywhere else up to that point and any future changes there and anywhere else will be lost when I restart the programme at a later stage, even if autosave appears to work, even if I save manually, even if I save under a different file name.

Oh, and the many crashes happening now all seem to be caused by the “qtgui4.dll” (at least that’s what’s listed under “ModName” in the Windows error report).

Edit: to clarify: the crashes are in no visible way connected with the saving error.

I’m running Windows Vista Home Premium and I’ve also had a problem with saving. I lost everything I wrote yesterday. I was working in the documents (not with text associated with the folders at all, just with the documents) and when I opened Scrivener today none of it had been saved. I haven’t had a problem with Scrivener crashing, just with saving.

I’m having a similar problem on XP Pro. Some of the edits I made to the text on my index cards today have saved as usual, but when I went back in to the program after a crash, I noticed that I’d lost a few of them.

I replaced the missing text and chalked it up to the crash, but after saving, exiting, and re-starting, the card info disappeared again. I’m not sure if I’ve lost any work in my main documents. I’ve been editing today, so I made a lot of small changes in various scenes. At least some of the edits saved, but I can’t remember if those were before or after I noticed the file card problem the first time.

I just made some test changes to both file card info and main text that have saved, so for me the issue seems to be inconsistent.

I experienced the same thing. I had a very productive day of writing on Saturday. I come back today excited to add on to the progress I’d made, and found that Scrivener for Windows saved nothing I wrote in my ten hours at the keyboard yesterday. Well that’s not entirely true, all my changes to the synopsis were saved, unfortunately, all the important stuff is gone. :frowning:

Having the same inconsistent problems with saving. I went in and made three small changes, two to folder text and one to a document. Only the last of them “stuck.” But the same test run again several times did not always have the same results. The only consistent thing is that it never saves correctly.
I am using Vista.
update: I don’t know if this is significant or not, but I’ve noticed that the asterisk on the top bar beside my project name, signalling that there are unsaved changes, never shows up in this new version. It’s as if it’s not recognizing that there are changes to be saved. ??

I’m not sure if this is related–but has anyone tried the Edit->Find->Project Search and used that to replace text throughout their project?

I have one project that will do the search and replace extremely fast. However, when I close and reopen the project–only my document titles have been changed. All of the document text (AND inspector data, i.e. notes, synopsis) have reverted to data before replace, as if it was never saved. (In fact, I watched the doc\files folder–nothing was getting written to disk there.)

scribbles - Yes, I reproduced that last night, on a project only 531KB, so I’m not sure it’s a project size thing after all (though I did initially get it to work properly on a fairly fresh project). I’ve also seemed to get it not replacing all the words, possibly related to a case issue and the auto-capitalization, though I haven’t pinned that down. “Ignore case” was selected but there was one instance within the main text of a document where the word wasn’t properly replaced. Still figuring out that one, and I was pretty beat so I may have just been missing something obviously User Error. Just throwing it out there in case anyone else notices and can shed some light.

Clarification–this is using Project Replace, not the normal find/replace.


I’m using Windows 7 Home Edition and am also experiencing a problem with the saving of my text after downloading the new beta. I worked on text yesterday and noticed while working that when I duplicated something, that it was not duplicating the whole text but rather an early version of the text. Then I manually saved and closed out of Scrivener but when I went to open it up again today, the earlier version was present on the pages that I originally duplicated from. I’m also thinking it’s an autosave problem as in, once it autosaves a version, it doesn’t write over it again and refuses to save the file again.

Also, for the first time with the new beta I’ve had conflict copies of my project pop up automatically. They’ve always synced up fine in the past.

Luckily for me, the major text of my project was saved outside of Scrivener before I shut my machine off. Now I just need to retype it all back in and hope it stays there. :unamused:

Wild-ass guess, but what button are you pushing when you get the pop-up about Scrivener being in beta? I’m almost always pushing “reset trial,” and haven’t had an issue with things not saving.

Running Windows XP SP1 and have had the same problem with saving to Zip ending up with a corrupt (empty) Zip file. Using the regular back up option appears to work fine.


I tried this after seeing your post, but using “reset trial” didn’t help me any, I’m still having really odd saving problems. I first noticed that index card text wasn’t saving for me, but today I’ve had trouble saving everything from formatting changes to text in my main files.

I hit ctrl+s nearly every time I make a change now, and the asterisk by the project title goes away. The asterisk often returns, though, immediately after I switch to a different document in the binder, so I ctrl+s again.

Some of my edits stick and others don’t. I’ve been continuing to play with things to see if I can find a pattern, but it’s made the program unusable for working on my project.

Also having this issue and lost all my edits today. I’ve tried everything I can and nothing works … (running Windows 7)

I lost several hours of revisions to documents in my draft today because something failed with save. I closed the program and when I reopened it all the work from my most recent session was gone. I have never had a problem with saving before and I have not been able to reproduce this loss. Like others, I suspected the autosave feature; autosave has been working so fast and reliably for me that I stopped saving manually. However, I tried to test this by making some edits, quitting the program when the asterisk disappeared (no Ctrl-S), and then reopening the file–and so far I have not lost more material. I am running Windows 7 pro 64.

For the more tech savvy users–have you guys tried watched the .scriv/Files/Doc folder and kept an eye on whether the files are saved/updated whenever you’re doing changes?

Oddly enough, since I thought to do it, I haven’t caught it not-saving, which is just typical of these sort of bugs, isn’t it?! :stuck_out_tongue:

I just thought I’d throw it out there in case it might help the collective pinpoint the source.

On this note, has anyone opened the project folder and checked the contents of the .rtf files within the Files\Docs folder there to make sure the changes are actually not saved to disk in the file and not that the .scrivx file is goofing up their display? It’s a long shot, but oddly something like this happened back in one of the first betas–the project appeared on a reopen to not have saved (despite manual saves and autosave), but doing a Windows search for the missing text called up the .rtf files and everything was there. I haven’t recreated the not-saving issue yet for 022 so I haven’t been able to check this myself.

EDIT: Actually, now my memory is kicking in, I think at the time (in the earlier beta) looking in the project folder may have shown empty/older .rtfs–something was really goofed up there. But the Windows system search did find the .rtfs. (This wasn’t my computer/project so I’m a little low on details–don’t know for sure the found .rtfs were the same ones as in the project folder and not some mystical Windows Vista backups, although there wasn’t any kind of special backup software or external drives or syncing software in the mix.) So maybe give both those methods a shot–check the .scriv\Files\Docs contents and also run a system search for unique words or phrases in the missing text and see if you find anything.