Make line spacing consistent throughout project?

I’ve been using Scrivener for years, but have recently upgraded to V3 for Windows.

I’m working on a project that contains lots of documents, and I’m struggling to format them so that they all look the same. I want to make them all one font, one line spacing. I’ve managed to sort out the font but can’t get the line spacing to work consistently throughout.

To make the font the same all the way through I set up the default font using file/options/editing/formatting. Then I highlighted all items in the binder, clicked in the editor (I think that’s right–I made it display scrivenings, then clicked on the open page), and clicked on documents/convert/text to default formatting. This has changed the font all the way through the project to TNR, which is what I wanted. But the line spacing in the project is all over the place.

When I set up the default layout I did make it double line spacing. But doing the whole convert thing does not change the spacing throughout the project. It only changes it for the paragraph I’ve clicked in.

If I hit CTRL-A to select everything, it only selects that one scene, not the entire text of the project. So that doesn’t work either.

I am sure I’m doing something wrong and missing something obvious and would really like some help here! How do I change the line spacing to double throughout the project, without having to change each and every scene individually?

Many thanks for your help.

Set up a file with all settings you want, then in options>editing>formating use formatting in current editor, click apply
Now try Documents> convert to default text formatting

1 Like

Thank you for your suggestion, but it doesn’t work. I’ve tried it several times. The text was already in the right font and size, but it’s the line spacing I need to correct to double line spacing: the files in the document that were in single line spacing are still in single line spacing.

This sounds like it might be the correct process, but I would try a different approach:

(Before doing this, I highly recommend taking a backup of your project, just in case.)

  • Set the default formatting (sounds like you did this already, but to confirm you should create a new document and double-check the formatting is exactly how you desire)
  • Click into the Binder and Expand all documents (View > Outline > Expand all)
  • Select all of the documents whose formatting you want to convert (you can select the topmost and then Ctrl-Shift-click the bottommost to select a large group)
  • Convert all selected documents to default formatting (Documents > Convert > Text to default formatting)


You should have changed line spacing in the same place.

I did set up the line spacing in the same place, but only the typeface and font size changed. The line spacing remained unchanged.

In the option panel in formatting is an option for line spacing in format bar off on right side. Try that

Please confirm: when you create new documents, is the line spacing correct?

If it’s not, then go back to the default formatting setting as @GoalieDad suggests and try setting it again.

If new documents are incorrect, then your default formatting settings are incorrect.

That’s what I’ve done, several times, but I still have inconsistent line spacing throughout the project.

Yes, new documents in the project come out with the correct line spacing. It’s just some of the older ones that still are single line spaced.

I must be doing something wrong, I just can’t figure out what!

first set default formatting, indents, line spacing, fonts etc. Then select all documents in manuscript, now go Documents>Convert>Text to default formatting and this should work. BACKUP project before try incase any issues

Did you adjust it here before converting your text to default format ?

[EDIT] Although, on second thought, that wouldn’t explain why it ain’t the same everywhere…

You may also want to check and see if you have double carriage returns here and there.

If you see you have double (or triple) carriage returns, use project replace, searching for “return-return”, and replacing them with a single return.
Run it twice if you have triple carriage returns.

Another thing : also make sure that the irregular spacing ain’t due to the paragraph’s formatting stored in one or more of the styles in use throughout your project.
(Styles override the default formatting, and would prevent it from being applied everywhere.)

Yes, it is a pain in the *** that the scrivening mode doesn’t allow to edit every documents at once under Windows.
But, if for some reason your old project inherited unwanted styles when being converted to Scrivener 3, here is how you could (moderately) quickly remove them all :

  • Select everything in the binder so that you see the whole of your project as a scrivening.

  • Then :

  • Then click “remove style”

    → That should revert the faulty paragraphs to the default format you adjusted in the options.

  • Then click anywhere in the editor to deselect text, and scroll down to the next document.

  • Click in the editor + Ctrl A

  • And repeat going down the project.
    (Don’t forget to breathe every now and then :wink: )

I’m sure @kewms or @AmberV could come up with a RegEx to make that a sneeze.

1 Like