"Manage Icons" greyed out

I tried this on several folders and documents. All of them are greyed out, whether I use context menu or documents. What should I do?

UPDATE: It is not greyed out on a new blank test project.

ANOTHER UPDATE: I accidentally closed my main project instead of the test one. So I closed the test one and re-launched Scrivener and now it is no longer greyed out. I am confused.

Usually when a setting is greyed out it means that the focus is not in part of the document that the setting would apply to.

For example, if you chose ‘copy’ from the menu but haven’t actually selected any text to apply a setting to then the ‘copy’, ‘paste’ or ‘paste and match style’ options would be greyed out.

Is the option also greyed out when you access it from Documents > Change Icon > Manage Icons… instead of the contextual menu?

Edit: ah, I just saw your updates. I’d chalk this up to some sort of glitch, because I can’t replicate a situation where Manage Icons… is greyed out. Let us know if it happens again.

I had the same issue no matter how I tried to access the manager. However, it seemed to fix itself when I copied icons into the project’s icon folder. I had to close the project and then reopen it to have it enabled. Copying and deleting the icons/pictures directly into the project’s icon folder, somewhat makes the icon manager unnecessary.

Dear community,
I don’t know how long it’s been like this, but I’ve just realized that I can’t manage custom icons anymore.
I’ve already added my own icons in my current project but now the writing “Manage Custom Icons” is grey and I can’t click on it.
Can you help me? Thanks in advance.

Pamina

I have sometimes seen this happen as well, where the command goes inactive after clicking around in a project a bit. I’ll sometimes see all of the icon previews in the menu disappear as well when that happens.

I think the trigger might be deselecting everything in the binder, and checking the menu in that condition. If you deselect and then select something without looking at the menu, it is fine, but once you look at the menu when it is fully disabled it stays locked out for the project session. Does that match what you see?

I’m not sure if I understand all you have written.

When I deselect everything almost all the available symbols in the menu are greyed out, not only “Manage Custom Icons”.

When I then select one document it’s the same as before: just “Manage Custom Icons” is greyed out, the rest can be chosen. I marked the greyed out part with an orange rectangle.


Does this answer you question? I don’t know what you mean by “without looking at the menu”. I select everything with Strg+A and I deselect everything in the menu (Edit/ Bearbeiten → Deselect All/ Auswahl aufheben).

EDIT: When I close the project and reopen it the option is no longer greyed out. But I don’t know yet how long it stays that way.

Just to be clear, what I described is how to break the menu. You should not deselect everything and then look at the menu unless you want to see the bug happen. In my testing that is what it takes to see the bug, so you can know what not to do.

Maybe there is another way to break it as well, but that is the one I spotted immediately. If you find another, please do update the thread so we can add it to the list.

1 Like