Managing documents in different languages


I’ve been spending the last hour reading this forum’s discussions on smart quotes, but I feel like it is getting more confusing by the minute. My problem is the following: I am currently writing two books, one in German, one in English, both in Scrivener. My Mac settings are set to English, as is my keyboard and the Scrivener interface. But when writing the German book, all formatting defaults to the English style, e.g., the English-language smart quotes.

As far as I can see, there is no way to change this other than switching the system language every time I switch from writing the English book to the German one, right? If I did that, all smart quotes would become German-style quotes when typing. I recently switched to the Mac from Windows and back there I could set up the document language and have it done with. There’s no option for this on OS X, right? And the problem is not really Scrivener-related either, correct? In Pages and TextEdit, I will have the same problems.

If I understood it correctly up to here, my question is: How do you recommend managing Scrivener projects written in different languages? Is there a way to automatically convert styles in a project? Can I set the language when compiling and have all smart quotes (or ordinary quotes) transformed into German smart quotes? Or is there an OS X-related solution of quickly switching between input languages without changing the UI languages?

Any help is appreciated. Thank you.

Scrivener uses the OS X language settings, so your options are pretty limited.

It is possible to set the Scrivener interface to a different language from your system language. Scrivener -> Preferences -> General. But that doesn’t help with the text editing issues.

If you switch languages frequently, I would suggest turning off all spellchecking and autoformatting features entirely while you’re writing. Then, at regular intervals or when you’re ready to compile, switch to the desired language and run the spellcheck (Edit -> Spelling and Grammar -> Check Document Now) and smart quote conversion (Format -> Convert -> Quotes to Smart Quotes) manually.


If you go to System Preferences —> Keyboard —> Input Sources, you can click the + sign below the left pane and choose to include German (Austrian, German or Swiss varieties), then turn the 'Show Input in Menu Bar’ on — that sets a flag-symbol in the menu bar giving your chosen keyboard settings. You can also set Cmd-Space to cycle through keyboard settings, though that turns it off as a shortcut for Spotlight.

Then, on the Preferences —> Keyboard —> Text pane, set Spelling to ‘Automatic by Language’ then click set up, move German up to second place behind English. It gives you instructions how to install other dictionaries if you haven’t already done so.

Have you done all that? Does that help you? Thats on System 10.9.4, by the way. You’ll have to see if it fixes things like quotation marks.

HTH :slight_smile:

Mr X

Thanks for the replies. Katherine, the spellcheck just before compiling is a good option. That would mean I don’t have to worry about such things until the very end. Mr X, I just tried changing the input sources but for me that didn’t affect the quote marks at all.

I also posted this question on a typography forum, hoping there were some people who used OS X. They had a very good piece of information: Among the many keyboard shortcuts there exist some for German quote marks.

ALT + ^ creates „
ALT + 2 creates “

There are a even shortcuts for french guillemets (ALT+Q, and ALT+Shift+Q) and even the normal english quote marks (ALT+2, and ALT+Shift+2) too. I think for now I’ll just train myself to use these shortcuts in Scrivener. While it’s not as convenient as what I was used to on a Windows PC, it seems like the best solution so far.

Anyway, thanks for the help. :smiley: