Mass changes

I imported a novel I’m working on, and this consisted of some 60 to 65 RTF files. I was finally able to figure out how to apply a consistent style over all the files, but now I’m left with ~65 RTF files with an extra blank line between each paragraph.

I’ve love to fix this all at once, but I cannot find a way to do so.

I can’t even find a way to do a find/replace of special characters like \n (newline) so that I could do “replace \n\n with \n”

Can anyone help me out?

In the search/replace dialogue, hold down alt as you hit enter to insert a new line character.
Just be careful how you search/replace so you don’t make changes you don’t want.


You can enter \n\n into the Project Replace or Find text fields - as with all OS X controls which end editing when you hit return or enter on its own, hold down the Option key while entering the newline character.

Given that Scrivener wouldn’t insert any blank lines between paragraphs, I assume that these were blank lines you had typed between paragraphs in the original RTF files. If there were no blank lines there, it may be that the blank lines are not blank lines at all but paragraph spacing, which you change by re-formatting again.

Hope that helps.

I’m new to the Macbook as well as Scrivener, so I was not aware that I could hold down ALT and press ENTER and it would do that. :slight_smile:

What’s disconcerting is that it doesn’t TELL you it’s done anything.

Anyway…it worked like a charm. Thanks!

[And yes, the blank lines between paragraphs were in the original files, which were RTF files created by yWriter5.]