MAYBE BUG -- COPY-CUT Before PASTE Operation

Version: Beta (937253) 64-bit - 26 May 2020

I would like to report what MIGHT be a bug. I know those are the worst kind, but I’ll at least post it and you all can decide.

This issue does not seem to happen to me all the time, but enough that it’s a little bit annoying, and I’ve tried different keyboards before posting with the same thing happening…

In certain instances, the COPY-CUT operation doesn’t seem to work properly, specifically the COPY part (or I suppose it could be the PASTE part later, but I’m more suspicious of the COPY).

Here is how I am aware of it… I’ll be working in a document, writing, doing my thing, and then might need to COPY a line (or a portion) before CUTTING it in order to PASTE it in again somewhere else close by in the document. Most of the time it works fine (my perception) but sometimes it doesn’t. I’ll do the COPY (CTRL-C) followed immediately by the CUT (CTRL-X) and then go to PASTE somewhere and I’ll get a BLANK (nothing to paste). If I UNDO and then go back and try it again, it works fine.

IF it’s a bug, it’s a subtle one. Not sure exactly the right steps to get it set up. But it’s happened to me (meaning I’m suddenly aware of it) too many times to just be me fat-fingering the CTRL-C/CTRL-X keys. By that I mean it’s always THIS SPECIFIC COMBINATION that is the problem. I don’t routinely experience CTRL-C or CTRL-X problems in any other situation that I’m aware of.

Of course, I could also be imagining things, so take it with a grain of salt… :slight_smile: It’s not a show-stopper by any means. It just pulls me out of my workflow unexpectedly when it happens. And Fwiw, I don’t experience this issue with any other editor in any other context, just Scrivener. And I use a wide variety of editors, plus cutting & pasting in web forms, etc. Which is one of the reasons I think it might not be my imagination.

That does indeed sound a bit weird. However, I have a question concerning the workflow: why copy and cut? Would a cut followed by a paste not achieve the same thing?

I haven’t encountered this, but I’ll start paying closer attention. :smiley:

Just out of curiosity, I wasn’t clear on why you’re doing the specific combination of COPY keystrokes before CUT keystrokes.

Is it because you’re first doing a COPY/PASTE and then following up somewhere else with a CUT/PASTE?

Or because you sometimes inadvertently press the COPY keystrokes before the CUT keystrokes?


Again, just asking because I’m curious. 8)


ETA Ha! bob.f beat me to it!

Hmm. I don’t really think this should affect the matter, but you shouldn’t need to do Ctrl+C before you do Ctrl+X: Ctrl+X (Cut) puts the material on the clipboard just the same as Ctrl+C (Copy). Nevertheless, doing that sequence shouldn’t cause the Ctrl+V (Paste) to fail. So just more a comment than a solution.

Answering both comments – Force of habit. Just got used to doing it that way. Not all (non windows) systems do a COPY before CUT. Anytime I’m about to CUT something I think I’m going to want to PASTE soon, I nearly always do the COPY-CUT sequence before PASTE.

No, I’ve waited quite a while to report this issue (if it’s an issue!) just because I did figure it was me somehow fingerboning something the wrong way-- maybe it still is. But I don’t recall this happening in the earlier version of Scrivener (whatever it was before the current v3 beta) and I don’t have this problem anywhere else in any other program. Word, LibreOffice, Google Docs, Wordpad / Notepad / Notepad++ / Wavemaker Cards / Atom / VCode / Vim / Vi / Web Forms-- sure, I probably fat fingered something but not the extent that I notice it in Scrivener v3. Maybe it’s even something as weird as timing behind the scenes…?? A big document, takes a while to copy something or whatever-- dunno, just speculating out of my ass… It’s only Scrivener v3 beta that I’ve encountered this issue.

I thinking it through, I think this is probably a legitimate bug and here’s why:

The point that DavidR made above is a good one. Regardless of whether or not I do COPY-CUT or just CUT before a PASTE operation is immaterial.


  1. The COPY operation should copy the text into the buffer.

  2. The CUT operation should also copy the text into the buffer… so what if it overwrites the buffer from the previous operation, it’s the same text… right?

WHAT I SEE when this happens is:

a. COPY - Nothing obvious, which makes sense, it's just a copy into to the buffer

b. CUT   - Text Disappears on the page, so obviously the software saw and processed the CUT operation, right?

 c. PASTE - In attempting subsequent PASTE, I get nothing, it's all blank.

So EITHER of the previous COPY/CUT operations should have grabbed the text and put it in the buffer. The fact that it ISN’T THERE TO PASTE is a real indication of a problem.

Ergo, It’s not just my imagination, or me fat-fingering anything, or else the text wouldn’t disappear from the page, right?

Also, Fwiw, I can confirm that this also happens in the Object Inspector in the notes area. It just happened to me a few minutes ago in fact. And I reiterate that I don’t have this problem in any other context with any other editor or software.

I’ve never purposefully done Ctrl-C > Ctrl-X > Ctrl-P, so can’t comment on that.

But I certainly do Ctrl-C > Ctrl-P and Ctrl-X > Ctrl-P a zillion times a day, and I don’t recall a failure.

Jwhitten, it would be interesting if you can come up with a repeatable sequence that causes this issue. If you’re on Win10, you can enable Windows Clipboard history. (Settings > System > Clipboard) It might be useful for you to take a look at that to get an insight into what might be happening or determine if you can see a pattern. Just a thought.


Tried this and can’t repeat it. Is there anything unusual about the notes? How long are they, what are they? Do they include HTML or images? How much text is on the page itself? (not sure why that would affect it, but who knows)

What else is running at the same time?

(Jimrac, RwFranz – Answering both of your posts with this reply)

Jimrac, I hadn’t thought of enabling the clip history buffer. That’s an interesting suggestion.

Even though I do a COPY-CUT–>PASTE operation, do I really? Meaning, isn’t the COPY operation superfluous? (Or technically should be). So the point that I do a COPY-CUT–>PASTE could be quaint, but theoretically, it shouldn’t be an issue.

And while I do the operations in quick succession, we’re talking about a computer that operates at incredible GHz speeds (whatever it is-- Six Cores, 16 Gigs RAM, High-End Radeon Graphics board-- the system is designed to be a gaming rig)-- the system should be dying of boredom just processing my keystrokes.

And to be fair, MOST of the time I don’t have a problem. Most of the time it works as expected. If I’m using the software all day long, it might happen to me once or twice. I only noticed it happening today in the Notes because we’ve been talking about it recently and it’s on my mind. It might have happened to me there before, but this was the first time that I consciously thought about it when it happened, and figured I’d add it to the report. And it sort of makes sense, because I suspect that you all are handling it in much the same way-- probably some common code between them there somewhere, I’m guessing.

Also, to answer RwFranz’s question, I have most often seen it in the main editor and have only just today noticed it happening in the notes section. It’s probably always been there and I was just attuned to it this time when it happened.

Also-- FWIW, I DON’T recall this happening until I started using the new v3-BETA. Maybe it did and I just didn’t notice, but it started happening enough in the Beta to get me to notice and annoy me enough to report it.

There is nothing special at all about the content I’m cutting. It usually happens when I’m moving a line or goodly portion of a line from one place to another. Not every time I do that, but that’s what I’m doing most of the time that it does occur. I know it doesn’t need to be the whole line, but I can’t recall it doing it on short stuff-- what constitutes long/short, I can’t say-- haven’t tried to track it to that level before. Just my perception of it.

It might have happened to me before when I was cutting/pasting pictures. I have occasionally had problems with that, but never associated it with this issue that I’m reporting before. So maybe it does and I just haven’t noticed.

So to be clear, the majority of my experience with this issue has been with simple text. Nothing fancy or complicated, only copying whatever format the text is in the document. Apart from the section title, I nearly always only use one font/size for text in my documents, though I do occasionally have exceptions. I can’t think of any situation where that seems to have mattered or would have been a consideration.

To the best of my recollection, I can only recall it happening when I’ve got a reasonably full document. When it happened to me with the notes section today, I had actually gone to a different document (in the same project) and copied (COPY-CUT’d) the entire set of notes, which was fairly lengthy [Much, much more than a single line-- probably 8-10 paragraphs of stuff], from the obj inspector and then returned to the first document to PASTE it into the notes of that document-- and it was blank. I had to go back to the other document, hit CTRL-Z (UNDO) to restore the notes, COPY-CUT them again and the second time it worked as expected.

EDIT: Striking the above paragraph. While it’s true what I said, I don’t think the length (amount of stuff) in the document has anything to do with it-- I think I’ve had this issue with short documents too. Though they have always been a subset of my overall manuscript which is around 55k words, whatever that works out to be in bytes someplace).

What’s running at the same time-- could be anything, ranging from nothing at all, apart from scrivener and probably Chrome opened into my mailbox or something-- to lots of chrome windows open doing facebook, youtube, tons of google tabs, etc. Might also have an image editor going, or be listening to music streaming over YouTube. I definitely do not do all of those things all of the time, so I don’t think that’s really the issue-- but it could be, so I’m answering it for completeness. Again, this system is a big, honkin gaming rig, so it’s probably causing the problem out of boredom-- just to have something to do… :slight_smile: [Obviousy I’m kidding there]

It definitely is not a show-stopper. It would not ever annoy me enough to stop using the software. It doesn’t happen often enough, but it does happen just enough for me to be pretty sure it isn’t me. I thought it was for a long time, or maybe the keyboard or something. I am using a wireless Bluetooth keyboard (though I’ve also tried it with other keyboards, including wired, and have seen it that way too).

But the thing that convinced me it was real was the fact that the text disappears after the CUT operation. That means it must have seen the CTRL-X (CUT) command and executed it. That I think is the indictment.

Hi, maybe you could check if there´s a space in the place instead the original text, years ago I had a similar issue in another program, and I found that somehow I was hitting “ctrl+space” instead “ctrl+x”.

Good thought, but I absolutely know that I am doing COPY-CUT. (CTRL-C - CTRL-X). If it happened once or twice, I might agree. But, as I’ve pointed out multiple times, I don’t have this issue anywhere else. If it was just me fat-fingering, this issue would follow me around (other editors, web text areas, etc.). Instead, I only experience it in Scrivener (and I THINK only in the v3 beta version of it. I don’t recall this being an issue in the older version, which I’m no longer using.) Plus, I’ve become attuned to the issue so when I do that operation, I have some awareness of which keys I hit. It’s a good thought, but it’s not the answer.

BUT-- That said, it does sound plausible. I wonder if there is some other way that what you said could be the case without me fat-fingering… (Keybounce or some other kind of issue-- in the program. Again, if it was me, my keyboard, or anything else on my end, I’d see it in other places, and I really don’t.)

Have you tried the troubleshooting step JimRac mentioned - turning on the Clipboard History?

I ask because I’m not seeing this issue on any of the computers I have the Scrivener 3 beta on (as others have reported too). Remember that to get to the Clipboard history you use the Windows key+V. It will give you a visual of what gets put onto the clipboard.

Turns out I already had it on but hadn’t thought to look at it. So I definitely will the next time I see it happening.

Haven’t written much today yet so haven’t encountered it thus far. Maybe I’ll go on a witch-hunt and see what I can drum up :wink:

I haven’t seen it anywhere but the Scrivener v3 Beta :slight_smile: It’s not a show-stopper, and only a minor annoyance, but I would like to figure out what’s causing it. If it’s me, I’ll cop to it. But don’t think it is. Not in any logic train I can think of. Your suggestion is the closest thing to plausible that anybody’s mentioned so far.

Okay, I have new information. Sorry, it took so long to get back, I didn’t write for a few days, and then have been writing heavily for the last several without incident. But it just happened to me a minute ago. This time I didn’t even do the COPY-CUT thing, just CUT. I highlighted a large block of text from one document (in the manuscript) and pressed CUT and went to the document I wanted to paste it into-- and nothing. It was blank.

I looked at the windows paste buffer, WIN+V, and it was blank too. Nothing there. It obviously processed the keystroke because the text disappeared from the page. But nothing in the buffer. There were other items in the buffer (WIN+V buffer review), including some stuff I had typed in previously, but nothing happened when I did the PASTE operation. Though going to the other document and doing an UNDO (CTRL-Z) restored it okay.

Can it be replicated? I.e., does the same thing happen if you cut the same block of text? If so, is there anything peculiar about that block, in terms of size or formatting or anything else? If not … well, then it sounds just random, which is no fun at all. I’m not using the beta myself, but I do read this forum (for some reason), and I don’t remember seeing another report of this. If no one else is seeing it, then it seems like something peculiar to your document(s) or setup.

No, whenever I go to do it again it generally works. I agree it seems very squirrely, which is why I wasn’t sure when I first reported it. But I don’t get this behavior in any other context. Just with this one program and at odd intervals.

No new information to report, but this issue is still happening.

I don’t have this problem with any other program, just Scrivener.