Mdate and cdate not working as they should

In projects where this has always worked, it is no longer working.

For instance, I have a novel with 574 separate documents in it. If I place ‘mdate:200d’ in the search field, I get two returns, one from 10-15-21 and another from 9-2-21. But I work on this project every day, and there have been hundreds if not thousands of modifications in those 200 days, including some just today, due to heavy revision and editing.

But I get no returns other than those two. What could be going on here? Am I doing something wrong?

It seems to not affect some projects, but it affects the three novels I am working on which are separate projects. It has always worked fine in those projects up until today while using the same computer all the way through.

The timing of this may be related to when I upgraded my M1 MacBook Pro to Monterey, or it may be related to when I up-revved Scrivener to v3.2.3.

Please help.

How many documents have you changed in the past 200 days?

hundreds just in this project

Something I would try first is clicking on the File menu, hold down the Option key, and select the “Save and Rebuild Search Indexes” command.

Thanks. Sadly, that didn’t help.

Check to make sure you haven’t inadvertently enabled any other search options.

That sounds like a reasonable idea. I don’t believe that I have, but then I don’t really know. I don’t think I know how to enable other search options. I am also pretty sure that I don’t know how to check that. It would seem to do something like that I would have to actively enable them, meaning I would have to know that that’s what I was doing, but again I really don’t know if that’s correct or not. But if it’s possible to inadvertently do that, then that is certainly on the table, but of course, inadvertently implies not knowing, which is pretty much the world I am in at the moment.

Is there a chance that you could explain this to me in a little more detail? Or point me in a particular direction?

I’ll try to see if I can find out anything about that in the manual.

Aha! I think that led to the answer. I’m not sure why excluded documents was checked and included documents was not checked. That is a selection I would never make, and certainly, I can’t recall ever making that choice.

But that’s how things were arranged in all three projects. I also assumed that anytime you made a search, that it would default to a standard selection. Or maybe there’s some sort of choice that automatically sets the options up this way in the background?

But maybe that is not the case. Maybe defaulting should be a preferences option? Or is it already a preferences option?

There is a preference of sorts, and you’re basically looking at it. The changes you make to the search tool stick until you change them. If you ever want a clean slate you can easily get that with the “Reset Search Options” command at the very bottom of the search settings menu.

Thanks. I do think this is designed properly. If certain preferences are preferred each time it would be mega annoying if they kept defaulting.

The only mystery left is how they got configured in a way that I never would have desired to configure them, which is why I was never suspecting that that is where the problem was.