"Missing Fonts" in Word Documents After Compiling

Hi there.

I’ve got a custom compile format defined for my book, which uses a mixture of Adobe Type One fonts and TrueType fonts to achieve a certain look in the document I’m generating from Scrivener. I Compile the document, and then open it in Microsoft Word 2016. It looks fine. Then I go to open it on another computer in Word 2016 . . . and the fonts aren’t there. It’s just in Helvetica. So I Compile again, then this time, I open the document in Pages instead of Word, and Pages tells me, “This document has missing fonts. Click here to show.” So I click on the warning, and Pages presents me with a dialogue box in which I can choose to "replace’ the missing fonts. I go through and I select the exact same fonts, and click Replace. Pages thinks a moment, then replaces the fonts. I click “Export to…” and choose Word. I get a .docx file. I take this .docx to my other computer, open it in Word, and voilà — there are the fonts, showing up perfectly. I only have this “font portability” problem with documents generated by Scrivener. Is there any solution to it? (Note, I am not using Styles in Scrivener, though I guess I should be. Question - if I do choose to use Styles in Scrivener, then does that mean I have to choose the “italics” style every single time I want italicized text? That seems like a pain.)


The most likely reason is that the fonts don’t exist on the other computer. If a Word doc contains a font that doesn’t exist on the computer and the font is not embedded in the .docx file, then Word will default to other fonts that are on the computer. If you want specific fonts to always display in your doc, then you should embed those fonts into the .docx. In my version of Word, “embed fonts” is under File > Options > Save.

The most likely reason is the Pages export process embeds the fonts into the .docx file. This is a complete guess on my part, as I don’t use Pages, but it would explain what you’re seeing.


JimRac’s description is probably accurate.

Note that Scrivener itself cannot embed fonts, for copyright reasons.


No. You can apply italics and bold just as you always have, and just as you can in other programs that use Styles.


I would be amenable to adding an option to embed fonts in .docx files. The third-party .docx converter that we use to create .docx files does have the option to embed fonts, but unfortunately there seems to be a bug whereby it’s not currently working. I’ve reported the issue to the company (Aspose) and they have logged it - and in my experience they fix bugs fairly quickly, within a matter of weeks. So once Aspose fixes this, I’ll add an option to embed fonts somewhere.

Thank you Keith! That’s awesome! I would SO love to have this option, as it would save me a ton of work! You’re terrific!