Missing page break between Part and Chapter

I am hoping for this structure:

Book One:
Fabulous Title for Book 1

(new page)
Chapter One:

(new page)
Chapter Two

What I’m getting is:

Book One:
Fabulous Title for Book 1 (missing page break before Chapter One)
Chapter One

(new page, as expected)
Chapter Two

The chapter layout I’ve selected shows a page break prior, and Scrivener is giving me a page break before each new chapter except the first one. It’s as though the page breaks for Book and Chapter are lumped together into one. Can I manually a command to the Part layout for a page break? Or am I doing something wrong?

I’m ever so confused.

Have you done the Tutorial, the part about Compiling? You assign different structural element types to the different levels and edit those, which require that you create a new layou scheme in the left Compile pane, preferably by duplicating an existing one. Then edit all the different settings for each level, like page break before or after, padding, font, etc.

I’ve look at the inline and video tutorials and the manual and can’t get there. Also the Extras separator project.

My chapter section layout shows a page break before a chapter. I will assume that having a page break before every chapter except the first one is expected (but confusing) behavior.

The solution would be to add a page break at the end of a Part section. I see no way to do this is the Formatting pane. (Compile/Edit Format/Section Layouts/Formatting)

In the Separators pane, there is the option to add a page break between sections, which sounds vaguely like the end of a section, but I see that my Part section layout is already set to have a page break between sections. I don’t see an option to add a page break at the end of a section. So I’m still not not understanding.

If you could point me to a page number in the Mac manual or another post on this, I’d be grateful.

The best way is probably to define a special category “Book” as structural element (I guess you already have like Chapter, Text, and a few more?) and add page break after for it. That should fix it.

… and to define strucutral elements/levels manually and not automatically by Binder structure.

If you have used Scriv 2 the special guide defining the differences is good to read.

Section 24.4 in the manual, page 621, gives a detailed explanation of separators.

I did create a section type called Book, using the Part section layout provided. I have read the section on Separators you mention.

As I said, there are only two places where one can add a Separator. Before a section and Between sections. I don’t need Before. “Between” might imply “after”, but my section layout has already has breaks in both Before and Between, but it still does not give me the desired page break.

I don’t see any way to add a section break at the End of this section layout Book/Part to deal with the odd behavior I’m seeing.

Thanks for the thoughts, however.

Did you read the part about forcing page breaks, using prefix or suffix?

What’s odd here is that you shouldn’t need anything special to get a page break after a part page. You don’t have to try to find a way to insert a second break after it, because the chapter break itself should do that. It would take additional customisation in fact to arrive at a scenario where the part title and chapter title occupy the same page.

You can see the stock behaviour demonstrated in the built-in “Paperback” compile Format. If you assign your parts to “Part Heading” and chapters to “Chapter Heading”, then it should work without any tweaking. (That Format will keep all breaks on the recto page, so you may see extra blank pages if anything.)

In fact there is just such a setting, and maybe it is already set to something, which would explain your result. The optional Override separator after setting is what you are looking for—and you would want to be checking the Separators for your parts here. If you turned that on and then left it as “Empty line” say, then it would in fact override the page break of the chapter Layout that follows it, and lead to both items being on the same page.

Case in point, this is how the default Manuscript formats work—where Parts are printed on a line above the first chapter of the part, no break between them, while chapters otherwise ordinarily break to a new page elsewhere in the manuscript, just like you describe.

All of which is to say, Scrivener can do both the thing you are describing as happening, and the thing you want. So I’d take a look at those two stock examples and see if the format you’re working on resembles Manuscript more than the former.

If the Override separator after setting is enabled, simply switch it off. Like I said above, the chapter break itself is sufficient to start a new page, so long as nothing else messing with it, like this setting.

P.S. Separators between are described on page 623:

So for that to work you need two adjacent binder items using the same Layout. Classic case of that happening are scenes, where something would be inserted between scene files, but not before them nor after them. So that setting will not work with something so disparately placed as parts.

Here’s a sample project that works as you want (I believe).

Check the “override separator” setting.

Slàinte mhòr.

Parts.pdf (51.1 KB)

Parts.zip (330 KB)

EDIT: Ioa beat me to it.

You both found my problem. My setup was identical to the sample project provided, but for whatever reason, in my project, Override Separator After was ticked in the Part section layout. Once I unticked it, I got the expected result. Yippee!

More study needed. I’m still learning to speak Scrivener, so I really appreciate the help. I send you all virtual cookies, or your vice of choice.

1 Like

Hot out of the oven and laced with generous chunks of Green & Black’s 85% dark chocolate…thank you very much indeed.

Glad it is working for you.

Slàinte mhòr.

HI, I have the same problem as Scrivtime. I am unable to see the sample project that JoRo supplied. I want a page break between Part and Chapter and I am unable to figure out a way to do that. scrivtime says "for whatever reason, in my project, Override Separator After was ticked in the Part Section layout. How do I find that. I am thinking I may also need to un-tick that.
Thank you,

If you double click the compile format you intend to compile with :
(Windows version screenshots)

…it gives you access to a lot of settings as regard to the compile. (Formatting, behavior etc.)
→ Duplicate first if prompted to do so.

Handle with care, read the manual.

If you don’t want to get into this for such a single little detail, here is a workaround:

  • Create a new document in your binder. Name it “page-break”.
  • Insert a page-break in it. (That and only that.)
  • In the metadata, assign that document to a section type that won’t get compiled with the document’s title. (The one that you used for your sub-chapters if you did split your chapters into smaller documents, for e.g.)
  • Position that “page-break” document where it is needed in the binder’s sequence.


From that point, duplicate the document if needed elsewhere.

You could also simply insert a page-break, in the editor, at the very end of your “Part” documents.
Just don’t forget you did, as these are actually invisible. (Unless you use “show invisibles” from the menu.)

In many cases (depending on the template used to create the project), the default separator for folders is a page break, hence all it takes to give a document a break is to make that document a folder.

Hmm… might work.
The first document following the “Part” documents.
Not the “Part” ones themselves. (And don’t convert them to files if they currently are folders.)