Missing text

Alright, so I have encountered an old bug- the one where if you do a manual save, it loses all your progress. Luckily I have a backup, so I’m safe, but it scared me half to death.
I did about seven pages (Scrivener autosaved all the way through), let it sit for about an hour, then saved manually and closed. When I opened Scrivener about an hour later, it had lost all of my progress from today.
I’m using beta 023 on Windows XP.

With beta 023? I thought with 023 all the saving issues of 022 were solved, but now it is the second post regarding new saving problems on 023. What’s going on?

it is 023. I don’t know, it seems to be just with manual saving (save as, ctrl + s) that it loses everything.
I tried typing something and ONLY doing autosave, and it was fine when I opened it up again, so I guess it’s the same, sorry old bug from 022.
[edit for typos]

Well, the bug from 022 also appeared even without saving manually, nobody (me included) knew how to reproduce it exactly (I suffered it, though). I don’t know what to say. After backing up properly my work, I will run some tests.

Alright, thanks much!
If the details are any help: I used the novel with parts template. I had work saved in the research section as well as the actual chapter/scene area, and in the characters folder (using the character bio template).

I’m putting a reward out on this bug as we want to squash it fast:



Question for Lee or whoever: Does Scrivener save by default when you exit, no matter if you’ve actually saved?

Reason I ask is that I deliberately made the auto save to something ridiculous like 300 seconds, wrote something, exited without saving, and the text was still there, even though I hadn’t saved. That is, I think the auto save function is still saving, even though it’s not active. If that’s the case, it might explain why people are missing text, if it saved when the text was deleted, moved, copied/pasted, etc.

Except I just tried writing something, cutting that text (ctrl-x), saving (ctrl-s), pasting (ctrl-v) then exiting without saving, and the text I’d pasted after saving was still there.

Yes. Auto-save always runs when the project is closed.

Okay, I’m onto something, I think.

I wrote some text. Didn’t save. Did a kill -9 on the PID to simulate a crash, and it didn’t save. (As expected.)

Is Scrivener crashing on exit?

Question for the people having issues with not saving

1.) What version of windows are you running?
2.) Is your account admin or? (Understand that Windows 7 is admin by default)
3.) Where are you saving your scrivener project file?
3a.) (Fiance thought of this one) What format is the drive you’re saving the project to? (NTFS, fat32, etc)

Keith has put out a reward for anyone who can reproduce this problem - I not able to at all.

Please read his post:

[url]Urgent: Reward for help with the non-saving bug]

These are all excellent questions that should be addressed if you can:

Lee :frowning:

For those seeing the save problem, it would be interesting to know if the project file that did not save had it’s time stamp updated when it was ‘saved’.