MMD and Footnotes

Hi, I’m writing for a thesis project for school and the output is going to be a Wordpress site. The plan is to learn MMD so that it is simpler to go to HTML and I’ll just have css styles ready to apply on Wordpress. I am wondering if anyone knows the best way to handle footnotes is with MMD and Scrivener. My goal is to have it work something like the attached image.

TL;DR: If Im using MMD to write blog posts with footnoted citations, and I want to have a bibliography page, should I use Scrivener’s own “Footnote” feature, the Scivener “Reference” feature, Multi-Markdown’s “Footnote” syntax, or something else entirely? Is there a way to make all footnote links point to one bibliography page?
Screen Shot 2014-02-22 at 5.34.42 AM.png

The look for footnotes will be designated by your theme’s CSS (or special CSS that you add to the WordPress theme). Adding footnotes is easy via MMD. Use this format:

As needed this website will used web-based footnotes [^This is an example footnote. Notice that it was numbered, clicking it took you to the bottom of the page. See the blue symbol? Click it to return to where you were reading.]. And now the regular writing returns. 

A nice link, with auto-numbering of footnotes, will be inserted, plus a link back in the footnotes area.

On the other hand, I’m not sure how to accomplish what you want exactly with footnotes linking to references. I assume you mean a reference “section” at the end of you blog page, not an entirely new “reference page” per se. At any rate that part is doable, but I don’t pesonally know how to pull it off.

Thanks Mitchell! That’s super helpful.

I actually in my research last night figured out how to use all the different types of footnotes:
MMD inline fns, MMD normal fns (where you put the fn pointer inside the text and put the actual fn in the bottom, and lastly the standard Scrivener footnote function.

I believe I’ll scrap the MASSIVE bibliography page idea and just have an annotated bibliography for my favorite essential references, and footnote anything that’s inconsequential.

The issue I’m still finding is that only MMD normal fns as I describe above allow me to embed a link inside of them. The Scriv fn function and the MMD inline function strip out any web links upon export. Am I doing something wrong? (Apparently according to Fletcher Penny (MMD creator) inline fns weren’t meant for links – see below.) But I’m still not sure about why Scriv strips out web links inside of fns.

TL;DR: Is there a particular way of formatting Scrivener footnotes so that they export to HTML with links included?

Screen Shot 2014-02-22 at 3.49.35 PM.png

Just to make sure we’re on the same page, Scrivener doesn’t convert hyperlinks to MultiMarkdown syntax when you compile, so if you are embedding your links without MMD syntax, they will just vanish. Everything in the editor gets converted to plain-text, with the exception of a few things Scrivener can handle, like footnotes, images, code blocks (via Preserve Formatting) and headings in the compile phase.

Hey Amber! Thanks for the reply. So I’ve done some sleuthing, and even got in touch with Fletcher Penny. As a side note, he just updated the github repo for MMD and now it allows support for the type of inline footnotes w/ links that I was attempting to do.

However, I still like the ability to use the native Scrivener footnote tool for some things. I figured out what the issue was, and I think it may have to do with plain/rich text in the footnote field. As you can see in the screenshot below, when pasting in code from a code editor, it later outputs correctly with the link, but when you just type it out, the footnote formats it and removes it for some reason. Hope this helps!


Also, as an aside, for some reason when I export to HTML, it includes an extra line on the bottom of the page. I’m having a hard time finding the corresponding setting in the compile and/or preferences section. I’ve attached an example.

I believe it has something to do with an extra

being inserted for some reason.

I think I’ve spotted the problem. If you look closely at the two different footnotes here, you’ll see one of them has a different style of quotation mark. I suspect you have typographic symbols enabled in your Corrections preferences pane. These are generally not good to have on when you’re working with any kind of code, since most parsers do not consider typographic punctuation, like curly quotes, to be valid syntax. The result is an output that will fail in most browsers.

Right now Scrivener is just dutifully reproducing what you typed. So, for this project you’ll also want to enable some of the options in the Transformation compile option pane to convert curly quotes to ASCII, and probably some of the other stuff there too. Unicode characters generally do work okay within the MMD workflow, so long as they are in a prose context and not code, such as inside an <a …> element.

Probably in the Separators compile option pane. Make sure nothing is printing a “Section break”.

You were right on all of those Ioa! Thanks a lot!