MMD in 1.1.0 Release

How do you compile MMD in the new 1.1.0 release? I’ve tried compiling to every MMD output there is but I can’t get it to work. I pick an option, say Multimarkdown to Latex. Hit the complie button and then get asked for file name and location. Once I do this it goes back to compile screen i.e. where you pick what you would like to compile to. No file is output?

I haven’t had a whole lot of time to dork with it (something about being half-braindead, since the fire, 3 cops and an ambulance got our house by mistake at 2:30 this morning), but I do know you need to have metadata filled out

In Linux, if I compile and select mmd, it goes through the motions, but doesn’t actually save anything. If I do it in Windows/WINE, it’ll make an mmd file, but it asks me about codecs beforehand.

Had a look at Fletcher Penny’s article Using MultiMarkdown with Scrivener and he says you set the metadata under the File menu, select “MultiMarkdown Settings…”. However, it doesn’t seem to be under the file menu and I can’t find it anywhere?

That’s very old information from Mac version 1.0. The meta-data settings, being more closely related to compilation, have been moved there. You need to have all compile options visible, and click on the “Meta-Data” pane with the orange suitcase tag to add keys. So, for example, click “Add key” which will provide you with most of the basic ones, select “Title” and then add the name of the work in the field to the side.

I downloaded the Scrivener manual (as a Scrivener project) as I figured that would have all the metadata set somewhere. I still can’t find it, but when I compiled it did go through the motions (unlike my project). However, it doesn’t actually save anything?

The manual project probably won’t work quite right out of the box as I always compile that from the Mac, and Mac compile settings do not carry over. Plus, I use a Meta-Data file (just a normal file in the binder with the meta-data manually typed in according to the specs) instead of the compile settings for that (since the Windows and Mac manuals each have their own meta-data). I just swap the files out as needed. Right now using a meta-data file doesn’t quite work out of the box. You’ll need to compile to plain MMD, edit the file to remove the space at the top, and then run it through MMD manually.

I’ve got that bug noted.

Of course, right now the manual won’t compile out of the Windows/Linux codebase quite the way it is intended. For one, it is still MMD2 as it was extensively written for the MMD2 workflow, and updating it would be a major overhaul which I haven’t had time for yet. It uses a custom post-processing XSLT script to cull out Mac/Win related notations based on a custom meta-data flag (amongst many other cosmetic level adjustments to the LaTeX output itself). The other problem is that the compiler does not yet have label filtering (removing items from the compile contents by label). So you would get all of the text, which is both user manuals! :slight_smile: A better test project might be MrGruff’s MMD tutorial in our forum here, as that one was written for MMD3 and I don’t believe it does anything too crazy like the manual does. You will still need to add meta-data to it though, since like I say compile settings do not cross the platform boundary yet.

Thanks AmberV. But still can’t get it to work :frowning: My binder has one document called test which looks like this -

This is a heading

This is some text

This is another heading

This is more text.

I looked at MrGruff’s MMD tutorial but the LaTeX metadata options aren’t available in my dropdown. I entered a title in metadata as you said, but it still doesn’t compile or save. Any idea what I’m doing wrong?

This sounds like a separate issue to me, since even if I don’t have meta-data set up the project still creates a file. Without meta-data, MMD is designed to treat the source file as a “snippet” rather than a “document” so that shouldn’t be messing anything up. I’ll have to check and see if it is embedded in the application or provided as an external executable in the installation folder.

Thank you AmberV. Don’t know if this is useful info or not; but no matter which MMD “Compile For:” option I choose (eg MultiMarkdown to latex (.tex)), once I hit the complie button and get to the save file dialogue, the file type selector is permanently set to *.mmd rather than the chosen export type (eg .tex).

Is the same to me.

I noticed that bug as well (on Windows). The output actually ends up okay (.tex), so the selection is misleading. Can you do a plain .mmd compile for that matter? If you don’t choose any of the formatted outputs, just regular “MultiMarkdown”, the export should be strictly Compiler code and no external code. I’m just curious if that works. If it does not, it might explain where the problem is.

Hi. No that doesn’t work either. I pick Multimarkdown (.mmd). Hit the complie button and then get asked for a file name and location. Once I do this it goes back to compile screen (i.e. where you pick what you would like to compile to). Nothing is complied (no ok button pops up) and the file is not saved.

Thanks again AmberV

Interesting, okay that steps the problem back up into Scrivener’s code and should make it considerably easier to locate. Thanks!

Yep. Got this one, too, for what it’s worth. Works fine with Windows/WINE.

Are you one of the Scrivener software engineers AmberV? From your answer it sounds like you are?

Just been reading Mr Gruff’s tutorial again and I’ve spotted some things other that are not working in this beta. I don’t know if they are just not implemented yet, or if this is helpful information while you’re tracing the current problem. But I thought I’d tell you just in case it helps while you’re looking through the code (if you are one of the developers).

In the formatting pane of the compile dialogue, the level settings don’t show # Title #, just Title (i.e. no # signs around Title) when the title check box is clicked.

Also, according to Mr Gruff’s tutorial, there are a number of keys that need to be added to the Metadata in the compile option pane for LaTeX output which are not available in the drop down. These are Latex mode, Latex input, and Latex footer.

Hope this is useful. Thanks AmberV.

I’m not a part of the development team, but am working for L&L with about fifty hats to wear. :slight_smile:

I know the feeling of wearing many hats! lol. Do I need to report the bugs somewhere else or is that one of your hats!? :slight_smile:

There isn’t really a good place for posting Linux specific bugs yet, given that it isn’t officially supported and all that. I try to keep an eye out for game breaking stuff like this, though, so this sub-forum is fine.