MMD - Linebreaks


I know that the topic has already been adressed in the forum, but I simply do not get it sorted. Here is the issue:

I am writing my References manually, and when listing them I want to force a line break after one reference with the next reference starting without an indent. I realized that MMD Exports removes the linebreaks (or does not interpret them) so I added a
command. But this leads to an indent in the next line.

I did not understand the thing with two spaces and softbreak at all.

Would be great if someone could help me out.

Thanks a lot


To insert a force return without a new paragraph, you need only add two spaces to the end of the line, like so:[code]Line one__
Line two__
Line three

Next paragraph[/code]Where spaces are rendered as ‘’ for visual aid. In the actual file these '’ would just be ordinary spaces.

Thanks. Works for the line break. However I am not able to insert a blink line with this. I tried


But it does only return:

“New Paragraph” Text

Is there any way to create

“Blank Line - no new paragraph”



This is technically a Markdown, not a MultiMarkdown issue, but I do not believe it is possible to create a blank line that is not a line between paragraphs.

It sounds like what you need to do is just define a style for your references that does not indent new paragraphs.

This is sort of related. I’m trying to export a document using multimarkdown . I want a blank line between paragraphs. I have entered two spaces at the end of the last line of the paragraph. The trouble hits when I open the tex document in TexShop and convert to pdf. It just indents the first word of the new paragraph. I tried messing around with the LaTex code (uncommenting the %\usepackage[parfill]{parskip} line but then I get an error saying that parskip has already been given option []. Anyways, any help would be greatly appreciated. An example of what I want:

Here is some text. Part of paragraph one. Approaching paragraph. Need to fill in some more words to make it wrap.

Now we are at the new paragraph… yadda yadda yadda.


I am not sure why you are getting an error when you uncomment the parskip package use line. That part works fine for me. I also had to do a search and replace to remove all instances of: \setlength{\parindent}{1em}

After making those two changes, I was getting clean renders with space instead of indents between paragraphs. Which class are you using, just the default memoir?

I got the error in the default memoir class as well as the 6x9book class. I tried deleting the


As well but may have missed some. I’ll try a search and replace and see if that works.


I still get the same error after trying this with 6x9book but now there are no indentions before the paragraphs but no spaces either. Very strange.

Here’s the entire error message with the help from TexShop:

[code]! LaTeX Error: Option clash for package parskip.

See the LaTeX manual or LaTeX Companion for explanation.
Type H for immediate help.


? h
The package parskip has already been loaded with options:
There has now been an attempt to load it with options
Adding the global options:
to your \documentclass declaration may fix this.
Try typing to proceed.
? [/code]

Dumb question: But I’m assuming you’ve already done a full seach for “parskip” and there is only one line addressing that stylesheet?

I get a clean run (one exception: A minor warning about printglossary which does not matter) with the 6x9book.xslt, too. The only thing I can think of is that you have an old version of the memoir class. Some distributions of LaTeX (even fairly recent ones) ship with a really old version. You might try updating that class manually.

Any pointers on how to update the class? I’m using the MacTex2007 distribution for what that’s worth. I appreciate the help.

Ok, I just updated folowing the direction here:

Everything still works as it should but I still get the same error when uncommenting parskip option.

I am going to guess that your LaTeX document has something that is incorrectly coded.

Try doing the following:

  1. Comment out the \usepackage[…]{parskip} line (if it exists)
  2. Search for and comment out ALL \setlength{\parskip}{…} lines throughout the entire document
  3. Add the following TWO lines (just before the \begin{document} line)


You can adjust the “2ex” value up or down (including in decimal values such as 1.75ex) until you find the paragraph skip size you prefer.

Once you get this to work, you can go back and uncomment any \setlength{\parskip}{…} lines where you may want to have paragraphs spaced at some distance other than what you set globally (in the preamble). Remember though, the change can sometimes apply from that point forward throughout the rest of the document, so you might have to “reset” your paragraph spacing with a new \setlength{\parskip}{2ex} when you want to return to double spacing.


(if this does not work, please post a minimal example of the LaTeX coding that does not work and I will troubleshoot it further)

Ok. That worked like a charm. Thank you! Is there a way to change this globally for the xlst file?

The xlst file is within the Scrivener package contents. Whether it can be changed, whether you can change it, and finally how you should change it are outside my realm of expertise.

Alternatively, you can create an AppleScript for TextWrangler (free), BBEdit (the non-free alternative to TextWrangler) or TextMate (a different alternative) that will comment out/strip the undesired commands and insert your desired commands before typesetting (TexShop does not have scripting abilities for this). This I can help with if you have an interest.

You can indeed change the XSLT files, but the recommended method is to install your own version of MMD and change the files in that copy. Scrivener will preferentially use that if it’s available, including the XSLT files in your ~/Library folder; it carries its own version around for people who don’t have MMD installed.

Thanks. I edited the XSLT in my own installation of MMD though I would be interested in the Applescript for use with TextMate, Jeffrey. I’m not an expert scripter but I do have some experience with shell scripts and Ruby but may need a bit of handholding to get the idea.

I will be glad to pass on the scripts once I get a copy of TextMate installed and some further testing carried through. This is likely to happen over the next few weeks.

In the meantime, look at the GREP find/replace features of TextMate. Using the TextWrangler syntax, you want to search for something like (\usepackage[.+]{parskip}) to replace with %\1, (\setlength{\parskip}{[.+]}) to replace with %\1, and (\begin{document}) to replace with \setlength{\parskip}{2ex}\r\setlength{parindent}{0pt}\r\1. If you can find the equivalent GREP find/replace commands within TextMate and see that it works manually, you’ll have the starting codes for what will be used within AppleScript.

Perhaps I am missing the bigger picture of what you are trying to do here, but why use AppleScript for this? TextMate has a built-in macro recording that would be perfect for a simple sequenced search and replace task like this. You can save the Macro into a custom bundle, even give it a keyboard shortcut.

I hadn’t thought of that. I’m going to give that a try and see how it works. Thanks!

I was using TextWrangler, which does not have support for this. Sounds like TextMate can be a better choice. The only other difference is, TextWrangler is free.