Modify the default body text

Hi,
I just upgraded to Scrivener 3.1.1
After reading the manuals I understand that it’s better to leave the body text with “No Style.”
BUT, I’d like to change the font/size/style of the BODY TEXT…and I can’t find how to do that.

Now, even after I created a style for Body Text, and apply it, as soon as I hit 'Enter", it’s back to Palatino 13.

Thank you for your help!

Two steps: First, change the Default formatting in Preferences. Next, convert your existing documents to the new default formatting.

To change the default formatting (you may have already done this, but I can’t tell from your description; forgive me if you already know this part):

  1. Manually adjust a paragraph in one of your documents to the formatting you want for default—font, size, indents, paragraph spacing, etc.
  2. Leave your cursor inside that paragraph.
  3. Open the Scrivener > Preferences dialog.
  4. Click on the Editing pane, and within it, the Formatting tab.
  5. Click on the “Use Formatting in Current Editor” button.

To convert your existing documents to this formatting:

  1. In th Binder, select all the documents you want to convert.
  2. Select Documents > Convert > Text to Default Formatting…

Hope this helps!

Note that you can also set a project-level default, in the Project -> Project Settings -> Formatting pane.

If you’ve set a Scrivener-wide default, but a particular project doesn’t honor it, that’s probably why. Be especially alert if you’re using one of our supplied project templates, since some of them come with their own formatting.

Katherine

This is great!
Thank you so much Silverdragon! I didn’t know that!
and thank you KEWMS! very helpful!
Problem solved! :smiley:

I don’t think that Scrivener actually has a ‘default format’: selecting a paragraph or a page of text and selecting ‘Make Formatting Default’ from the ‘Format’ menu doesn’t change the fact that I have to select away from ‘NO STYLE’ every time I hit the return key.

So… ‘NO STYLE’ , or stop typing, over and over again, selecting a paragraph style that works for me, instead of actually settling-in to writing.

But ‘NO STYLE’ is non-configurable.

The deal-breaker is that the Sitka font is extremely unfriendly to people with certain types of dyslexia.

The ‘NO STYLE’ paragraph indenting isn’t great, but being stuck with Sitka, and line-by-line reformatting, makes me very glad I’m still in the free trial.

While you’re on the trial… try the interactive tutorial (under the “Help” menu). It will answer almost all of those basic questions.

You can, of course, change the default format. You do this in one of two places:

  1. For new documents in this project and every new project

  2. For new documents for this project only.

For 1: Go to Options) > Editing > Formatting and change the format in the dummy text box to your tastes using the formatting icons. Of course, you can set the paragraph spacing, indent, format, font, font size etc etc in this box.

For 2: Go to Project > Project Settings > Formatting and you see the same sort of dummy text box. Make sure the ‘Use different default formatting for new documents in this project’ box is ticked, then make your changes.

Or, if you prefer, in the editor, use the tools in the format bar and formatting menu to format a single paragraph the way you want it to look. Then select that exact paragraph and choose Format > Styles > Set Default formatting…, which will take through to the formatting dialogue you saw in Method 2 above. Click the ‘Use Current’ button and the dummy text will update to the format of the selected paragraph. You can also use this technique with Method 1, but you need to use Options > Editing > Formatting to get there.

All the above steps will only change the default formatting for new documents in the binder. To convert existing documents to the new default, select them in the binder, then choose Documents > Convert > Text to default formatting, click OK on the dialogue box which appears (you usually won’t want to have any of the options ticked). Note that this process isn’t undoable, so best to test on a dummy document first.

The above is a quick run through the process: there are a couple of other ways of achieving what you want, but this will get you going.

But November_Sierra is absolutely right: you really must spend the hour or two it will take you to skim through the tutorial if you’re going to get the best out of the program. Scrivener works best when you work with the way it’s designed: it’s not a standard word processor and you’ll save yourself a lot of time by doing the tutorial first.

Hope this helps, and good luck with the trial!

2 Likes

In addition to the tutorial, and the advice in this thread:

  • In the FAQ: How do I set the default formatting in my project? Answer being: it’s a single menu command (Format ▸ Make Formatting Default) and that’ll walk you through it.
  • Documentation:
    • §15.1, Rich Text Editing Philosophy: the introduction to Chapter 15, Writing and Editing, doesn’t specifically pertain to setting defaults, but does go into breaking away from the Google Docs / LibreOffice way of thinking, where one is chained to how they want to print by and large.
    • §17.1, Think Different, in the user manual PDF: regarding how Scrivener’s style system is opt-in when needed rather than mandatory.
    • §15.7.4, Resetting Formatting.
    • Appendix B.3.2, on the Editing: Formatting tab in options/preferences.

Was that a question ?

No point in assuming such things when there is actually the forum…
Might as well just ask if it is or not first. (You are already here anyways…)
:slight_smile:
It is, btw.

‘No style’ is configurable … and it’s not. If you push ⌘⌥0 (Mac) or the Windows equivalent, it applies default formatting as it’s configured in Preferences/Options.

But then, if you go to Preferences/Options and change the default formatting, it has no effect on existing text. In that way, ‘No style’ is not a style.