Mouse pointer doesn't go back to typing cursor

I’ve looked through most of the posts with the words “cursor” or “pointer” in them, but couldn’t find an answer. When I create a scrivener link in a document, and then switch to another document, the mouse pointer no longer changes to the typing cursor when hovering in a block of text. It simply stays as an arrow.

I’ve tried this both with the right-click context dropdown menu, and by using the Edit menu “Scrivener Link” option, and it occurs with both. The difference is that with the right-click menu, the behavior occurs as soon as you move from the current document to another document, while with the Edit menu option, you have to actually click the Scrivener link and then move to another document.

I’ve tried this many times in multiple projects, and it always happens. The only way to bring back the typing cursor, that I have found, is to completely close Scrivener and restart it. Is this something that anyone else has seen and can reproduce? Or am I simply crazy?

Yes, this is a bug, I’m afraid. It happens with all links when the mouse cursor passes over the link. Functionality is the same, but you don’t get the I-beam back until you restart. It’s on the fix-list.