Mouse wheel scrolls too much in Outliner

Mouse-wheel scroll works well in binder and in documents (and in other programs), so I can’t just change the system setting. In Outliner mode, it actually scrolls more than page up and down do (which I’ve just noticed works inconsistently).

These are the possible sources of this problem:

  1. Directly related to the code used to develop Scrivener 3 RC. (You can’t do much about this)

  2. A setting has to be changed within Scrivener. I don’t see an option for this in Scrivener 3 RC. So you’ll probably have to change a setting in the theme files itself, which is a highly technical procedure. (I wouldn’t recommend this.)

  3. A setting in your mouse software or windows mouse settings has to be changed. First try changing the wheel scroll speed in the Windows mouse settings, then in your mouse’s proprietary software settings.I know you don’t want to change the system mouse settings as it’s a global change. But, often times, you’re mouse’s proprietary software will provide an option to change an application specific vertical scroll speed.

I hope this helps.

I’m pretty sure it’s a bug because like I said scrolling in other panes of the interface works well.

Did you find a setting in the theme files for outliner scroll speed? I looked in the .prefs file but didn’t see one.

Or do you mean using CSS scrolling in the .qss file?

Yes, this has been bugging me too. It really reduces the utility of Outline View.

Just to be clear, the issue seems to be that the scroll setting is applied to rows in the outline rather than lines of actual ext. This means scrolling makes the screen jerk horribly.

I’m on Windows 10 Pro Version 10.0.19042 and RC18.

Under Windows Mouse Settings, the settings “Roll the mouse wheel to scroll” and “Choose how many lines to scroll each time” work together to determine scrolling velocity of my mouse wheel. These settings directly impact scrolling in the Outliner.

I have mine set as per below (lines to scroll = 5) and Scrivener beta Outliner scrolling with the wheel works perfectly.
[attachment=0]Mouse wheel settings.jpg[/attachment]Hope this helps,
Jim

@zornhau - I am in the process of working out/auditioning various storylines for my novel using your book Storyteller Tools. Thank you for sharing your approach, it’s really helped me! :smiley:

Do your settings work when you have Title and Synopsis showing (and the synopses can be several lines) ?

PS Glad you like my book. If it helps, please post a review!

I’m now on RC19. Starting with a fresh copy of the Tutorial, which has Title and Synopsis showing by default:

I select the Draft folder
Select Outliner mode
Click on folder 1. The Basics in the Outliner
Select View > Outline > Expand All

With the Mouse settings per my screenshot above, one notch of the scroll wheel moves the Outliner from 1. The Basics as the top row to 1.1.1.2 The Editor. Next notch goes to 1.1.1.3.3 Bookmarks, next to 1.2. Get Organised.

Increasing the Mouse setting Choose how many lines to scroll rapidly increases the velocity of the Outliner scrolling. So set at 5, the Outliner scrolls as above. Change to 15 and each notch scrolls half a screen. 30 results in full screening scrolling per notch.

Another factor that might be useful for you to know is my screen resolution is 1920 x 1080 at 100%. Different resolutions might be a factor. ETA: Actually, I just played around with different resolutions and %'s, and it made only a tiny difference.

Hope that helps.
Jim

I thought the device might make a difference.

My normal device is the excellent Perixx Perimice-720 trackball mouse.

I also tried my settings with a Logitech mouse and got the same results.

I copied in varying amounts of text into the Synopsis field, and I’m not seeing any jerkiness when scrolling at the settings I’ve listed above.

The Outliner scrolling (for my setup) doesn’t seem to be based on rows or lines of actual text. Instead, there seems to be a standard measure of a couple inches of screen real estate that’s scrolled with each scroll wheel notch. This makes sense to me, as the fonts used in the Outliner are of varying sizes (folder name vs. document name vs. synopsis), so scrolled based on the uneven rows or lines would be uneven.

Could you post a video of what you’re seeing?

I’m not a heavy user of the outliner yet, or the corkboard for that matter, but I see almost the exact same thing (I believe) on google calendar via the chrome browser. I display three weeks at a time, but when I scroll down one click of the mouse wheel, I’m suddenly many weeks in the future.

Just an observation in case it sheds any light :bulb: on this problem.

Ah. You’re right. What’s happening is:

Windows Mouse settings let you specify “Choose how many lines to scroll each time”. (N)

Scrivener, however, scrolls N x D, where D seems to be a measure of screen real estate.

If I set N to 1, then Scrivener scrolls quite reasonably. (That global setting is however inconvenient.)

It would be nice if D was 1, or else could be adjusted.