"move focus" shortcuts in scriv3

I’d like to move quickly between typing titles in the binder and typing in the editor - the commands that used to work are bringing up bookmarks (shift option cmd B) or Export (shift option cmd E) or Target (shift option cmd T) - it’s like the option key is ignored in this combination. The option key works though, because option E compiles and option B hides/shows the Binder.
Not sure if this is due to Sierra upgrade or Scrivener 3. Making an App-specific shortcut “Move Focus To Binder” doesn’t help.
Is there something that I can do to reach the editor without clicking in Scrivener 3?

The default commands for moving to Binder, Editor and Inspector haven’t changed in V3: they’re still on cmd-opt-ctl-B(inder), (E)ditor and (I)nspector Synopsis as they were in V2. (ie NOT cmd-opt-shift…). (And cmd-opt-ctl-r goes to Other Editor if you have one open). You can also use Ctl-tab to move between Binder and the Editor(s). The cmd-opt-ctl sequence is also used to move to the various Inspect Panels (e.g. cmd-opt-ctl-h goes to Notes, -k to comments/footnotes etc.

The normal commands for Targets / Export etc don’t have an option key in them: cmd-shift-t and cmd-shift-e. As far as I can tell from KeyCue (which lists all shortcuts in use), cmd-opt-shift-E and cmd-opt-shift-t don’t have default bindings, so I’m not sure why they’re invoking export/target for you — they have no effect on my system.

Cmd-shift-b should bring up the Bookmarks panel, while by default cmd-opt-shift-b should go straight to the full Bookmarks Window.

If these shortcuts aren’t working then another program on your system is overriding them somehow and you’ll have to use trial and error (or a program such as KeyCue) to track down what’s causing it - this can be a bit of a pain, I’m afraid.


thank you, I had not remembered it correctly. And I thought ^ is short for up arrow which is shift. well. Keycue is useful to keep running for a bit.

I have once remapped one key combination to be able to browse through a pdf with one hand (right option and arrows) instead of having to use left option and thus both hands. even though I uninstalled this, it may have left a trace here. shouldnt do things like remapping keys :wink:

ps having keycue open breaks the option u umlaut on the us keyboard, puts the dots before the vowel instead of on top. so no keycue.

KeyCue doesn’t break the ü combination for me — using the UK Mac keyboard.

Do you have option set as the trigger for the KeyCue HUD? You can change the sequence in the preferences to see if that makes a difference. I disable everything option except one and have that set to show all three possibilities (Menu shortcuts, System-Wide shortcuts and Macros) on cmd-shift hold. I’ve never found a conflict with anything yet.

I use US.
I’m having more problems with these shortcuts, nothing I set works in Scriv 3. I think I’ll make a new post for this, the “move focus” shortcuts do work now. thanks!

The cmd-opt-ctrl-T shortcut - to move the focus to the title - does not work for me (Scriv 3.0 on Mac). Am I missing something or is this a bug?

Check the Navigate ▸ Move Focus To ▸ Header Bar Title menu command and see if the shortcut is correctly printed there, and that the menu command isn’t disabled (indicating the cursor is currently in an area that can’t target the header bar). If it all looks like it should be working, then the interference is probably coming from another program setting a global shortcut. Those can be hard to track down, especially if it isn’t listed in the System Preferences: Keyboard: Shortcuts pane somewhere. You just have to go through preferences in the stuff you have running.


Did you manage to find a resolution for this?


Slàinte mhòr.

For completeness: https://forum.literatureandlatte.com/t/header-bar-title-shortcut-not-working/45523/1