Multi-Level Documents (Subdocuments) Issue

I’m on an old PPC iBook G4 with system 10.5.8, using the NaNo version of Scrivener, and prepping everything for the UF mystery I’m writing for NaNoWriMo.

The below picture illustrates both what I’m trying to do and what won’t happen. I’m trying to drag a document over to put it as a subdocument of another (like the 3 in the image are subdocuments of the “Freewriting” document. Scrivener isn’t letting me do that.

To produce the “Freewriting” one, I had to convert it to a folder, drag one of the documents in, convert it back, and then it would let me drag subdocuments to join the first one.

This just me?
Picture 1.jpg

It sounds as though your Option key is getting stuck. If the Option key is held down, then you can’t drop onto text documents.

Not trying to be difficult, but I just double-checked, and my Option key isn’t pressed or stuck or anything. :neutral_face:

I have the same problems as Carradee on an iMac G5 with 10.5.8, Scrivener NaNo 2.0

‘Move To Left / Right’ and the shortcuts are working. But it’s impossible to drag and drop a document onto another.

Given that I can’t reproduce this, it would be really helpful if you provided more info - unfortunately “it doesn’t work” doesn’t really give me much to go on. :slight_smile:

First, check your console (~/Applications/Utilities/ - any errors there?

Second: you’re both talking about the binder, right, and not the outliner (where multiple selections etc may have an effect)?

Third, please provide the exact steps to reproduce, because no one else has reported anything like this in months of beta-testing and it works fine for me, so I won’t be able to fix it unless you can tell me how to see it for myself.

Unfortunately my PPC machine went walkabout when I moved houses, so I haven’t been able to test on a PPC. I’d be interested if anyone else is having similar problems on a PPC machine, although I can’t see how PPC architecture would have an effect on this particular issue.

Many thanks!

All the best,

Here is another possibility to get out of the way:

You cannot drop items into other items in a Collection view. So, if you are looking at a Collection in the Binder area, rather than at the Binder per se, then what you are seeing would be expected behavior.

Nothing shows up in Console.

To reproduce:

  1. Have one document without any subdocuments in Binder. (Not Collections, not Outliner, not Corkboard. :slight_smile: )

  2. Attempt to drag something else to the document to set that “something else” as a subdocument or subfolder.

Result: You can put the desired subelement before or after the desired master element, but you aren’t even given an option to set it as a subelement.

I had the same thing happen on a MacBook with Snow Leopard. Resetting the default preferences seems to have fixed it, but I haven’t been able to figure out what caused it.

EDIT: Found it! When I have “Option-dragging creates duplicates” checked, I can’t drag documents onto each other.

You are my hero/heroine! I just wrote a long posting about my testing and observations, tadaaa! , problem solved.
Why didn’t I try this the other day…

That fixed it for me, too. :slight_smile:

Ah, yes! Thanks! That is behaving backwards and was the extra info I need. Currently drop-ons are being disallowed if you have “Option-drag creates duplicates” checked. I’ve just fixed that for 2.0.1.

Thanks again,

I’m glad I could help :slight_smile: