Multilingual user: how to switch or disable dictionaries and auto correction

Hello everyone.
I use Scrivener to write both in English and Spanish.
English is my second language so the auto correct features are useful to me in that language.
However, when I write in Spanish, autocorrect underlines almost every word with those little red symbols meant to call attention to a potential error, which gets tiresome to look at.
It would be great to enable the dictionary that matches the language I’m using as needed, this would allow me to take advantage of auto-correct features in either language. I haven’t figured out how to do that.
If the above isn’t possible, and since I really don’t need auto-correct too much when writing in Spanish, it would be great to disable the red underlining, but I haven’t found a way to do that either.
All help will be greatly appreciated! :slight_smile:

After several weeks I’ve received no replies to my OP, but I can see several hundred users have read it, so I guess I wasn’t the only one with this question. I’ve figured it out, the solution was actually easy enough and should have been obvious, I share it here in case it helps anyone:

  • In Mac OS, go to system preferences, choose KEYBOARD, then choose the TEXT tab, and use the drop-down SPELLING menu to select the language you’re using. If Scrivener was already open, save and restart the program. Voilá,

After choosing Spanish, the annoying red underlining is gone when writing in Spanish, hurray!

Switch language again and restart the software to enable change of language preference as needed.

1 Like


Does “Automatic by Language” not allow you to use both languages at the same time? Should work on a paragraph-by-paragraph basis at least.

Slàinte mhòr.


I am also having trouble with switching languages. My system setting is “automatic by language” and I do most of my writing in German. Scrivener’s interface language is set to system default and everything is displayed in German. But I sometimes compose entire projects in English and/or have English quotes in my German texts.

So far the spell-checking function works fine when my system settings are automatic BUT my quotation marks will always stay in German (, ') for both single and double quotation marks. I was only able to change this by switching the entire interface language in Scrivener to English and relaunching the app — which was cumbersome … and also not really an option for projects in which I need to write in both languages and hence need both types of quotation marks. Is there an easier way to solve this problem?