MultiMarkdown 2.0.b4 Released

I have released version 2.0.b4 of MultiMarkdown today. As always, it can be downloaded from:

Some of the changes include:

  • 2.0.b4 - empty labels for headers now produce valid XHTML (e.g. no id="")

  • fix bug in clean-text.xslt that caused a problem with closing doublequotes

  • the .xslt extension is no longer required in metadata

  • added customizable letterhead XSLT (this is one of my personal favorite new features - check out the

  • fix bug in table support that choked on extraspaces at end of lines

  • Major Change: switched to Text::ASCIIMathML formath support, meaning that
    everything is once again perl based (this enablesmath features on web sites
    using MultiMarkdown, for example)

  • fix bug that occurred when ‘Abstract’ was not the first chapter

Note: Scrivener users should make a backup copy of ~/Library/Application Support/MultiMarkdown prior to updating with this version. Remember to copy back any customized files that you have in that location as well.

Enjoy, and please let me know if you find any problems.

Happy holidays,

Fletcher Penney

Since updating and trying to use it with Scrivener, I’m getting this error:

warning: failed to load external entity “.xslt”
unable to parse .xslt

Am I supposed to change something in the MultiMarkDown Settings? Is it still not:
LaTeX XSLT memoir-xelatex.xslt (for example)?


Strip out the extra spaces in your metadata

I’m sorry, what extra spaces? In the Meta-Data Key box, I have “LaTeX XSLT”, and in the pane to its right, I have “memoir-xelatex.xslt”. I don’t see what extra space you might be referring to.

I can almost guarantee you that there are extra spaces after memoir-xelatex.xslt.

No, unfortunately, there are not. Any other ideas? Again, only after the new beta update did this begin. The exact same file and setup was working before.

Send me a copy of the file, if you can, and I will look at it — preferably by exporting as MMD text (not latex, etc) and sending me the text file to start with. It’s the same error another user had when there were trailing spaces (or perhaps invisible characters?) in the metadata, and I suspect that’s where the problem is.

I updated the MultiMarkdown TextMate bundle today. This update fixes a problem that Leopard users were having — or at least I think it does. It still works for me in Tiger, and I hear reports that this fixes the problem Leopard users were having. Specifically, they were getting an error message like:

/bin/bash: line 2: cd: ~/Library/Application\ Support/MultiMarkdown:  
No such file or directory
/bin/bash: line 3: cd: bin: No such file or directory
/bin/bash: line 5: ./ No such file or directory

This was caused by an apparent change in the way the shell works under Leopard. Please let me know if you continue to have trouble with this, and thanks to everyone who helped track down this bug.

Download the new version from:

I get the same Latex Export Error.

There are no spaces in LaTex XSLT. But if I export the Scrivener doc as MMD, then it has two spaces added to all the lines that contain Scrivener MMD Settings. Like Title, Author, Latex XSLT etc

Spaces can then be manually removed from the exported plain MMD file and then it works. Making one believe that the extra spaces were in Scrivener, when there were none.

Try this experiment: End the Latex XSLT setting with return (which is forbidden in the MMD Scrivener instructions… try with XSLT as the last setting). Then the buggy extra spaces are added to an empty line, not to the xslt line. Extra two spaces seem only harm the xslt line. And you don’t get the MMD Latex export error anymore. Building a pdf from exported .tex file seems to work.

Actually, if one puts in the Latex XSLT setting: memoir-xelatex.xslt + return + Date: 2007-12-27, then you don’t get the empty line, but a line with date (when the file is exported as plain MMD). No MMD Latex export error.

Who knows if date-line or the two-spaces-only-line create other complications.

So, it is a problem with too many spaces in the metadata, as I said.

The only difference is that Scrivener is putting the spaces in the metadata.

(As I have mentioned before, when troubleshooting, always export as plain MultiMarkdown text, and go from there)

In either case, the next release of MMD will solve this problem, for now you can edit (and the other files):

find the line that looks like this:

$g_metadata{$currentKey} =~ s/\s*(\.xslt)?\s*$/.xslt/;

and make it exactly like that. Now the extra spaces will be silently discarded.