MultiMarkdown compile strips out asterisks

I write directly in Markdown and surround text that should be italicized with asterisks. For the last several betas, the Compiler removes these asterisks (except for a few that somehow survive) and they are absent in the resulting .md file. This means I have to go through and manually re-add italics in Word after doing the md > docx conversion. I have been using Basic MultiMarkdown in the compiler, with “Convert rich text to MultiMarkdown” unchecked - I don’t think (?) that setting is relevant to this but I thought I would specify just in case.

That’s correct, the setting you mention should in fact escape the asterisks, so that they become visible in the output, kind of rather the opposite of stripping them out. The idea being that if one isn’t using Markdown to write, they probably meant the asterisk for what it is and wouldn’t want it unintentionally turning something into italics because there happened to be two in the same paragraph.

As to the rest, I haven’t actually seen that happen with the .md output. It sounds like it isn’t a sure thing, that there may be some condition that causes some of them to go away and others to remain—so I probably haven’t encountered that in my testing. Ideally none of it should be touched at all when compiling straight to .md, Scrivener should only be adding what things you use in the editor that generate MMD (like footnotes). Do you have an example case you can provide where they are stripped?