"Name of setting" appears in every new file

Everytime I add a new file to my chapter, the sketch for places, always appears on it. So everytime I try to add a new file to my chapters, I have to rename the doc, and delete the “Name of Setting” document… All the tutorials I’ve seen, shows a blank page being added, so I must have clicked something wrong… How do I fix this?

Regards, Marianne

How are you trying to add the new file? Make sure you are in the binder at the place you want the new document to be and ensure you are using the new file or green + button and not selecting new from template. By default I believe the new from template selects a setting or character sketch in some templates.

Can I change that default?
I am highlighting the chapterfolder, and I have tried everything from duplicate, the green + button, the add-button in the bottom, and ‘add new file’… Stil comes up with the setting sheet…

I am having this same problem. This Name of Setting file even replaced my ‘scene’ (blank) in my templates folder and I can’t get rid of it. It’s hindering my ability to work and set up new scenes. I don’t want to keep deleting all the text out of the preset template, but that seems to be the only workaround, besides lengthening my current scenes to include several sub-scenes. It’s not ideal.
I just tried upgrading the software hoping it might fix the problem but it hasn’t. Thanks for any help.

That’s exactly what is happening!
I hope someone can find us a solution

Where in the Binder are your chapters placed? As children to the Manuscript/Draft folder, or as siblings? Could you provide a screenshot? It sounds as if Scrivener thinks you are outside the Draft, in the part where you have Scenes and Characters.

Thank you, lunk! Based on your note, I checked my folder organization and saw that some of my more recently added chapters were farther out to the left than the majority of my chapter sub-folders. When I pushed those too-far-out folders over to the right a couple of levels, the problem went away and new files opened as untitled blank scenes again. It’s weird, but at least now I know when those unwelcome ‘name of setting’ files come up what made it happen and can adjust. Thanks again.

I’m having the same issue. In my case, it’s using a Character template. I’ve tried deleting the template and the template folder. It still brings up that template (even though it no longer exists) when creating a new text file. I’ve tried all of the different methods for creating a file and verified that I was within the manuscript folder. It doesn’t do it every time but most of the time. Once I got it to create a blank file I created a few more and then on the fifth new file it reverted back to the template text. I’ve tried deleting the template text from the newly created file but it’s maintaining the formatting that was in the template. It’s making it very frustrating to use.

Hi Sean,

Even though you deleted the templates and template folder, they still exist and are active in trash. Delete them from trash and see what happens.

If the problem keeps occurring, could you please post screenshots as suggested by Lunk. Would want to see the folder selected and what button you are clicking to do your “add”.


Hi Jim,
Yes I had cleared the trash. I had also closed and reopened the project after deleting the trash. I just did it again to get a screenshot. As shown in the screenshot, I created 3 new files without issue (the untitled files above the problem file) but on the fourth file, it reverted to using the template. I was creating the new file by selecting the preceding file to the location I wanted (“Sabrina does KP duty” in the pic) then clicking on the green plus button.

Also, I did get feedback from the support email this morning. I was advised to create a new project and move all of my files into the new project. This has solved the immediate issue but without knowing what caused it to happen, I don’t know how to avoid it in the future.

If you could send a copy of that project to the support person you are in contact with then we could maybe figure what is going on by seeing the problem for ourselves and what options are set for the project. It’s not likely to be a simple switch you can toggle since there aren’t any features that would work the way that is being described.

I’ve got the same issue with the Character Sketch forcing itself as my default template wherever I use it.

Creating Characters was the first thing I wanted to do, so I started working in a new folder I made, called Characters. It defaulted new pages to the Character Sketch template. I didn’t like that and so I found that renaming my Characters folder to Character List allowed all new pages to default as blank, which I preferred. Now, if I go into my draft and actually want to start writing a story, the new files come up as Character Sketches.

Literally no matter where I create a new file it always uses the Character Sketch template. Is this a bug or can I change a setting somewhere?

Looking closely, I see that Ctrl-N is common between New File and New from Template. That doesn’t seem right.

scrivener issue.jpg

The shortcut for the second is Ctrl-T, Ctrl-N, not just Ctrl-N. If you don’t use the T first it won’t trigger.

That aside, thanks for the additional info, but unfortunately nothing has really changed from my earlier remark. This isn’t programmed behaviour and I can’t get it to reproduce with these instructions. So really the best way for us to debug this will be to send in a live example—unless you can find a way to reliably reproduce it from a Blank start.

I have the exact same problem with one of my projects.

Whenever I create a new document it uses a template that is prefilled with text.

Even stranger is that the template is already deleted and my Trach folder is empty.

Thanks for that clarification. Yes, I misread it as two alternatives but you’re right it is a sequence.

Nevertheless, the bug remains. As others have mentioned in this thread, it even happens after clearing templates and deleting the templates folder. I even tried creating a new templates folder with blank contents, but it still loads a Character Sheet when I press Ctrl-N or use the green plus icon.

Again though, this is something we need a live sample on our systems to further analyse.

I am having this exact same problem. I thought it was just me and have been trying for weeks to reset it to no avail because I could not figure out how to. But I DID force it to kinda work by deleting all templates and making new ones and then going all the way to choosing New From Template and then choosing the actual template I wanted every time. The formerly handy green + button doesn’t work (it inserts your Character Sheet Template that I no longer use and have since deleted - removed it from trash too). And choosing New File or New Folder from the drop down menu also inserts this Character Sheet Template. And this goes for all cards I add to the corkboard too. I try to ignore what they look like though and just keep right clicking and adding. The actual formatting when I’m outlining is less important to me, so it’s okay if these insert as Character Sheet Templates I guess.

I use Scrivener on both my laptop and desktop (they are running Windows 10) and I installed Scrivener on my iPad too. Didn’t see the problem until that happened. Also, using Scrivener on my iPad wipes out all of my formatting when it syncs to what I have on my other two computers, so unless I’m using a corkboard for an outline or adding text to a character sheet, etc. I’m hesitant to even use it and regret purchasing it because this renders it almost useless for me. I wanted to be able to write and add to my stories while I travel and having to go back and remember where I italicized, etc. to fix everything I’ve already written is highly inefficient and some things get missed. Also, icons don’t sync. I wasted a lot of time updating stuff on my corkboard in the app so that I could visually differentiate cards on the corkboard and none of it carried over to my computers. And now some icons are also randomly turning red!

One of the first things I did once I had Scrivener on my iPad was mess around with the Character Sheet template for the first time - changed the formatting from your default. Perhaps this triggered the weird stuff that is happening with the add button, drop down menu, etc now? Just a thought because it started happening immediately after I did this. I’m more than happy to send you the Scrivener project I am working on so that you can see what I’m encountering (hopefully).

Oh, and I sync with Dropbox if that’s helpful. Often it tells me there’s an open project elsewhere when there isn’t one. So then I go back and double check to make sure Scrivener’s closed on my machines and that Dropbox has fully finished syncing and I even turn off my iPad sometimes too just in case (after Scrivener’s already closed there as well) and it still tells me that a project is open. Usually it will load just fine with no conflicts despite the warning though. Only had the conflicts folder populate three times so far. It’s a nice feature. :slight_smile:

Where/how can I send you my Scrivener project?

I’m also having this problem.
The first thing I did upon making my project was to create a handful of templates for different types of character sheets. But now, whenever I try to create a new file, unless I specifically use “New from template…” it automatically assigns one of the templates that I created. The same one, every time. Which makes it impossible to create a simple blank document. I have tried cancelling the templates folder, and I deleted the template that keeps getting used, and emptied the trashcan, so theoretically that particular character sheet template no longer exists within the project. However, even despite that, whenever I try to create a new file or folder (via “New File” or “New Folder”) it creates that same character sheet instead, even though it shouldn’t even exist anymore.
Sometimes it randomly switches back to creating normal blank documents for a while. Then for no apparent reason it’ll switch back to only creating character sheets. So I figure it’s a glitch.

Best thing to do would be to use the File/Back Up/Back Up To… menu command and save that to your desktop with the zip compression option enabled. You can then send that in via our contact page, using the appropriate email address at the bottom of the form (since you can’t attach with the form).

Thanks in advance!