Narrowness suddenly

I have a project that has been quite normal up to now - the text goes all the way across the page of what would be an A4.

But for some reason the text on any new pages refuses to take up any more than half of the page. I’m trying to make a list, and I write "Item 1 (tab tab tab) - and the third tab sends the next word onto the line below.

I’ve tried Cmd-T to bring up the font stuff; I’ve tried searching for “margins”, I’ve tried Format/Paragraph/Increase-Decrease Indents (all items greyed out). I’ve tried setting the Tab Bar to be visible, but still can’t see any tabs or margins.

How can I re-educate this document to have its remaining pages the normal width, please?

Adding to this - if I want to type further material after the number I’ve tabbed out to, it types away happily. It’s only adding another tab that pushes the figure onto the next line.

Use the View -> Text Editing -> Show Invisibles command to look for any hidden formatting commands.

Why are you making the list manually rather than using the Format -> List commands?


Why would I need to format it as a list? It’s a list of expenses, and I want the cash sums to line up on the right.

I did try viewing invisibles, but that didn’t show margins stopping the last tab in the middle of the page.

You can see tab stops and line length if you show the ruler, command-R

I second the advice to open the ruler so you can see what is going on visually with the indent settings. For a more precise numerical view, use Format ▸ Paragraph ▸ Tabs and Indents….

But another tip is to just reset the formatting on these documents. And if for some reason these weird indents are coming from your defaults, that article also has tips for getting your defaults set up correctly, too.

Did that but the answer doesn’t tell me a lot. Here’s what it says, and a couple of lines from the document so you can see what I’m talking about (the top line being part of the list, which refuses to extend beyond the centre of the page, the bottom being a line of explanatory text below it which extends all across the page.

Yeah, those settings look like what I’d expect to see for the second paragraph. I can’t tell you what settings you have on the first line since the cursor is in the second, though.

But my guess, based on your initial description above, is that you only have two tab stops on this line. So when you press Tab for the third time, it has nowhere to go and jumps to the next line (not my favourite fallback behaviour of all time, if I’m honest, but that’s how the text engine works).

There are two ways to “fix” that:

  1. Establish a Default tab spacing in the tab and indent pane, for your default settings. This will cause Scrivener to act more like a regular old text editor, where pressing tab merely jumps four or so spaces to the right, and you can continue to do so until the end of days (or the end of the editor with line wrap).
  2. Add a third tab stop (and however many more you require) using the provided interface.

The other alternative explanation is that you have a right aligned tab stop, where the value in Euros is given, which would indeed cause the “page” to feel artificially narrow, since once you tab to that your text will move leftward into the page, like right alignment. That can be investigated in this panel as well, and you can even change the alignment type right there.

I thought adding an extra tab stop would work, but no, added one and tried pressing it, and it jumped to the next line. It’s maddening!

I suppose I should edit the default tab spacing - but how do I do that? Is it complicated? Why doesn’t Scrivener just tab out to the end? (I thought at first that maybe I’d accidentally invoked Scriptwriting Mode, which is annoyingly easy to do, but no.

Well that would work, so something must have gone wrong between steps 1 and 5, so to speak. All you should have to do is open the ruler and click on it to make a new tab stop, drag it somewhere to the right of where your cursor is, and then tab to it. If you then delete that tab stop the cursor will jump to the next line.

As to why, that’s just how the text editor works, like I say. If it runs out of tabs it goes to the next tab stop on the following line. The option to add a default interval to your global settings is really the answer to that question though. If you want Scrivener to simply tab all the way across at fixed intervals, it is one setting away.

I wouldn’t say so, it is the aforementioned text field in the middle of the Format ▸ Paragraph ▸ Tabs and Indents… palette. For best results you should use that tool from within the Editing: Formatting preference pane. Then you can use the standard Documents ▸ Convert ▸ Text to Default Formatting… command to add the default tab stops to your existing text.

Now the way this works is that if there are no tab stops to jump to on the ruler when you press Tab, then it uses the default interval instead. If there is a tab stop then it will ignore the interval and jump straight to it. But if there are no more stops on the line after that point, it will drop back to using the interval. Thus you won’t end up on the next line unless you’ve actually run out of line.

So given that, what I do myself, since I don’t need formatted tab stops, is remove all of the default stops from my default formatting (with Format ▸ Paragraph ▸ Remove All Tab Stops), and then set the default interval to roughly four spaces wide. That makes Scrivener work more like a classic text editor, which is what I’m used to.

How do I open this ruler? I can’t find it - have been looking for it all along. It was that palette (pictured in one of my posts above) that I added another tab to, by the way.

Found along with most of the settings that impact the text editor, it can be toggled with View ▸ Text Editing ▸ Show Ruler.

… or Command-R

Thanks. I’ve now got the ruler invoked. but can’t drag the tab controlling all of those figures; it’ll only drag each tab on each line individually, so they’re all over the place now, due to my lack of dragging skills.

Have you tried selecting several lines at once when you do this? :wink: And lack of dragging skills is what the Tabs and Indents dialogue is all about. Maybe you prefer the visual feedback of the ruler, that’s fine, but when you’ve got things close to right you can go into that panel and round the awkward numbers off. Once you know the numbers, you can use the panel to apply modifications to other paragraphs by just typing in numbers you’ve jotted down somewhere.

And if they aren’t all together, that’s what the copy and paste commands in the Format ▸ Paragraph ▸ submenu are for.

And if you do this a lot, and want all of these paragraphs to always be the same even if you change your mind in the future, that is what Styles are for.

I would tentatively say that one should never find themselves in a position where they are manually recreating paragraph formatting one at a time, over and over. Scrivener has a whole drawer full of cookie cutters for this problem.

Thanks, Amber.

I know how to select a series of lines at the tab in Word, but it doesn’t seem to work in Scrivener.

I’m not sure what Word does, but in Scrivener you just click and drag with the mouse to select as much text as you want. Any paragraph included in the selection will have its ruler changed.

Ah, that worked! Thanks!