Native Mac "Lookup" context menu disappears in Scapple... Bug?

Hi, I’m using Scapple 1.4 (1122) with a new MacBook Pro (M1) and the native Mac “Lookup” in the context menu dictionary disappears in Scapple once the word in question is selected. I tested this in Scrivener but it works fine. I’m guessing this is a Bug?

I’m afraid I have not been able to replicate the problem on an iMac running macOS Monterey 12.1.

What version of macOS are you running on your MacBook Pro?

Monterey 12.1. When I highlight the word and select “lookup” the dropdown flashes briefly but disappears instantly. I’ve tried reinstalling Scapple with no luck.

Works for me … M1 MBA, Monterey 12.1, Scapple 1.4. Highlight word then Ctrl-Cmd-D and it opens the dictionary, no problem.



but not for me… still same issue with the keyboard shortcut :frowning:

Have you got some other app or something that is hijacking the shortcut. For instance, I recently tried keyboard maestro, only to find that it interfered with much used shortcuts in my other apps.


Mark, if you are new to Keyboard Maestro, perhaps you have not yet read about Conflict Palettes. Palettes are one of the main reasons why I use Keyboard Maestro. It saves me from having to try to learn lots of shortcut keys. Not everybody’s style of working, but I have found them very useful.


Nope I doubt it. Lookup seems to work fine elsewhere including Scrivener. Here is a link to a screen recording of the buggy behaviour : Screen Recording 2022-01-21 at - pCloud

Hi Martin. Thanks for the reply. What really got me was that it hijacked Shift-Cmd-V, which is “Paste Text Only” (i.e. “Paste and Match Style”) in almost all my Editors, and also the shortcuts I use most frequently in Graphic Converter. That really riled me.

I’m sure it’s very good, and if I’d started using it a decade ago things would be different, but now what time and energy I have I want to spend on things I need, want and know how to do, rather than working out how to resolve such conflicts between an app I don’t know and apps I’m very familiar with. And on the other hand, I’m not desperate to automate processes I use, even though that may mean working in stages with separate apps.



PS Apologies to @peter100 for somewhat hijacking the thread.

Since, I and other people have no trouble with this, it must be something about your machine and installation. I would try:

  1. Shutting down and re-booting the computer.

  2. Running Onyx, Cocktail or similar system maintenance app to clear any possible gremlins out of the system.

  3. With Scapple closed, going to ~/Library/Preferences/ and locating the preferences file (com.literatureandlatte.scapple.plist), moving it onto the desktop and then re-opening Scapple. If that solves it, you will need to redo your preferences.

  4. If by this point, it’s still not solved, go back and delete the new plist file and put the old one back. I’d open a support ticket with Literature & Latte.

Hope that helps.


So I tried your suggestions Mark, but to no avail. I’ll open a ticket and see if they can help

Paste and Match Style doesn’t “paste text only” without formatting (a common misconception).

P&MS formats the pasted text to match the cursor location. If the cursor is in italicized text, the pasted text will be italics. If the cursor is in regular text, the pasted text will be regular, hence wiping out any bold, italics, or underline (et cetera) in the original text.

I tend to use italics quite a bit, so P&MS is pretty much useless to me.

For your information, I have the shortcut set to “Paste and match style” in Scrivener and “Paste Text Only” in Nisus Writer Pro. The difference is immaterial; what I was commenting on was Keyboard Maestro hijacking commonly used shortcuts.

It’s not immaterial if a person expects bold, italics, underline, etc. or any other character formatting to survive the copy/paste. That doesn’t apply to you, perhaps, but the implied results of “paste text only” are not what P&MS actually does.

About the native Mac “Lookup” in the context menu dictionary disappearing, the quick answer is that Siri Suggestions is interfering with the regular Look Up feature at a system level on your computer. To re-enable the regular Look Up feature on Monterey 12.1 go to Apple menu ▸ System Preferences, and click on the Spotlight icon. In the Search Results tab uncheck Siri Suggestions. Now Spotlight searches only the contents of your Mac and Look Up searches only the dictionaries enabled on your Mac.

With this unchecked I was immediately able to use the Look Up feature in Scapple1.4 (1122).

Just incase Siri Suggestions is vital to you in another application, the longer answer is that Apple’s Look Up now shows personalized suggestions from web, iTunes, the App Store, movie showtimes, locations nearby, and more. To make suggestions more relevant to you, Look Up includes your approximate location with search requests to Apple. Siri now analyses how you use your device to provide personalized suggestions and better search results using local, on-device processing. You can find out more about it by going to Apple menu ▸ System Preferences, and click on the Siri Icon. At the bottom of the Siri tab click on “Siri Suggestions & Privacy…”. Select each of the apps in the list on the left to see what choices you can make. Open the “About Siri & Privacy…” button to read all about Siri and your privacy.

1 Like