Navigating around edit window....

Hi! I am just starting to try out, and very much enjoying, Scrivener, which may well turn out to be my “go to” software for story creation. Today, my first day of real work in the program, I have found one thing that might be described as a bug, and one that is a kind of irritation:

  1. If I have “typewriter scrolling” enabled for the editor window, I can’t double click on a word to select it. I end up selecting a word above or below the one intended. When I disable typewriter scrolling it works as expected. This seems like a bug to me, and it would be great if it could be fixed.

  2. Currently, it isn’t posslble to move through a text document using the “PgUP/PgDOWN” buttons. In Word, and other text based programs, if I hit page down, the screen moves down one screen, so that I can keep reading the text continuously. When I hit “PgDown” in Scrivener I move forward a lot, and I can’t follow the flow of text this way. The only way I can read my text is to use the down arrow, and advance it line by line. This is pretty inconvenient, as it forces me to focus too much on navigating, rather than reading. I don’t know if this is a bug, but it would be great if it could be fixed. (I’m not sure what the value of hitting “PgDown” is, if it moves you kind of helter skelter forward, landing you in a surprise spot! :confused: )

Thanks for a great piece of software!


Thanks for your interest in Scrivener! The two issues you describe do sound like bugs, especially the first, but I’m not able to reproduce either of them–selecting text with the mouse doesn’t move shift the screen for me (as it shouldn’t–this was fixed in the last beta, so only keyboard input should center the page on the insertion point) and the page up/down keys do jump an entire “page” in a lengthy document. What hardware are you using (and what version of Windows)? That may be making a difference. Definitely we want to figure this out if it’s a problem on some systems, so thanks for any details you can provide!

Hi back!

Okay, well, I feel kind of silly, but I can’t get the “double click to select” problem to repeat. It was happening all morning (meaning, if I double clicked to select a word, my cursor would end up on the line above or below the word). When I disabled typewriter scroll, it went away. Now, whether or not typewriter scroll is enabled, I can’t get the behavior to repeat. I did spend the first part of the day doing a lot of research, adding links and .htm and .pdf files to the research folder, so maybe I introduced some strange behavior and then turning scroll on and off was like kicking a car and cleared it out.

As for the page up/page down feature-- that, too, has been behaving more normally tonight. At first, when I was paging up and down I had a hard time tracking where I was on the new page. Then I realized that, sometimes, the first line on the new screen ends up getting cut off, and sometimes not. When that line does get cut off, it has the effect of completely disorienting me, so a relatively small drop in text feels bigger than it actually is. My default font is Times New Roman, and my default spacing is single, so I would notice slight slips in the window more than somebody who was using double space. Interestingly, in full screen view, the window never slips-- page up page down work perfectly.

I apologize for the faulty report, and thank you so much for your courteous reply. If it happens again, I will try to remember what I was doing before.


AHA. It happened to me again, and I figured it out. If one document is selected in the binder, page up/page down works as expected. If two documents are selected (which I had been doing yesterday when everything was all wonky), page down will leap forward many screens worth. Try it, and see if it happens to you. It happens to me, reliably. And, now that I know what causes it, I can just work around it. Plus, I feel like Sherlock Holmes. :wink:

Excellent, Holmes! :slight_smile: I do see it now–or something like it, anyway. When there are multiple documents open in a Scrivenings session, page up/down jumps from the top to the bottom of each document, skipping everything in between. I did have it work as paging on the first of the group of documents in one trial, but of course since then it’s just done the top/bottom thing, so now I have to play Sherlock and figure out what I did differently the first time, but in any case, consistency in the views would be nice along with a separate keystroke for jumping to the top and bottom of each document.

Meanwhile, the Ctrl-Up/Down keystrokes might help you; that jumps per paragraph.

And I also see that the typewriter scrolling in the Scrivenings session still jumps with the mouse, so thanks for that catch, too!

Most welcome. I did a hard sell of this program today to a friend in my writer’s group-- although I didn’t have to work very hard. Just started showing her the document folder I had created, and she said, “Wow, I’ve been waiting for this program my whole life.…” :smiley:

I’m teaching a Scrivener workshop this week and I just encountered this same issue. On Windows (not Mac) in Scrivenings mode, Page-down seems to take you to the end of the scene rather than the end of the page. It works correctly in Mac.