navigating between binder files

Hi, I’m fairly new at Scrivener. I have a lot of files in my binder, and I am confused about something that seems to happen sometimes, but not others. I am writing in one main file, and I click on another to look at it, perhaps cut and paste something. Then I want to go back to the one I was in previously. But when I click the navigation “back” arrow at the top left, I end up often in the file just above whatever file I clicked into, rather than returning to my main file. Can you explain if this is just the way it works, or what I can do to easily navigate -in the way that Web pages work - back to the first file after clicking away from it? Hope that makes sense.

Hi Amy, and welcome! I think I understand what you’re describing, but I’m not clear if there’s some bug you’re running into here or just confusion about buttons. There are two sets of arrow buttons in the editor header; those on the left, which I think are the ones you’re clicking, should act like backward/forward navigation buttons in your browser, moving back and forth in the editor history. So this should be doing what you want, i.e. with a binder setup
if you have document A loaded in the editor, then select document D to load it, then hit the back button, you should see document A again as the most recently loaded document in the editor, rather than getting document C. The other buttons on the right move up and down to the previous and next documents, so here, if you had loaded doc A, then doc D, and then clicked the up arrow (go to previous document), this is would load C as the document just before D in the binder.

So if you happened to be sometimes hitting the one button instead of the other, that could explain it, but if you’re always clicking the back button, there may be something going quirky with the settings. Moving forward, try clearing the document history for each of your split editors, just to start fresh; that may clear up the issue, but even if not, you may be able to more easily notice a pattern that seems to trigger the incorrect behaviour of the button. To clear the history, click into the editor to focus it, then choose View > Editor > Clear Document History.