New(ish) Linux user, having problems installing on Fedora 20

Hello all! I’m not sure if this is something to make a new post for, and if not please bear with me (or let me know)!
I’ve been a lover of Scrivener for a couple years now on my Windows 7 (now Windows 8.1) laptop, but I just recently installed Fedora 20 on my desktop and have been far more enjoying writing here. It’s an exciting feeling!

Anyway, I tried to install the Scrivener beta on my Fedora 20 machine just now, the 64bit version (I thought my machine was 32bit but after checking up on that, it appears I was wrong) and used the tarball download. I extracted this with Files into /home/myusername/LiteratureAndLatte, putting the Scrivener file in /home/myusername/LiteratureAndLatte/bin/Scrivener. I had a little trouble figuring out where to go next, as the “unofficial guide” seemed more geared toward Ubuntu (again, please be patient, I’m still learning between the different distros!), but I managed to find this from the download thread here:

And I followed these instructions pretty closely. They worked fine the first time when I ran through with the 32bit version (I thought it was correct, apparently was wrong), and when I ran through again from scratch with the 64bit version, the install failed. The last line did not do anything for me either time.

I then returned to this thread, and followed it starting at the Scrivener/Linux icon image, and before the graphical root option. This all seemed to work just fine, and it created the shortcut with the image that when I clicked on it to run the program, told me it was “untrusted.” I clicked the “trust this application” option, and the window went away. I attempted to run the program here, and from the ~/LiteratureAndLatte/bin/Scrivener location, but neither one seemed to do anything at all… no errors, no nothing.

I finally added the graphical root option to the executable desktop file referenced in the last link, and now when I click the icon to launch the application, it tells me

I apologize for the long and drawn out description, but I would dearly like to get this working (even if it is buggy) on my Fedora system and I’m still too inexperienced with Fedora and Linux in general to know where to turn next.

Any help or ideas would be very heartily appreciated!

I look forward to talking with all of you!

Sorry to state the really obvious, but are you sure you’re not running 32-bit Fedora on your 64-bit machine? A 32-bit OS will run on 64-bit architecture (though not the other way round).

If you have 32-bit Fedora, you need to install 32-bit Scrivener, even if your machine is 64-bit.

You can find out your OS version with uname -a .

Don’t be sorry–I really am that new.

I did check, and I’m fairly sure you’re right, and I probably am running a 32-bit version of Fedora. This computer is rather old, and I didn’t think to check that when I installed Linux. Mental note for next time.

I did actually install the 32-bit version of Scrivener first though, thinking at the time that this machine was a 32-bit. As I remember, I had little luck with it either.

I’m not certain if it’s possible that the 32-bit OS on a 64-bit machine could be the culprit?

Either way, thank you for your input!


I ran through the above quoted “instructions” one more time, ran across an error with libpng, and after a bit of internet searching I discovered some additional packages were needed, I guess to resolve some sort of dependency. (I’m assuming it was the later version, 15, I needed) After all this was done, I started Scrivener and it’s running fine now.

Sorry for the newbish questions–I’m thrilled to have it working now!

Thanks for the help!

Great you got it working! Welcome to the Scrivener Linux club :smiley: .

I confidently predict this will not be the last time a package drives you crazy with its dependencies. :wink: