No luck - Kubuntu 12.04


dpkg -i --force-architecture (scrivener package)

Looked like it installed, but when I try to run it I get the following:

/usr/bin/Scrivener: 2: /usr/bin/Scrivener: /usr/share/LiteratureAndLatte/bin/Scrivener: not found

I checked those locations on the drive, however, and the files are there. Thoughts?


I was thinking the need for getlibs was only if you wanted spell check, which I don’t care about. Turned out to be a library dependency issue. I installed getlibs and then re-installed Scrivener and it works :slight_smile:

Did you try running Scrivener from the GUI’s user menu? I installed on an upgraded Xubuntu (was Ubuntu 11.10, converted to Xubuntu in December, upgraded to 12.04 this weekend) without any issues.

Kubuntu 12.04 seems to be a problem child. I haven’t been able to get it to work on it, but it does run in Ubuntu just fine. It seems to be linked to the way the libraries are loaded, or something. That’s about as far as my knowledge will take me, though.

Weren’t other people on Ubuntu 12.04 having issues, though, too? Or was that a separate issue?

Scrivener actually runs under Ubuntu 12.04. It must be another issue. Was it the spell checker?

Hrm, could be. I thought it was a Qt error, as well, but I could be mis-remembering.

I’m using Xubuntu 12. 04 LTS and I tried to upgrade from an older scrivener beta but it didn’t work. I uninstalled and reinstalled and it worked fine. Try downloading the .deb package again from the link above (It’s the second of two announcements) and installing it through the Ubuntu software center.

Actually, I’ve been unable (repeated attempts) to get Scrivener to run on Ubuntu 12.04 64-bit. I’m relatively new to linux but no stranger to computers in general and I can’t make heads or tails of it. Using the command line to install it doesn’t work, and neither does downloading and installing the 32-bit libraries. Pretty frustrating.

Try using Virtualbox and a 32 bit install of Ubuntu (or Mint).