Non-breaking spaces removed when compiling to MMD?

We have non-breaking spaces in some documents (Opt-Space, unicodes 00A0 and 202F).
But when compiling to MMD, these non-breaking spaces are removed. (  works, but kind of unpleasing when viewing.) Anyway to keep them?

You could use the replacements from your compile format.
Work your document using normal non-break spaces, but when compiling have them replaced by  . They should be invisible just the same in, say PDF, or whatever final format you’ll compile to. (?)

If you first compile to MMD, I can assume that it is for further editing (?).
In that case, perhaps you could do the reverse replacement if needed once you land in that second software.
An extra step, but you won’t have to make your eyes trip on   in Scrivener.

I can’t reproduce this using either plain MMD or plain Pandoc compiles, I get U+00A0 preserved in the output markdown file just fine. I suspect there is some setting somewhere doing this, if you can make a minimal test project we can try to reproduce.