Not allowing me to paste?

So I’m using version 1.60 for Windows and for some reason it’s not letting me paste anything into any files. I can create a new file, type into it - but if I try and paste anything in, it won’t allow it. It just won’t do anything.

Using Windows 8 64bit. Mostly trying to paste from Googledocs or notepad.


Are you running ConstantGuard or any other security software? There was an issue with ConstantGuard where if it didn’t have Scrivener on the whitelist it would just close the software entirely when trying to do various actions like cut and paste; you may be seeing something similar, though less drastic. Adding Scrivener to your security software’s whitelist (or removing it from the blacklist) should fix the problem if that’s the cause.

If that doesn’t do it, some additional information would be helpful. Are you pasting via the menu command or just by the Ctrl+V shortcut? Can you cut and paste text within the editor in Scrivener (cutting any outside programs from the equation for the moment)?

Using WebRoot (antivirus) and just checked and made sure that it’s allowing all of Scrivener’s stuff to go through and it is, so I don’t think that’s a problem.

I’ve tried pasting through both the menu command and by control+V. Neither works. I can copy-paste between within the editor, yeah, just tested that. Just can’t bring in anything from an outside program.

Any idea what’s going on? It’s making it rather difficult to use Scrivener at this point since I’m doing a lot of work on the go. :frowning:

Sorry for the delay; no breakthroughs, though, I’m afraid. But have you tried reinstalling Scrivener from a fresh full download? I’d give that a go, as it might just be a corrupt install. Do a complete uninstall of your current version first, so you start with a blank slate, then download 1.6 from here. Uninstalling will not affect your existing projects, which are saved externally to the program (in your Documents folder by default, though you may have chosen another location when creating the project). You can also save your program settings before uninstalling by going to Tools > Options… and choosing “Save Preferences” from the Manage menu button. After the uninstall/reinstall process, just return there to load the saved preference file.

Try creating a new blank project and pasting into the “Untitled” document there–any luck? If it’s still not working, go into the Scrivener installation directory and launch the “clipboard.exe” program there and try pasting into the top of that, then select all and copy in the lower section and save it into a plain-text file and attach it here. Given you’re having the problem just copying from Notepad, I suspect this won’t tell us much, but at least we can check.

The full re-install worked! :smiley:

Thank yooooou. :smiley: :smiley:

Oh good! Thanks for reporting back!

So I’m sorry to say but this glitch is back…in a very odd way. I just noticed it after updating to the newest update.

I can literally copy from one Scrivener project to another, but it won’t let me copy from notepad into Scrivener.

I can copy from Google docs into Scrivener, but the formatting is atrocious and therefore I avoid it. I use Notepad as an intermediate to void the formatting, but it’s refusing to paste into Scrivener. I tried a full uninstall and re-install just in case.

Haha I don’t even know what to do with this.

Interestingly, when I’m pasting from Googledocs, it only works with the Cntrl+V command or with ‘paste’. It will not paste if you select ‘paste and match style’.

Ah Huh… some one with my same problem driving me batty.

Scrivener latest update. Problem started about the time updated from Win 7 64 bit to Win 8 and then within a few days to 8.1 64 bit.

Nothing posts INTO Scrivener with paste either way Ctl-V or past in Scrivener. Works fine between zillions of other files, text, Word, two e-mail systems etc etc. I do not have IE running, nor Skype installed. I have many programs used daily and Scrivener seems so far to be the only one that won’t take paste from any others.

As the last poster said it WILL paste BETWEEN Scrivener files.

I disabled my clipboard managers Clipcache so it is not the problem. However it is the solution to a work around. If I have clipcache running where it “caught” the copy I can “quickpaste” from it into Scrivener.

I almost always have clipcache running and never interferes with any other “copy” and if kill it paste into Scrivener still does not work.

I also use Webroot (as earlier poster who found that not the issue).

It seems has to be a glitch with Scrivener interacting with at least Wins 8 64 bit unless others here have other systems having the issue.

This is quite strange. I am running Windows 8 and 8.1 and can’t replicate this issue on either OS. However, there does seem to be issues copy and pasting on some Windows 8 machine - not sure if it’s related? … -Paste-bug

There is a program in the Scrivener directory called clipboard.exe.
C:\Program Files (x86)\Scrivener\clipboard.exe

I suggest copy and paste the text that Scrivener doesn’t seem to recognized into the top text area of the Clipboard Capture tool and post the contents of the bottom text area ‘Clipboard Content’ in a plain text file on this thread and I will take a look to see if there are any obvious issues.

Basically the Clipboard Capture tool reveals the raw MIME data that you have copied in the top most text area in the bottom text area.

Thanks for link and ideas… on what doesn’t work… the Clipboard Capture bottom window just shows as plain text. Ironically more complex rtf format does paste into Scrivener.

Details of my experimentation:

The Scrivener clipboard capture is interesting.

If I copy something as plain text it shows as such in bottom window as plain text but usually… will not paste into Scrivener. But when I first started experimenting it did a few times, than stopped :cry:

But it seems to convert it in the upper window to rtf text and when copy the rtf text it WILL paste into Scrivener :smiley:

Thinking my first few times pasting plain text worked though maybe it worked awhile after a reboot.
But rebooted again and txt text won’t paste. But it did briefly earlier when started this experiment.

This may explain why I can paste from with Quickpaste in ClipCache that captures all clips because it seems to do the same as the Scrivener clipboard - converts it to rtf which will paste into Scrivener but not just text…after a few copies/clips.

From the good link and others this appears to be a fairly widespread Windows 8 issue but with different solutions and combinations of programs. I tired some of the suggestions, like num-lock on and off, I don’t have bluetooth, and I also have 4 monitors so tried to see if copy paste in same monitor vs different and some of the other ideas. None of which worked consistently.

Sometimes I can paste into Scrivener with just paste and will work but not as paste and match style … but just did again and confirmed plain text won’t paste as either now that I have been experimenting with it.

But I can’t find other consistent patterns other than seems to always…so far… paste rtf fine just usually not plain text…

From websites, html will paste but not paste and match style.

This is all on win 8.1 running from desktop not Metro. Using Start8 so never have to look at Metro and desktops look just like Win 7 plus some features.

I also tried on laptop also running 8.1 with same result, plain text won’t paste but rft and html will. I am using SugarSync which works great to sync Scrivener so can use in both places of house. Often I copy stuff from various sources paste into text editor (Textpad) to rewrite or just use parts etc. Then use Scrivener to organize by topics I use for newsletters and other things. Use to use OneNote but much prefer Scrivener now… and it pasted txt fine when using Win 7. At least the workaround is fairly easy.

I have a similar problem: when I paste a formatted citation from Mendeley to Scrivener nothing happens in the document explorer window, but it does paste to the synposis window. If I paste first to, say, Word then to the document explorer window it works. Why does this occur and how can i fix it?

I have a very similar problem: I was coying and pasting from tables from word and suddenly, it doesn’t allow me to do it anymore. No way. Anybody knows how to fix it? It is a huge problem. :cry: :imp:
Thank you for the help :slight_smile:

I have this problem too. I want to cut from my genealogy software into Scrivener, but it does not work. I can cut from the genealogy software into, say, Word; and from Word into Scrivener works fine. But not direct. I am using Windows 11 with my files on Dropbox.

There is no such version and never was, I think. The latest version 1 is 1.9.16 (November 2019) and version 3 is at 3.1.1, so I wonder what you’re looking at.