(NOT) Importing pictures in NaNoWriMo edition

This is weird. I have a bunch of pictures that it would be significantly easier on me to deal with if they could be seen from within Scrivener. I must be doing something wrong.

I have dragged them onto the Corkboard view, under Research. Nothing. I have ensured that I am on the Research folder and then attempted to do the File > Import > Files thing. Again nothing.

What precisely is it that I need to do to import a file or three into the Research folder? (I am not automatically assuming that the program is at fault - I may well be doing something wrong.)

This is happening (or not happening, as the case may be) on both an XP Professional , SP3 computer, and on a Windows 7 Professional laptop.

What format are the graphics saved in? Currently you can’t import directly onto a corkboard view; you have to drag stuff to the binder. So that explains that part, but importing via the menu command ought to work.

Other than a single SVG file that I’m not too worried if it doesn’t import, everything else I’m trying to get into Scrivener is either a GIF or a JPG. (And I just tried a drag and drop from my desktop to the Binder, dragging it specifically onto Research. Still no dice.)

They simply will not transfer into Scrivener for me, and since my searches didn’t find anyone else with this problem, I’m pretty sure it’s something I’m doing wrong.

Funny thing is, I checked the options, and made sure that it’s giving me the warning about importing (I’d shut that off before), and the program is at least starting the routine to import a picture.

Note that attempting to import a document into the main body works.

Okay - now I’m REALLY confused. I tried a different JPG - and it imported without a single problem. The files aren’t corrupted, because I can open them in Photoshop and GiMP without error messages.

Apparently ONLY the files I want are not importing.

I solved it, and learned a valuable lesson. I had stored the Artwork folder (imaginative name, huh?) in the .SCRIV folder, for ease of locating the files. They would not import from there.

When I moved the folder up a single level, to the NaNoWriMo2011 folder (another imaginative name), which is the holder for my .SCRIV folder, the files now import without a single hitch.

Oh, and the files dragged-and-dropped onto the Research corkboard (sub-corkboard?) without a problem, by the way.

Ah, that could probably use an error box or something at the very least. I’ll make sure Lee knows about it.

Oh, and cool that importing straight into corkboards are working now. I knew that was on the list of things planned to be implemented but didn’t realise it was already done.

Glad to have been of some help.

And you’ll note that I was right, at the beginning of my starting this thread? It WAS my fault! grin

Keeping the customer always right since 2006. :slight_smile: