Not recognizing shortcut defined in macOS System Prefs

I’m having an issue with Scrivener not recognizing shortcuts that are assigned in the System Prefs. For example, I have a shortcut assigned to “No Style” in my macOS System Preferences under Keyboard>Shortcuts>App Shortcuts>Scrivener (see screenshots) but sometimes Scrivener doesn’t recognize it. This is not always the case, sometimes it does work, and it also doesn’t happen with all Shortcuts. It specifically happens with the “No Style” command. In the screenshot, the Shortcut for “Block Quote”, for instance, always works without problem. Unfortunately, I haven’t figured out what exactly causes it so I can’t provide step-by-step instructions yet.
But I’m wondering if anyone else has experienced this or might have some suggestions for where I should start digging. (Restarting Scrivener doesn’t help, I tried that already.)

BTW, I’m quite hesitant to use the “bug” tag, as I don’t know whether this is a Scrivener issue at all or some macOS quirkiness (doesn’t happen with any other apps, though) … so please if this doesn’t qualify as a bug, forgive me and the moderators should remove the tag. :slight_smile:

Forgive me, but is there any reason why you’re trying to override Scrivener’s built in shortcut for no style (cmd-opt-zero) with the exact same shortcut?

I wonder if that’s somehow causing the issue?

Uhm … how did I miss that there already was a shortcut?! :confused:
And then how did I manage to come up with exactly the same shortcut?!? :flushed:
This is really bizarre, because I normally try to use all the default shortcuts that an app provides, so I clearly didn’t see this one – or maybe in some earlier version of Scrivener there was no “No style” shortcut and I just never checked back …

Either way, yes, that’s what was the problem … just deleting my own shortcut solved it …
Thank you so much for pointing that out!!

(And sorry for wasting people’s time … :man_facepalming:)

No problem! Glad it helped :grinning: