Not Responding

I’m sure I’m not the only one. But when I load the Beta, just about every time I move my mouse over the program, it goes into whiteout/not responding mode. My laptop is far from the most powerful. After a few moments it clears up and I can proceed. It happens at start up and randomly while I’m working. My first post here. If more info is needed I can provide. Thanks! Love the product!

Several issues like this have been noticed.

This usually happens to me when I select in the binder:

  • more than dozens of large documents (over 5000 words each)
  • many documents (I noticed it with 400 very small documents, but haven’t checked to see when it becomes noticeable to me. I have a middle-to-high-end box, but what really drives this is disk read speed, I’m pretty sure).
  • documents with many images (they increase the size, and the time to load)

It also happened, at one point, when I had installed the Scrivener Beta in the same directory as the current version of Scrivener for Windows (1.9.x). I uninstalled both, and reinstalled both, into separate directories (Scrivener and Scrivener3). Problem ended.

And it happened once for no apparent reason. I’d installed a Beta into Scrivener3 directory, but something was off (delays in loading). I uninstalled the Beta, deleted the directory reinstalled the Beta into Scrivener3 directory, and the problem went away.


Scrivener loads everything you select. If you select one document, just that loads. If you select the entire project, it can take a while to load. Especially if the documents have any complexity to them. A small document can have complexity (lots of font and style changes, for example), and those take longer to load. My 400 document project, for example, had several font and style changes in each document (12 words per document). Total of about 5k words. It took over a minute to “select all.” A project I have open right now has 500 documents total (62k words total), but most of them are not that complex, and it “selects all” in under half a second.

On startup – if you have checked “Reopen projects that were open on quit,” it will reload those projects. If they are large, or there are many documents, that will take some time.

A project is made up of a lot of small files. Every document can be several files. If they involve images, those are more files to load.

At some particular size, a document takes significantly longer to load. I haven’t checked where that limit is on my box (I’m pretty sure it’s hardward-dependent), but it’s over ~5k words. At ~5k, I notice the delay in loading (it’s under 2 secs, but I notice it).

You may be able to rearrange your project to take less time when loading. Reduce the number of font and style changes if possible. Split large documents into multiples if possible and if that makes sense.

However, there’s another issue. If your documents are converted from version 1.9.x, they also may take longer to load or to select, or to save any changes, and they may just act screwy. So, if your project is converted, you may want to create a new blank project, import the old one, and move your documents into the appropriate places in the new project. This may speed your access times, or it may not. Your mileage may vary. Backup first, because this is a Beta and your project might break (shouldn’t. I haven’t had that happen. But it might).

Not sure any of that helps. If you’re seeing seconds of delay, and not minutes, on a lower-end or older laptop, I’d think that’s expectable, given how Scrivener works. But my Toshiba S855 (i7-3630QM)(2012 release) laptop handles things just fine, so perhaps some of the ideas I’ve mentioned may help.


rwfranz, has written a good summary of possible Scrivener slowdown reasons. Thank You, rwfranz!

I would like to add that upgrading your v1.9 project should not impact the speed of the project in Scrivener v3. If there is a reason for the delay, it is something else in the project but not the project upgrade.

Something that happens very often to users is importing large images or images using very high resolution in documents or inside the Binder. When you combine this with a HighDPI display, but a slow computer and a slow graphics card, you hit a wall. I know a lot of writers choose slow cpu and graphics card because “hey I use it only for typing text”, but the nice image you found and imported is a 4K image, which comes too much for your typing purpose computer.

Scrivener does not downscale your images, to preserve quality, but unfortunately large images or high resolution images eat a lot of resources and cause significant delays.

Please, be very careful when you import images inside your Scrivener project. Anything with resolution above 120dpi or a document image bigger than 1920x1440px should be resampled or use an up to date computer.

Now I have to go find the 1.9 projects that bogged the Beta, earlier in testing.

I have a similar situation with a folder of over 400 files. Anytime I use OUTLINER mode it hangs for over a minute even though there is little in the files. Why is Scrivener loading all that info in outliner mode? It appears that only the basic info is being shown to the user. The rest of the interface responds well otherwise. OUTLINER mode would be very useful if it worked but now it renders Scrivener entirely useless. I’ve reconfigured my folders and no happiness ensued. I still need to deal with all those files – now in multiple folders – and I can’t do it.

ALSO: Should we re-report bugs that we once submitted on earlier betas and haven’t been fixed yet? Or, given how buggy the current beta is, should we just wait? I only want to know what is most helpful.

Outliner mode is a little slow. 400 files is tricky; as I mentioned, I had 400 documents with just a few bytes in each, and it took a while to select all. Outliner was slow. They’ve sped it up as much as it may be, at the moment.

However, there may be a way to speed the project up. First, I’d try reindexing. (File ->Save and Rebuild Search Indexes). That MAY speed things up (it may not, too; I haven’t had much luck with it. But it does sometimes work, and the investment of time is small.

Second, if that does NOT work, create a new project. Select all in the Binder. Drag and drop to the new project. Close the old one. Rearrange. This may speed things up, also. I’m not sure why this works, either, or even if it will work for you.

Third, if neither of those helped significantly, try importing the old project into a new one, and then rearranging. Really, it’s another way to copy a project, but it works differently.

If either of the last two methods work, I’d zip both project directories, mention which one worked, and let tiho ask you for copies… (really, truly, the bug needs to be found, and the clue is likely in the project files somewhere).

FYI, I use one of those last two methods when a project slows down beyond my patience to tolerate. Usually Select All → copy → paste → rearrange.

As for the last question, typically not, unless they’ve reported it fixed and it really isn’t (this is mentioned here on the forums somewhere). They’re well aware of the unfixed bugs.