Notification Center disabled in composition mode

Hello, I’m hoping someone out there can help me with this. I’m using Scrivener 2.5 on OSX 10.9.4, and I’ve discovered that when I enter composition mode (which I where I spend most of my writing time), the Mac Notification Center is disabled. Any alerts that happen during that time will not make any sound, and any banners that appear during that time will have disappeared by the time I exit composition mode. Alert windows are still there, but aren’t visible when I’m in composition mode, so there’s no way to know they happened.

I understand it might be desirable to some to have alerts suppressed like that, but for me it’s no good. Is there any way to change this behavior? I read another post that claimed this was a feature of Notification Center, but I’ve tried several other apps and they all leave the Notification Center enabled when they’re in full-screen mode (even Scrivener’s other full-screen mode doesn’t affect Notification Center).


Thanks for the report Dave! We’re taking a look at the issue and will see what we can do to resolve it. It definitely does not seem to be working the way it should. In fact we have special Scrivener notifications that are meant to be running exclusively in Composition mode—such things as alerting you when a save is complete, when document, session or project goals are met and so forth—so it definitely not intentional that notifications are seemingly disabled.

Thanks for the reply. I’ve done some more fiddling around with it, and have found a workaround that might provide you another data point as you look into it: if I first go into Full Screen Mode (which I think uses the built-in OSX full-screen capability) then Scrivener gets moved to its own Space, and if I enter Composition Mode from there, then Notification Center will remain on.

Hope that’s helpful!

Interesting! That is one variation we did not see, I’ll add this to our notes.

Thanks for that! This seems to work only if “Hide main window in composition mode” is not selected. With that checked, the notifications still do not appear even when entering composition mode from FS.

I did indeed have that option unchecked on mine, but just tested it with it checked, and as long as I’m in FS when I enter composition mode, Notification Center is not greyed out, and I’m still able to receive notifications. Not sure why it would be different from one system to another, but that’s how it seems to work on mine…

I’ve done some more testing with this, and I think part of the issue is switching desktops while in composition mode or in Full Screen. With the same preference settings, I can enter composition mode from FS and have notification center disabled, then switch back to the other desktop, click in the Preferences pane (without changing any settings) and then switch back to the composition mode desktop and suddenly notifications are enabled. So, e.g.:

  1. Open a project in Scrivener
  2. Open the Preferences and leave all the options in “Composition Mode Set-Up” enabled
  3. Load that project to Full Screen mode (notifications enabled)
  4. Load the document in composition mode (notifications disabled)
  5. Switch desktops back to the Preference pane and click in it to give it focus
  6. Switch back to the Full Screen composition mode desktop: notifications are now enabled

For further excitement, start with step 3 and as step 4.5 open the inspector in composition mode. Reliably when I switch back to the other desktop and click in Preferences for the first time, the inspector floats after me even though it shouldn’t, and that it does so seems to prevent the notifications from being enabled–if I continue with steps 5 and 6, notifications are still disabled. But if I repeat 5 and 6, the inspector HUD stays in the FS desktop like it ought, and then notifications are enabled.

So this seems like an interesting quirk of Full Screen and Desktops in 10.9.4. I haven’t played with it yet in Yosemite.

That’s completely nuts. There’s definitely some difference between the behavior on your system and mine. For me, following your directions still yields a working Notification Center. The only thing that seems to have an effect on it is whether I go into Full Screen before entering Composition Mode.

Also, if I understand you correctly, my behavior with the Inspector HUD is slightly different. As you said, it does float back to the other desktop when I switch to find the Preference pane. But it does that every time I switch, not just the first time I switch and click on the Preference pane. It never stays on the Composition Mode desktop.

No idea why our two systems would function differently. Maybe it’ll all be fixed in Yosemite?

Well, I said it was crazy. :slight_smile: It’s something with my other software/system settings, I don’t disagree. I was just correcting my earlier statement about it being the specific preference settings. Further testing in the same environment suggested that it wasn’t the settings, just the fact that I was switching desktops to modify them that made the difference. The main issue, that notifications aren’t showing at all when you enter composition mode without going FS first, I see the same as you. The full screen thing I’m running into is some focus issue which is specific to how I’ve got things set up on this machine and might not be related.

Just an update on this: the problem is deeper than Scrivener can handle. This actually appears to be an “intentional” feature of Notifications, where using a display that hides the menu and dock automatically suppresses them. The bug seems to be that it also ignores them forever, and we’ve filed that with Apple.

In the meanwhile, you could try using Growl instead of Notifications.