Numbered lists/bullet points

I often have problems with numbered lists where when I go the next line it starts again at 1 instead of the next number. I have this happen in a number of applications but it’s worst in Scrivener. I assume it’s that I don’t understand something about how numbered lists work. It usually happens when I cut lines out or paste new lines in.

Today I’ve opened a document I made earlier in the year, the last numbered point was 3 and I can’t for the life of me get the next line to be 4. It keeps reverting to 1.

It would also be useful to be able to start the list at 1. again intentionally.

Any ideas on what is happening?

Running Monterey OS10.6.6

The correct way to get line 4 is pressing enter at the end of line 3. Is that what you’re doing? Then, to stop the list, press enter twice.

yes, that is what I am doing. But a 1. appears instead of a 4.

Could this be a factor? Current Scrivener 3.3.1 trying to work with an ancient version of macOS?

macOS 10.6.6 which appears (various internet sources) to be more than 12 years old. The earliest “Monterey” version was 12.0 in Oct 2021 (almost two years ago). Current version of macOS is 13.4.1 (c). I don’t know how far back with macOS version Scrivener tests with.

sorry, that’s a typo. Monterey is OS12 and I’m running 12.6.6

I just tested to remind myself how this all works. “Muscle Memory” for many years so I’ve kinda forgot …

What @drmajorbob says is correct. Re your comment about cutting and pasting, I can cut an intermediate line formated as a numbered list, but I suspect that whatever you are pasting in has some (invisible?) characters that confuses the list? If you show the “invisibles” is there anything odd about the tabs and pilcrows? Here is how it looks for me. All text lines have “No Style” applied.

Screenshot 2023-07-22 at 08.56.56

Edit: I notice that when I cut a line in middle, numbers not correct. I just select the entire list, and re-do Menu: Format → Numbered list. (again Muscle memory kicking in as I’ve always done that and moved on). I don’t see anything odd or unexpected going on.

Brilliant, that’s fixed it. Thank you so much because this has been driving me nuts of ages.

(I agree there is something invisible that I can’t see happening, but even when I select all to show the purple bits like in your comment, it all looks normal to me)

1 Like

There is also a “Re-number List” contextual menu command that appears when right-clicking on a selected list. In my experience it tends to not work as well as just toggling the list off and back on though, particularly where cut and paste has been used. I suspect doing that essentially creates its own self-contained list on the clipboard, so when you paste one list line into an existing list, you end up with three adjacent lists, and re-numbering will only work within the scope of one list at a time.

As for avoiding it, sometimes you won’t be able to, but if you are cutting and pasting mainly to move lines around within a list, check out the Edit ▸ Move ▸ Up|Down menu commands / keyboard shortcuts. That’s a lot easier than cutting and pasting in my opinion, and automatically renumbers as you move things around. They use the same shortcuts you would use to move binder items around in the sidebar as well as outliner & corkboard, as well, so you get to learn two very useful functions with one bout of memorisation.


I have a numbered list of around 230 people; every now and again the numbers get messy when I add information, and skip one number.
So normally you can force them into re-education by backing up one, then entering a paragraph again. But sometimes this doesn’t work, and the list now refuses to believe it’s numbered. Here’s an example (which I’ll delete after you kindly helpers have helped me. Sorry that these aren’t as obvious as they should be - there’s too much information between them to screenshot them as a single item.
Bushell is No 20, and Byrne, the next person, should be (and was) No 21, but something went doolally and he’s now No 22, knocking out all the following numbers. I’ve tried deleting the number and tab and then paragraphing again, but the app stubbornly refuses to make him No 21 and correct the following numbers.

Can’t see how to add the pictures; I’m using an old computer…

I tried renumbering the list the last time this happened, but then I ended up with a list that contained sets of numbers within other sets of numbers. I spent hours on several days removing the numbers to get it right. Is there any way to tell the list “Continue from here”?

I tried renumbering the list the last time this happened, but then I ended up with a list that contained sets of numbers within other sets of numbers.

That’s what we were speaking on, how that command doesn’t work if you really have several lists one after the other. It is a simple matter to repair a broken list.

Can’t see that.
Screen Shot 2023-08-14 at 16.08.36

This is a picture of the contextual menu, and I don’t know why. You know how to turn list formatting off, and how to turn it on—that’s all we’re talking about here.

  1. Format ▸ List ▸ None
  2. Format ▸ List ▸ 1. 2. 3. (or whatever).

Or the button in the Format Bar, like normal.

Oh, sorry, I thought you were saying to right-click on the selected list to get the contextual menu with the renumbering. I’ll try the Format>List biz.

Nope, Format > Lists > None just removes some of the numbers and leaves others there. This has made it worse.

To give you an idea of how it looks, here are three of the people in the alphabetical list now; Brady should be No 12.

I should explain that there’s a whole run of names - Bermingham, Berry, Boland, Bradley - whose paragraphing hasn’t caused them to be numbered with the rest. I assume that there are similar gaps in numbering down through the list.

Edit: Weirder than I thought. That run of names isn’t numbered, but the numbers start up correctly after them, so it’s (in effect)

1: Alexander
2: Barret
4: Byrne
5: Carney

If removing the list formatting left some numbers hanging around, then they aren’t part of any list, and rather are text that has been typed in manually at some point. You probably would want to clean those out, so that the list can handle numbering itself, once you apply it back again.

That can sometimes happen if lists have travelled around a bit between programs. Every other word processor or rich text editor does things slightly differently, and converters do their best to keep up, but I’ve noticed lists in particular can be very picky and it’s easy to end up with “double bullets” and such. But I’d imagine it’s even possible to end up with that happening in Scrivener all by itself too, with enough cutting and pasting and moving things around. It’s a very fragile feature.

How can I tell which is which though?
And what about that whole run of names that have no numbers?
Edit: I don’t think I’ve added any numbers, though I have deleted some physically over the weeks that this has been going on.
It may be a software clash all right; this old MacBook Air, which I like and trust, refuses to update past High Sierra. I suppose I’ll have to transfer the list onto the nasty newer Air.
Edit again: I have transferred the list to the horrid newer Mac, and sure enough selecting all and telling it to make it a list with 1) 2) 3) etc works. It’s done what it did before - retained the earlier numbers - which looks ugly, but at this stage I have to admit I’m beaten. Choosing “None” had no effect.

Yeah, it’s probably fruitless to try and speculate why some of your markers ended up turning into regular text. It doesn’t matter too much and you’ll likely never be able to avoid it entirely. So it is just something to be aware of, and when it does happen, to know that the best thing to do is set the whole affected list to “None”, delete the redundant markers that are left behind with the Delete key, like normal text (because that is all it is at this point), and then select the whole thing again and add numbering back.