Odd Vanishing Text

I had three projects open on my computer. I was reading a scene in one of my largest stories, and when I clicked on the next item in the binder, the editor went blank and there was no text where there should have been. Confused, I clicked back on the item I had just been in, and poof, that was gone too. Starting to panic I flicked through everything, and it all vanished as I clicked on it! I looked on the corkboard and all seven cards were blank.

Feeling safe that I had everything backed up, I closed out of that project, and looked at my next one. The same thing happened in that one. Click and vanish. I closed out of that one as well (afraid of clicking on anything else, because clearly I wasn’t helping matters), and tried in the third project. Try as I might, I couldn’t get anything in that one to vanish. I closed out of it as well and reopened the two projects with the disappearing text. Everything was restored! All the text was there! The notecards were fine, everything is great.

That was the strangest thing I’ve had happen in the betas so far, though. I have no idea what caused it. I’m trying to reproduce it, but I haven’t been able to so far. Everything that disappeared was in the research folder. I’m on Windows 7.

EDIT To add to this, I also had a website page in both projects where the text disappeared, and neither one of them would show up either. They were still there, but the editor stayed blank and they wouldn’t load.

Yes, this definitely is an odd one. If you remember any other details about what might have triggered it or if it happens again, please post! I haven’t seen anything like this. Needless to say, I’m glad to know your text is all there and just wasn’t displaying properly.

Just to check on this one–the corkboard would show you the synopsis, not the main text. My understanding then is that both the main text in your documents was vanishing from the editor and then also the synopses didn’t load when you looked at the corkboard, so this assumes you did have synopses written on the cards. Is that correct? Were the titles from the index cards gone too? Were there lines on the cards and just no text? (I know you might not remember, but if you do it would be helpful to know.)

I don’t suppose you had the inspector open and could see if the index card there still had a title and synopsis?

And finally, this all happened in beta 024, yes? Did you upgrade while any of the projects were open?

I had the inspector open. The titles were still on the cards, but the synopsis were gone both in the inspector view and the corkboard view. There were still lines on the card, but no text except for the titles. I didn’t have those projects open when I updated.

I know it’s strange, lol. It hasn’t happened again and I’ve tried. I also updated on my Windows Vista computer and it hasn’t happened there, either. I’m starting to wonder if it was just a display glitch. Even as it was disappearing it didn’t feel like Scrivener had eaten my work never to be seen again. It was just odd as I said. Hopefully this doesn’t happen to anyone else and it was just something weird my computer did.

Thanks for the extra info. Glad it’s not happening again, although it’d be nice of course if we could figure out what caused it. :wink: One last question, to clarify on the text vanishing: the text just entirely failed to load, it didn’t appear briefly and then vanish? i.e. you clicked a document in the binder and the text from your previous document disappeared (as you’d expect) but no other text (from your selected document) loaded in its place? And the editor header didn’t say anything like “No Selection”? (Uh, that was two questions, shh.)

Right, and I’ve thought of something else that may help. Okay, you know the icons next to the items in the binder? If the documents have text in them the icons show a little page with text on it, but if there is no text in the document, then the icon is just a little blank page. Well, when I clicked on the next item in the binder, the icon switched from how it was supposed to look to blank. And the Editor was blank as well. The editor header still had the title of the document, as did the card in the inspector, but the editor was just the blank, white page, as was the little icon.

Each item I clicked on in the binder after that did the same thing. The icon would show that there was text in the document, but as soon as I clicked on it, it went blank and so did the editor.

Oh, thanks! The binder icon bug is a refresh issue; I’ve never seen it also affect the editor display, but it’s good to know you saw that in case it’s linked. (That’d be handy–squash two bugs with one shoe, or something like that.)

Any progress on restoring vanishing text from documents? I have been using the 24 Beta version for about 5 days, and noticed initial disappearing text this morning. Now, I’m unable to retrieve all text entered over a day ago. :open_mouth: Any thoughts or suggestions? How should I be backing up information in the meantime until bugs are corrected? Thanks.

Hi Bdlt,

I’m very sorry you’re having a problem with text disappearing. Lee’s looking into this, but I don’t have any answers on it yet. Could you describe in any more detail the symptoms you’re seeing? It sounds a little different from the original post in this thread, where the documents went blank as they were loaded, but everything was restored when the project reopened–that sounds like the text isn’t actually being lost from the project but that Scrivener’s for some reason not loading the document properly and needs a refresh. I’m concerned that you’re saying you haven’t been able to retrieve the text–you noticed the document was blank when it shouldn’t have been, you closed the project and reopened and it’s still blank? Did you notice the text disappearing within a single session (e.g., you saw it in the document, you switched to another document and did something and then returned to the first document to find it blank) or was it there when you closed the project and gone when you reopened later? Also, how is the text missing: are documents loading blank, as the OP described, are just bits and pieces (recent changes) made in text documents missing (but the other earlier text is still present in them), or are entire documents missing from the binder? Any information here would be a clue to what’s going on.

While we’re looking into this, I’d suggest definitely making regular backups via File>Backup Project To… and I would further suggest keeping these backups in a specific “Backups” folder so that you don’t accidentally open and work from them–it’s an easy mistake to make, and it’s certainly alarming if it happens since the initial feeling is that you’ve lost work when it’s just that you’ve opened an earlier version. (On which note, I’d definitely check to make sure you’ve been working consistently in the most recent version of your project and didn’t accidentally open an older version!) Backing up as zip files will help avoid that as well.

Additionally, using the Compile feature to export your manuscript to an .rtf file before you close your project will make sure your draft is preserved in yet another location; it’s not a backup of the whole project, but it will be a copy of your writing. You can adjust the compile settings under Elements to include the synopses and titles as well as the text if you like. To export sections of your project that aren’t in the Draft folder, you can either temporarily move them to the Draft folder and include them in compile or you can use the File>Export feature to pull them out as single documents.

Thanks for your response. I was alarmed, myself, given that I absolutely love the mac version of Scrivener (proudly used since 2007.) I hope to use the PC version as well, but I’m hesitant to do so until the vanishing text issue is resolved.

To answer your questions:
–documents appeared to load normally (with text-filled icon next to the titles), then when I clicked on the document, the text was completely missing except for the tile
–the text never returned
– text vanished from both draft and research sections, occurring as all or nothing response (vs bits and pieces)
–some documents had entire text disappear within a single session and others loaded blank after closing and reopening the file
– I tried everything from clicking on other documents and then clicking back, toggling between corkboard and document view, closing and reopening the file, making sure it wasn’t a previous or backup version, etc.
–this only occurred with my largest project, but I have only two to three documents saved in the other two projects

Hope this information helps. Thanks for the backup suggestions. Please don’t hesitate to ask additional questions if I can be of further assistance.

Thanks, that does help very much for tracking this down.

For you, meanwhile, I forgot to suggest this earlier, but have you tried using Window’s search tool to locate your text? Try typing in a unique word or phrase from some of your missing documents and see if Windows can find the .rtf file that’s part of the .scriv folder. It could be that the underlying files are just fine, and for some reason Scrivener just isn’t loading the text properly. If the Windows search brings up the files, you can salvage your text from them (copy/paste the text or copy the whole .rtf file and save it in another location outside the project .scriv folder) while we’re working on this.

This sounds something like I am having issues with. I am copying text into my project and where the text should be there are black lines like the text has been before I did the copy. Any clues on this one?


Bonnie, is it possible you’re copying your text from a source like a web page, where the color of the text may be white against a darker background color?

In that case, the text would be invisible once in Scrivener (or other formatting editors). You can fix it by doing a control-A to select all the text there. You’ll see it then due to the color inversion upon selection.

Once the text is selected, you can set its color to normal black by using the Colors icon on the Scrivener editor’s ruler.


Couple more questions to throw out here:

For the text disappearing–either of you using Dropbox or another sync service, with the project live on the service?

Bonnie–Are you saying that the text you copy in doesn’t appear in the editor or that it’s highlighted in black, matching the text color, so it’s not readable? You did say “black” and there is a bug that occurs sometimes where text copied in from other sources pastes into Scrivener with an odd black highlighting. If that’s the case, you could help out by opening the ClipboardCapture.exe from the Scrivener directory and, when you run into this error, pasting the same initially copied source text into the ClipboardCapture window (just use Ctrl-V). Then create a folder and save as the program will prompt you, and if you could then zip that folder (right click on it and choose Send to>Compressed (zipped) file) and attach it here or in an email to support AT literatureandlatte DOT com, that’d be helpful in tracking this down.

If it’s that the text is just white or otherwise invisible when you paste, could you provide any more details? e.g. is it visible if you select it with your cursor or if you scroll down in the editor?

Thanks, all.

I see I’m not the only one with this problem. I opened a project today and all of the cards that were NOT in the manuscript section came up blank (I’m using the Novel with parts template). Since I back up religiously, I loaded my backup copy and everything was fine. I’m running Windows XP and v. 024. So far this has only happened once, but its enough to make you backup your backups.

Maybe we should call this forum “Adventures in Beta Sitting” :slight_smile:


Hi Ed,

I’m so sorry you got hit by this, and glad to know you had a backup. I assume you lost synopsis text and/or document text from the project? It sounds like you noticed immediately when you opened the project and text was missing, so presumably you’d have noticed if it had disappeared before you closed the project last. Did you make your backup via Backup Project To… right before closing?

If you can give any other details at all on this, I’d really appreciate it. E.g.

  1. Is your account admin?
  2. Where are you saving your scrivener project file?
  3. What format is the drive you’re saving the project to? (NTFS, fat32, etc)
  4. What is your ‘Save after period of inactivity’ set to in Options>General ?
  5. Do you have any sync/backup services running?
  6. Did your computer go to sleep while your project was open?

Sorry to pound you with questions, but all information helps! Also if you happen to still have a copy of the project missing the text (not the backup), you might take a look into the Files/Docs folder and make sure that your missing text files aren’t actually there, just not showing up in the project. They’ll all just have numbers for the file names, but Windows’ search tool should let you look for specific text that went missing.

Ok, I will try to answer as best I can:

  1. Yes, this is a laptop, not part of a network
  2. I save a copy on my C drive, one on my external drive and occasionally upload to MS Skydrive. In addition, I compile after every writing session and save that document in all three locations as well.
  3. Drive format? Sorry, but that info is way above my pay grade (means I’m not that techie and I don’t know)
  4. Save after inactivity is set to 2 seconds (must be the default, I have not changed it)
  5. No sync or backup services (I normally just drag and drop the entire Scrivener folder or just the project file from the laptop hard drive to the external drive.)
  6. Computer may have gone to sleep. I have a bad habit of closing the lid and putting it away and that sends it to sleep mode.

Everything has been restored nicely, but to add to this thread, I did some writing earlier today, did my normal back up routine (I don’t think I missed anything) and when I opened the project, both the back up and the C drive copy were older than what I had saved. This could have been an overwrite error on my part and thankfully the compiled version was intact, so no harm, no foul.

Love the "Back up to… " feature… wasn’t aware of it before I started reading this thread. That will make things easier. Still a huge fan and Scrivener is often the topic of conversation in my writer’s group. BTW, if you ever need someone in the Los Angeles area to run classes on using Scrivener, I have a teaching background, including curriculum development. Keep up the good work, but don’t forget to get some sleep. :wink:

and finally… MM, what in the world is your avatar all about? I can’t seem to make sense of it. (Yeah, probably not the most important question of the day)

Hi Ed,

Thanks for the info. No problem on the complicated ones. ;0) If I could root into it a little further, though:

Admin account–This is just for on your computer, when you log into Windows. With an administrator account, you’re able to install programs wherever you want (e.g. to Program Files!) and change system files, etc., whereas with a standard account you’ll be told you don’t have the appropriate permissions. You should be able to see which it is if you go into the account settings via the control panel. Not a huge deal, but there you are.

Saving the project–I’m assuming you mean that you keep the active project on your C: drive and work from there, then save backups in one way or another to the other locations. Do you do that via the Backup Project To… command or do you just copy the .scriv folder after you’ve closed the project? Since your backups weren’t subject to the data loss that your original was, I’m working off the idea that you must’ve made a backup before closing, then propagated the backup to the other locations, but if that’s wrong please correct me. It will help pinpoint when the data disappeared.

Step-by-step details on your backup routine would help figure this out too. It sounds as though you may have been accidentally working off the wrong project, which is common enough if you save the same file to multiple locations. What exactly was the difference in the files–are you saying that various changes you had made weren’t there or that the modified dates on the projects were off?

Glad in any case of course that you’ve always had a backup of some sort to restore from!

It’s a Portal 2 designer turret! :slight_smile:

Yes, I have admin permission. I normally work from the C drive, then copy everything over to the external drive. When I execute “Back up to…” I have folders on both C and external and backup to both. The exception to this is when I’m using my computer at work (which happily, now has a copy of Scrivener on it, love the drag and drop install ability). I save to the external drive, then copy everything back on to the C drive when I get home. I know it sounds crazy, but I always compare date/time stamps before I overwrite.

The problem was that both copies were missing info that I had typed, but they didn’t match, which is very odd considering that I almost always overwrite everything to the same copy. If nothing else, beta testing teaches us good habits, hopefully not at too great a price.

Loved the turret video, sounds like a game that would completely derail my writing efforts. :laughing: