Official way to reset single font choice to default?

Other than resetting all preferences or loading a theme, is there a standard way in macOS or Scrivener (keyboard shortcut etc.) to reset a single font to its default value? I’m talking about UI fonts like those here:

I suspect it’s super simple or explained ten times in the manual, so if you want me to feel really dumb, that’s your chance.

This will reset all:

I know. That was not my question.

What is the question then? Which font? Clicking the font name there (where you were) allows you to change just that font, its size, and type. I added the defaults button in case you wanted to go all the way back and start fresh.

“Other than resetting all preferences or loading a theme, is there a standard way in macOS or Scrivener (keyboard shortcut etc.) to reset a single font to its default value?”

Potentially any font for various UI elements in the Scrivener preferences. But not all of them at the same time. Just pick one.

Yes, thanks for taking the time. As stated in my first post, I’m aware of this method, but that’s not what I’m looking for.

There’s no specific button for restoring the factory default; you’d need to click into the font field and reset the font from there. The “System Font” and variants are available from the bottom of the font panel.

1 Like

And we have a winner! :smile: Damn. I’ve never even noticed this dropdown menu down there. Thanks, that’s exactly what I was looking for.

ADD: Now I remember why. It’s missing in some places. e.g. for the Scrivenings title font:

@MimeticMouton It’s supposed to be there in this specific instance, right? (I see the dropdown in most of the other [Scrivener] font dialogs.)

Does anyone else experience the same problem (missing dropdown menu for the system fonts, in this specific case for Scrivenings titles)? It’s there in other font dialogs. Is it a bug, or is my installation corrupted? Scrivener 3.2.3 on macOS 12.6.

It’s not just you. I’m also using macOS 12.6 and Scrivener 3.2.3. I also do not have that systems font drop-down like I see in other font options.

Edited to add: I can’t speak to whether this particular panel should have that drop-down, however.

I’m hoping @MimeticMouton or @AmberV might be able to answer if that’s expected behavior for that panel.

1 Like

Thanks, how do we proceed from here? Should I file a bug report?

That option is available to settings that would configure “interface” as opposed to “content” (if we don’t split hairs too much about it). Apple does not wish for their UI fonts to be used outside of the UI, such as in Scrivenings titles or for default writing text, so you won’t find that setting anywhere that sets up what we might more traditionally think of as formatting. Synopsis card text though? Sure, that’s UI.

1 Like

Thanks for the clarification!

Okay, but it is the default font for Scrivenings titles. Unless one changes it out of curiosity and then there’s no reasonable way back. :thinking:

It shouldn’t be, if so that’s a bug. The default is Palatino 22pt, to match the default body text formatting.

1 Like

Sounds in line with your explanation. But for some weird reason it ended up like that:

I’m pretty sure I didn’t change it to this setting, because (unlike my stupidity that started this thread) there’s literally no way to do it. Weird.

That looks like some kind of fall-back behaviour, note how it is 12pt as well, which would be odd for a heading (smaller even than the default text size). I don’t know how to get to that point though.

1 Like

I suspect it was at some point set to a font no longer installed (I’m speculating) and now panicked back to that one. Or so.

… which would be a workaround of sorts, I guess. :face_with_raised_eyebrow:

1 Like

True, if that’s the desired result. But it looks like that’s not the intended default font (which I assumed and was clearly wrong).

Now the only mystery remains: Why does Scrivener fall back to a “UI font” where it should be a “text font” (like Helvetica?).